bitlbee-facebook-1.1.2-1.4.x86_64.rpm


Advertisement

Description

bitlbee-facebook - The Facebook protocol plugin for bitlbee

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename bitlbee-facebook-1.1.2-1.4.x86_64.rpm
Package name bitlbee-facebook
Package version 1.1.2
Package release 1.4
Package architecture x86_64
Package type rpm
Category Productivity/Networking/IRC
Homepage https://github.com/bitlbee/bitlbee-facebook
License GPL-2.0
Maintainer -
Download size 66.45 KB
Installed size 175.19 KB
The Facebook protocol plugin for bitlbee. This plugin uses the Facebook Mobile API.

Alternatives

Package Version Architecture Repository
bitlbee-facebook-1.1.2-1.4.i586.rpm 1.1.2 i586 openSUSE Oss
bitlbee-facebook - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libjson-glib-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
bitlbee-facebook = 1.1.2-1.4
bitlbee-facebook(x86-64) = 1.1.2-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package bitlbee-facebook-1.1.2-1.4.x86_64.rpm
Source Package bitlbee-facebook-1.1.2-1.4.src.rpm

Install Howto

Install bitlbee-facebook rpm package:

# zypper install bitlbee-facebook

Files

Path
/usr/lib64/bitlbee/facebook.so
/usr/share/doc/packages/bitlbee-facebook/COPYING
/usr/share/doc/packages/bitlbee-facebook/ChangeLog
/usr/share/doc/packages/bitlbee-facebook/README

Changelog

2017-09-16 - tampakrap@opensuse.org
- Version bump 1.1.2
- Fix "Failed to read thrift" with unknown fields in /t_p payload
- Fix rare login hang/timeout when the last page of contacts is empty
2017-04-20 - tampakrap@opensuse.org
- Version bump 1.1.1
Fixes one last issue to the server side changes from last week.
- Send orca-formatted user agent for all HTTP requests too. Fixes "Failed
to parse thread information" errors when joining channels.
This is in addition to the connection error fixes mentioned in the previous
release. Quoting from the previous release: "Fix connection errors after
facebook discontinued support for old versions of facebook messenger for
android. While most of the protocol implementation was already above that
version, there was a subtle change that broke fetching of sync_sequence_id,
and the previously empty MQTT user agent string is now considered an old
version too (#138)"
I waited a few days before releasing this to ensure things calm down,
hopefully it continues like this.
- Version 1.1.0
Long overdue release, with a year worth of changes. This is now the minimum
required version.
- Fix connection errors after facebook discontinued support for old versions
of facebook messenger for android. While most of the protocol
implementation was already above that version, there was a subtle change
that broke fetching of sync_sequence_id, and the previously empty MQTT user
agent string is now considered an old version too (#138)
- Fix receiving topic/groupchat membership events (#119)
- Fix creating channels, inviting, kicking members (#120)
- Fix setting channel topics (#121)
- Fix contacts pagination for accounts with more than 500 friends (#74)
- Fix chats with only two members including self, like the Marketplace ones
- Fix crash on some kinds of SSL connection failure (#82)
- Fix crash when glib is compiled with G_ENABLE_DEBUG
- Deduplicate echoes of sent messages (#76)
- Set a non-empty HTTP user agent for api/graphql queries, since the empty
user agent often gets flagged for suspicious activity (#108)
- Prevent disconnections due to contacts with incomplete profiles (#89)
- Prevent disconnections on invalid attachment errors (#73)
- Prevent disconnections when trying to join a chat after being kicked (#244)
- Use FetchContactsDeltaQuery to incrementally sync contacts. Uses less
traffic, can be done more often and fixes issues with non-friends (#116)
- Parse URL attachments generated by the android share feature (#97)
- Add mark_read_reply setting to only mark messages as read on reply (#69)
- Add support for the bitlbee 3.5 plugin information API (bitlbee 3.4 is
still supported by this version, but will be dropped in the next one)
- Improve url comparison to avoid showing urls twice on attachments
2016-08-12 - tampakrap@opensuse.org
- Initial commit

See Also

Package Description
bitlbee-mastodon-1.4.0-1.1.i586.rpm A Mastodon plugin for Bitlbee
bitlbee-mastodon-1.4.0-1.1.x86_64.rpm A Mastodon plugin for Bitlbee
bitlbee-steam-1.4.2-1.6.i586.rpm Steam protocol plugin for BitlBee
bitlbee-steam-1.4.2-1.6.x86_64.rpm Steam protocol plugin for BitlBee
bitmap-1.0.9-1.1.i586.rpm X bitmap editor and converter utilities
bitmap-1.0.9-1.1.x86_64.rpm X bitmap editor and converter utilities
bitstream-vera-fonts-1.10-315.10.noarch.rpm Bitstream Vera(tm) Truetype fonts
bittwist-2.0-2.5.i586.rpm A libpcap-based Ethernet packet generator
bittwist-2.0-2.5.x86_64.rpm A libpcap-based Ethernet packet generator
blacs-devel-headers-2.0.2-11.2.i586.rpm Development headers for BLACS
blacs-devel-headers-2.0.2-11.2.x86_64.rpm Development headers for BLACS
bladeRF-1.4.0-6.2.i586.rpm SDR radio receiver
bladeRF-1.4.0-6.2.x86_64.rpm SDR radio receiver
bladeRF-devel-1.4.0-6.2.i586.rpm Development files for libbladeRF
bladeRF-devel-1.4.0-6.2.x86_64.rpm Development files for libbladeRF
Advertisement
Advertisement