backintime-qt4-1.1.24-1.3.noarch.rpm


Advertisement

Description

backintime-qt4 - Back In Time Qt4 GUI

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename backintime-qt4-1.1.24-1.3.noarch.rpm
Package name backintime-qt4
Package version 1.1.24
Package release 1.3
Package architecture noarch
Package type rpm
Category Productivity/Archiving/Backup
Homepage https://github.com/bit-team/backintime
License GPL-2.0+
Maintainer -
Download size 85.00 KB
Installed size 293.55 KB
This package has a Qt4 GUI for backintime.

Alternatives

Package Version Architecture Repository
backintime-qt4-1.1.24-55.5.noarch.rpm 1.1.24 noarch Archiving Backup
backintime-qt4 - - -

Requires

Name Value
backintime = 1.1.24
dbus-1-python3 -
libnotify-tools -
polkit -
python3-qt4 -

Provides

Name Value
application() -
application(backintime-qt4-root.desktop) -
application(backintime-qt4.desktop) -
backintime-qt4 = 1.1.24-1.3
config(backintime-qt4) = 1.1.24-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package backintime-qt4-1.1.24-1.3.noarch.rpm
Source Package backintime-1.1.24-1.3.src.rpm

Install Howto

Install backintime-qt4 rpm package:

# zypper install backintime-qt4

Files

Path
/etc/dbus-1/
/etc/dbus-1/system.d/net.launchpad.backintime.serviceHelper.conf
/usr/bin/backintime-qt4
/usr/bin/backintime-qt4_polkit
/usr/share/applications/backintime-qt4-root.desktop
/usr/share/applications/backintime-qt4.desktop
/usr/share/backintime/plugins/notifyplugin.py
/usr/share/backintime/plugins/qt4plugin.py
/usr/share/backintime/plugins/usercallbackplugin.py
/usr/share/backintime/plugins/userscriptsplugin.py
/usr/share/backintime/qt4/app.py
/usr/share/backintime/qt4/icon.py
/usr/share/backintime/qt4/logviewdialog.py
/usr/share/backintime/qt4/messagebox.py
/usr/share/backintime/qt4/qt4systrayicon.py
/usr/share/backintime/qt4/qt4tools.py
/usr/share/backintime/qt4/restoredialog.py
/usr/share/backintime/qt4/serviceHelper.py
/usr/share/backintime/qt4/settingsdialog.py
/usr/share/backintime/qt4/snapshotsdialog.py
/usr/share/dbus-1/
/usr/share/dbus-1/system-services/net.launchpad.backintime.serviceHelper.service
/usr/share/doc/packages/backintime-qt4/AUTHORS
/usr/share/doc/packages/backintime-qt4/CHANGES
/usr/share/doc/packages/backintime-qt4/LICENSE
/usr/share/doc/packages/backintime-qt4/README.md
/usr/share/doc/packages/backintime-qt4/TRANSLATIONS
/usr/share/doc/packages/backintime-qt4/VERSION
/usr/share/doc/packages/backintime-qt4/copyright
/usr/share/man/man1/backintime-qt4.1.gz
/usr/share/polkit-1/
/usr/share/polkit-1/actions/net.launchpad.backintime.policy

Changelog

2017-11-18 - tejas.guruswamy@opensuse.org
- Update to upstream version 1.1.24
* fix critical bug: shell injection in notify-send (https://github.com/bit-team/backintime/issues/834)
* fix bug: stat free space for snapshot folder instead of backintime folder (https://github.com/bit-team/backintime/issues/733)
* backport bug fix: backintime root crontab doesn't run; missinng line-feed 0x0A on last line (https://github.com/bit-team/backintime/issues/781)
* backport bug fix: can't open files with spaces in name (https://github.com/bit-team/backintime/issues/552)
2017-05-15 - tejas.guruswamy@opensuse.org
- Remove rpmlintrc following security review
2017-04-20 - tejas.guruswamy@eopensuse.org
- Update to 1.1.20
* backport security fix: polkit CheckAuthorization: race condition in privilege authorization (CVE-2017-7572, boo#1032717)
- Don't store passwords given to polkit helper
* backintime-polkit_priv_downgrade.patch
- Backport security hardening measures (boo#1007723)
* backintime-security_hardening_backport.patch
- Fix Requires and BuildRequires
* No longer requires xterm
* Note: backintime requires python3-keyring (not py2), but not available in openSUSE yet
- Delete udev configuration files on uninstall
- Merge doc subpackage into main package
2016-10-29 - felibank@gmail.com
- Added a new script for launching backintime as root from desktop
(boo#1006356)
2016-01-12 - ronisbr@gmail.com
- Remove unnecessary patch that was already applied by upstream:
* backintime-1.1.10-AttributeError-About-Dialog.patch
- Remove the workaround for x-terminal-emulator. Upstream developed
a new dialog to avoid this problem.
- Version bump to 1.1.12.
Upstream changelog:
* Fix bug: remove x-terminal-emulator dependency (#515)
* Fix bug: AttributeError in About Dialog (#515)
2016-01-11 - ronisbr@gmail.com
- backintime-qt4 uses x-terminal-emulator to open a terminal with a
man page in the menus Help->Help and Help->Config File Help.
However, openSUSE does not have x-terminal-emulator, instead it
has xdg-terminal that does not work because it can only accept
one argument. Thus, the solution was to replace
x-terminal-emulator with xterm. Now, everything in the Help menu
is working properly.
2016-01-11 - ronisbr@gmail.com
- Remove unnecessary BuildRoot in spec file.
- Change package URL to https://github.com/bit-team/backintime .
- Add patch backintime-1.1.10-AttributeError-About-Dialog.patch to
fix upstream issue #515. For more information, see:
https://github.com/bit-team/backintime/issues/515
- Fix doc path so that the buttons Authors, Translations, and
License in About dialog work properly.

See Also

Package Description
backward-cpp-1.4-1.2.i586.rpm Stack trace printer for C++
backward-cpp-1.4-1.2.x86_64.rpm Stack trace printer for C++
backward-cpp-devel-1.4-1.2.i586.rpm Development files for backward-cpp
backward-cpp-devel-1.4-1.2.x86_64.rpm Development files for backward-cpp
baekmuk-bitmap-fonts-2.1-13.6.noarch.rpm Baekmuk Fonts, Bitmap Version
baekmuk-ttf-fonts-2.1-13.6.noarch.rpm Baekmuk Fonts, TrueType Version
baka-mplayer-2.0.4-3.2.i586.rpm A media player with UI using libmpv
baka-mplayer-2.0.4-3.2.x86_64.rpm A media player with UI using libmpv
ballerburg-1.2.0-1.1.i586.rpm Two players, two castles, and a hill in between
ballerburg-1.2.0-1.1.x86_64.rpm Two players, two castles, and a hill in between
baloo5-devel-5.57.0-1.1.i586.rpm Development package for baloo5
baloo5-devel-5.57.0-1.1.x86_64.rpm Development package for baloo5
baloo5-file-5.57.0-1.1.i586.rpm Filesearch components for Baloo Framework
baloo5-file-5.57.0-1.1.x86_64.rpm Filesearch components for Baloo Framework
baloo5-file-lang-5.57.0-1.1.noarch.rpm Translations for package baloo5
Advertisement
Advertisement