atkmm-devel-2.29.1-1.1.i586.rpm


Advertisement

Description

atkmm-devel - C++ Binding for the ATK library -- Development Files

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename atkmm-devel-2.29.1-1.1.i586.rpm
Package name atkmm-devel
Package version 2.29.1
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.gtkmm.org/
License LGPL-2.1-or-later
Maintainer -
Download size 49.13 KB
Installed size 218.90 KB
atkmm is the C++ binding for the ATK library.
This module is part of the GNOME C++ bindings effort.
This package provides all the necessary files for development with ATK
library's C++ bindings.

Alternatives

Package Version Architecture Repository
atkmm-devel-2.29.1-73.7.x86_64.rpm 2.29.1 x86_64 GNOME Next
atkmm-devel-2.29.1-73.7.i586.rpm 2.29.1 i586 GNOME Next
atkmm-devel-2.29.1-50.5.x86_64.rpm 2.29.1 x86_64 GNOME Factory
atkmm-devel-2.29.1-50.5.i586.rpm 2.29.1 i586 GNOME Factory
atkmm-devel-2.29.1-1.1.x86_64.rpm 2.29.1 x86_64 openSUSE Oss
atkmm-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libatkmm-2_30-1 >= 2.29.1
pkgconfig(atk) >= 1.18
pkgconfig(glibmm-2.60) >= 2.59.1

Provides

Name Value
atkmm-devel = 2.29.1-1.1
atkmm-devel(x86-32) = 2.29.1-1.1
pkgconfig(atkmm-2.30) = 2.29.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package atkmm-devel-2.29.1-1.1.i586.rpm
Source Package atkmm-2.29.1-1.1.src.rpm

Install Howto

Install atkmm-devel rpm package:

# zypper install atkmm-devel

Files

Path
/usr/include/atkmm-2.30/atkmm.h
/usr/include/atkmm-2.30/atkmm/action.h
/usr/include/atkmm-2.30/atkmm/component.h
/usr/include/atkmm-2.30/atkmm/document.h
/usr/include/atkmm-2.30/atkmm/editabletext.h
/usr/include/atkmm-2.30/atkmm/hyperlink.h
/usr/include/atkmm-2.30/atkmm/hypertext.h
/usr/include/atkmm-2.30/atkmm/image.h
/usr/include/atkmm-2.30/atkmm/implementor.h
/usr/include/atkmm-2.30/atkmm/init.h
/usr/include/atkmm-2.30/atkmm/noopobject.h
/usr/include/atkmm-2.30/atkmm/object.h
/usr/include/atkmm-2.30/atkmm/objectaccessible.h
/usr/include/atkmm-2.30/atkmm/range.h
/usr/include/atkmm-2.30/atkmm/relation.h
/usr/include/atkmm-2.30/atkmm/relationset.h
/usr/include/atkmm-2.30/atkmm/selection.h
/usr/include/atkmm-2.30/atkmm/stateset.h
/usr/include/atkmm-2.30/atkmm/streamablecontent.h
/usr/include/atkmm-2.30/atkmm/table.h
/usr/include/atkmm-2.30/atkmm/text.h
/usr/include/atkmm-2.30/atkmm/value.h
/usr/include/atkmm-2.30/atkmm/wrap_init.h
/usr/include/atkmm-2.30/atkmm/private/action_p.h
/usr/include/atkmm-2.30/atkmm/private/component_p.h
/usr/include/atkmm-2.30/atkmm/private/document_p.h
/usr/include/atkmm-2.30/atkmm/private/editabletext_p.h
/usr/include/atkmm-2.30/atkmm/private/hyperlink_p.h
/usr/include/atkmm-2.30/atkmm/private/hypertext_p.h
/usr/include/atkmm-2.30/atkmm/private/image_p.h
/usr/include/atkmm-2.30/atkmm/private/implementor_p.h
/usr/include/atkmm-2.30/atkmm/private/noopobject_p.h
/usr/include/atkmm-2.30/atkmm/private/object_p.h
/usr/include/atkmm-2.30/atkmm/private/objectaccessible_p.h
/usr/include/atkmm-2.30/atkmm/private/range_p.h
/usr/include/atkmm-2.30/atkmm/private/relation_p.h
/usr/include/atkmm-2.30/atkmm/private/relationset_p.h
/usr/include/atkmm-2.30/atkmm/private/selection_p.h
/usr/include/atkmm-2.30/atkmm/private/stateset_p.h
/usr/include/atkmm-2.30/atkmm/private/streamablecontent_p.h
/usr/include/atkmm-2.30/atkmm/private/table_p.h
/usr/include/atkmm-2.30/atkmm/private/text_p.h
/usr/include/atkmm-2.30/atkmm/private/value_p.h
/usr/lib/libatkmm-2.30.so
/usr/lib/atkmm-2.30/
/usr/lib/atkmm-2.30/include/atkmmconfig.h
/usr/lib/atkmm-2.30/proc/
/usr/lib/atkmm-2.30/proc/m4/convert.m4
/usr/lib/atkmm-2.30/proc/m4/convert_atk.m4
/usr/lib/pkgconfig/atkmm-2.30.pc

Changelog

2018-12-03 - bjorn.lie@gmail.com
- Update to version 2.29.1:
+ Build:
- Require C++17.
- Replace the Visual Studio project files with MSVC NMake
project files.
- Use glibmm-2.60 instead of glibmm-2.56.
- Change the ABI to atkmm-2.30.
- Replace pkgconfig(glibmm-2.58) with pkgconfig(glibmm-2.60)
BuildRequires.
- Drop pkgconfig(glibmm-2.60): Fixed upstream. Following this, also
drop libtool and mm-common as well as autogen.sh call, no longer
needed.
- Bump soname following upstream changes.
- Drop atkmm-glibmm-bump.patch: Fixed upstream.
2018-04-17 - dimstar@opensuse.org
- Export CXXFLAGS="-std=c++17" until upstream catches up. Required,
as libsigc++-3.0 moved to C++17.
2018-03-31 - bjorn.lie@gmail.com
- Add atkmm-glibmm-bump.patch, fix build with new glibmm2.
- Following the above, add libtool and mm-common BuildRequires and
pass autogen.sh as the patch touches the buildsystem.
- Also replace pkgconfig(glibmm-2.56) with pkgconfig(glibmm-2.58).
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2018-02-24 - luc14n0@linuxmail.org
- Update to version 2.27.1:
+ Change ABI to atkmm-2.28.
- Update '+' in GPL/LGPL License tags to '-or-later' and add GPL
version 2 and 3 to the preamble to comply with the copyrights.
- Update packages descriptions to show more explictly subpackages'
content.
- Drop unneeded standard BuildRoot tag declaration: RPM already
handles this itself.
- Point fdupes to the data directory under the build root instead
of the build root directly, which is a practice that must be
avoided.
- Rename shared library subpackage name to libatkmm-2_28-1 to
follow upstream change.
- Recommends the documentation subpackage.
2017-08-25 - zaitor@opensuse.org
- Update to version 2.25.4:
+ Build: Use glibmm-2.56 instead of glibmm-2.54. We have changed
the ABI name in glibmm.
+ Text: Plug memory leaks in get_text_vfunc() and
get_selection_vfunc(). These vfuncs shall delete the returned
character array after it has been copied to a Glib::ustring
(bgo#783360).
2017-05-20 - zaitor@opensuse.org
- Update to version 2.25.3:
+ Use C++11 enum classes instead of old-style enums, and put some
enums inside relevant class declarations:
- Relation: Change RelationType to Relation::Type.
- Text: Move enums into the class.
+ Build: Windows: Visual Studio builds: Update glibmm ABI
version.
- Changes from version 2.25.2:
+ Build: Use glibmm-2.54 instead of glibmm-2.52.
+  (Murray Cumming)
+ Replace uses of Glib::ArrayHandle<> and Glib::SListHandle<>
with vector.
+ Visual Studio: Require Visual Studio 2017.
2016-12-05 - jengelh@inai.de
- Rectify rpm groups.
2016-12-05 - dimstar@opensuse.org
- Update to version 2.25.1:
+ This is the first release of the atkmm-2.26 API/ABI.
+ Require C++14.
+ Use glibmm-2.52 instead of glibmm-2.4.
+ Fix silent builds (bgo#768797).
- Rename libatkmm-1_6-1 to libatkmm-2_26-1, following upstreams
soname change.
- Remove outdated condition for openSUSE 11.2 (make the doc package
unconditionally noarch).
2016-04-15 - idonmez@suse.com
- Update to GNOME 3.20  Fate#318572

See Also

Package Description
atkmm-devel-32bit-2.29.1-1.1.x86_64.rpm C++ Binding for the ATK library -- Development Files
atkmm-doc-2.29.1-1.1.noarch.rpm C++ Binding for the ATK library -- Documentation
atkmm1_6-devel-2.28.0-1.1.i586.rpm C++ Binding for the ATK library
atkmm1_6-devel-2.28.0-1.1.x86_64.rpm C++ Binding for the ATK library
atkmm1_6-devel-32bit-2.28.0-1.1.x86_64.rpm C++ Binding for the ATK library
atkmm1_6-doc-2.28.0-1.1.noarch.rpm C++ Binding for the ATK library
atlascpp-devel-0.6.4-1.2.i586.rpm Development files for the Atlas protocol C++ implementation
atlascpp-devel-0.6.4-1.2.x86_64.rpm Development files for the Atlas protocol C++ implementation
atmel-firmware-1.3-164.7.noarch.rpm Firmware for Atmel at76c50x Wireless Network Chips
atomiks-1.0.4.1-1.10.i586.rpm A faithful remake of, and a tribute to, Atomix, a classic puzzle game
atomiks-1.0.4.1-1.10.x86_64.rpm A faithful remake of, and a tribute to, Atomix, a classic puzzle game
atomix-3.32.0-1.1.i586.rpm A puzzle game where you move atoms to build a molecule
atomix-3.32.0-1.1.x86_64.rpm A puzzle game where you move atoms to build a molecule
atomix-lang-3.32.0-1.1.noarch.rpm Translations for package atomix
atool-0.39.0-4.2.noarch.rpm Commandline Tool for Managing File Archives of various Types
Advertisement
Advertisement