appindicator-sharp-devel-12.10.1+bzr20170215-4.1.i586.rpm


Advertisement

Description

appindicator-sharp-devel - Development files for libappindicator-sharp

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename appindicator-sharp-devel-12.10.1+bzr20170215-4.1.i586.rpm
Package name appindicator-sharp-devel
Package version 12.10.1+bzr20170215
Package release 4.1
Package architecture i586
Package type rpm
Category Development/Libraries/Other
Homepage https://launchpad.net/libappindicator
License LGPL-2.0-only AND LGPL-3.0-only AND GPL-3.0-only
Maintainer -
Download size 20.42 KB
Installed size 33.85 KB
This package contains the development files for the appindicator-sharp library.

Alternatives

Package Version Architecture Repository
appindicator-sharp-devel-12.10.1+bzr20170215-4.1.x86_64.rpm 12.10.1+bzr20170215 x86_64 openSUSE Oss
appindicator-sharp-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
appindicator-sharp = 12.10.1+bzr20170215
pkgconfig(gtk-sharp-2.0) -

Provides

Name Value
appindicator-sharp-devel = 12.10.1+bzr20170215-4.1
appindicator-sharp-devel(x86-32) = 12.10.1+bzr20170215-4.1
pkgconfig(appindicator-sharp-0.1) = 12.10.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package appindicator-sharp-devel-12.10.1+bzr20170215-4.1.i586.rpm
Source Package libappindicator-12.10.1+bzr20170215-4.1.src.rpm

Install Howto

Install appindicator-sharp-devel rpm package:

# zypper install appindicator-sharp-devel

Files

Path
/usr/lib/pkgconfig/appindicator-sharp-0.1.pc
/usr/share/doc/packages/appindicator-sharp-devel/README
/usr/share/licenses/appindicator-sharp-devel/COPYING
/usr/share/licenses/appindicator-sharp-devel/COPYING.LGPL.2.1

Changelog

2019-01-13 - ximi.obs@gmail.com
- Changed the activate-support patch to signal an "activate-event"
so users can create callbacks themselves.
Original patch from Yichao Yu <yyc1992@gmail.com>.
2018-03-10 - dimstar@opensuse.org
- Add libappindicator-no-Werror.patch: the libappindicator code is
aging and is not keeping up well with the moving world around it.
2017-09-04 - dimstar@opensuse.org
- Disable building of -doc subpackage (source not compatible with
gtk-doc 1.26 - and the doc is available online anyway):
+ Remove gtk-doc BuildRequires.
+ Replace --enable-gtk-doc configure parameter with
- -disable-gtk-doc,
+ Drop the -doc subpackage.
2017-04-28 - jengelh@inai.de
- Rename %soname to %sover to better reflect its purpose.
- Update summaries.
- Remove redundant pkgconfig() reqiures; these are already
autodiscovered.
2017-04-19 - sor.alexei@meowr.ru
- Update to version 12.10.1+bzr20170215 (changes since
12.10.1+bzr20141110):
* Handle watcher service appearing and disappearing.
* Make test-simple-app really working.
* Fix icon and theme paths when running in $SNAP environment
(lp#1600136).
* Do not emit label changes when guide is still empty.
* Do not append the snap prefix if the icon is saved in a well
known readable path.
- Add libappindicator-activate-support.patch: Open menu on the
left-click action (lp#1403449).
- Rename python-appindicator to python2-appindicator.
2016-07-07 - t.gruner@katodev.de
- Allow building with mono support in case without mono is set
2016-06-13 - sor.alexei@meowr.ru
- Little spec cleanup.
2015-05-05 - sor.alexei@meowr.ru
- Update to 12.10.1+bzr20141110:
* scroll-event: change parameter to the right type.
- Rebase 0001_Fix_mono_dir.patch.
- Remove no-deprecated.patch: merged upstream.
- Remove dont-build-examples.patch: fixed upstream.
- Minor spec cleanup.
2015-03-05 - schwab@suse.de
- Allow building without mono support
2014-03-11 - p.drouand@gmail.com
- Fix appindicator-sharp require in appindicator-sharp-devel

See Also

Package Description
appmenu-gtk-module-common-0.7.1-1.2.noarch.rpm Common files for appmenu-gtk{2,3}-module
appmenu-gtk2-module-0.7.1-1.2.i586.rpm GtkMenuShell D-Bus exporter (GTK+ 2)
appmenu-gtk2-module-0.7.1-1.2.x86_64.rpm GtkMenuShell D-Bus exporter (GTK+ 2)
appmenu-gtk3-module-0.7.1-1.2.i586.rpm GtkMenuShell D-Bus exporter (GTK+ 3)
appmenu-gtk3-module-0.7.1-1.2.x86_64.rpm GtkMenuShell D-Bus exporter (GTK+ 3)
appmenu-qt-0.2.7~daily13.05.02-3.13.i586.rpm Application Menu for Qt
appmenu-qt-0.2.7~daily13.05.02-3.13.x86_64.rpm Application Menu for Qt
appmenu-registrar-0.7.1-1.2.i586.rpm Canonical AppMenu Registrar Provider
appmenu-registrar-0.7.1-1.2.x86_64.rpm Canonical AppMenu Registrar Provider
appres-1.0.5-1.3.i586.rpm Utility to list the resource database of an X application
appres-1.0.5-1.3.x86_64.rpm Utility to list the resource database of an X application
appstream-glib-0.7.14+0-1.2.i586.rpm AppStream Abstraction Library
appstream-glib-0.7.14+0-1.2.x86_64.rpm AppStream Abstraction Library
appstream-glib-devel-0.7.14+0-1.2.i586.rpm Development files for the AppStream abstraction library
appstream-glib-devel-0.7.14+0-1.2.x86_64.rpm Development files for the AppStream abstraction library
Advertisement
Advertisement