apcupsd-gui-3.14.14-7.4.i586.rpm


Advertisement

Description

apcupsd-gui - APC UPS Monitor GUI (for APC UPSs)

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename apcupsd-gui-3.14.14-7.4.i586.rpm
Package name apcupsd-gui
Package version 3.14.14
Package release 7.4
Package architecture i586
Package type rpm
Category Hardware/UPS
Homepage http://www.apcupsd.com/
License GPL-2.0-only
Maintainer -
Download size 68.00 KB
Installed size 146.35 KB
Controls and monitors the status of an APC UPS under Linux. Allows your
computer or server to run for a specified length of time on UPS power
then executes a controlled shutdown in the case of an extended power
failure. Find APC on the Internet at http://www.apc.com/.
APC also made their PowerChute plus available for download at
http://www.apc.com/tools/download/.

Alternatives

Package Version Architecture Repository
apcupsd-gui-3.14.14-118.21.x86_64.rpm 3.14.14 x86_64 Hardware
apcupsd-gui-3.14.14-118.21.i586.rpm 3.14.14 i586 Hardware
apcupsd-gui-3.14.14-7.4.x86_64.rpm 3.14.14 x86_64 openSUSE Oss
apcupsd-gui - - -

Requires

Name Value
apcupsd = 3.14.14
libX11.so.6 -
libc.so.6(GLIBC_2.4) -
libgconf-2.so.4 -
libgdk-x11-2.0.so.0 -
libgdk_pixbuf-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgthread-2.0.so.0 -
libgtk-x11-2.0.so.0 -
libpango-1.0.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -

Provides

Name Value
apcupsd-gui = 3.14.14-7.4
apcupsd-gui(x86-32) = 3.14.14-7.4
application() -
application(gapcmon.desktop) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package apcupsd-gui-3.14.14-7.4.i586.rpm
Source Package apcupsd-3.14.14-7.4.src.rpm

Install Howto

Install apcupsd-gui rpm package:

# zypper install apcupsd-gui

Files

Path
/usr/bin/gapcmon
/usr/share/applications/gapcmon.desktop
/usr/share/pixmaps/apcupsd.png
/usr/share/pixmaps/charging.png
/usr/share/pixmaps/gapc_prefs.png
/usr/share/pixmaps/onbatt.png
/usr/share/pixmaps/online.png
/usr/share/pixmaps/unplugged.png

Changelog

2018-03-21 - tchvatal@suse.com
- Do not use path based dependency but use normal package name
2018-03-15 - tchvatal@suse.com
- Drop support for < sle12, also removes patch:
* apcupsd-pm-utils.patch
- Drop intitscript
- Format with spec-cleaner
- Use license macros instead of %doc macros
2017-12-11 - crrodriguez@opensuse.org
- BuildRequire pkgconfig(x11) not xorg-x11-devel
2017-11-23 - rbrown@suse.com
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)
2017-08-31 - dimstar@opensuse.org
- Pass --with-distname=, based on the values of ID_LIKE from
/etc/os-release to configure. Since the removal of
/etc/SuSE-release, the build system is no longer able to identify
us building on a SUSE system. Let's help it.
2016-12-08 - manfred99@gmx.ch
- update apcupsd-httpd.conf to work with apache2 >= 2.4. Entries
are commented out, so this file acts as example only. bsc#950950
2016-05-31 - manfred99@gmx.ch
- Update to apcupsd version 3.14.14
* win32: Fix missing DLLs when installing only apctray
* Fixes for socket error handling. Resolves apcaccess crash when connection
fails as well as several other theoretical issues.
* MODBUS/USB error handling (COMMLOST) improvements for faulty USB links
* Fix hiddev binding when usbfs is mounted on /dev/bus/usb instead of
/proc/bus/usb. This is necessary for switching between MODBUS/USB and
USB/HID on Linux.
* Update GPLv2 text and FSF address to match current versions from FSF.
* Various fixes for potential issues suggested by Coverity Scan
* MacOS X port support for El Capitan System Integrity Protection (SIP)
aka "rootless"
* Fix shutdown failure on Windows when UPSNAME includes spaces
* Fix building bsd-usb driver
(This was broken when modbus-usb support was added.)
* Add status display for output current as well as apparent power
- fix firewall rule installation in spec file
- drop BuildRequires: net-snmp-devel, net-snmp was dropped in favour of snmplite
- drop installation of own automake files for ppc64, not needed any more
- Removed patches, fixed in upstream:
* apcupsd-3.14.6-undef-MIB-for-new-net-snmp.diff
* fix-fsf-adress.patch
* apcupsd-3.14.1-cloexec.patch
* apcupsd-gpp.patch
- Removed patch, not needed as it builds on all supported arches,
and not linking against libstdc++ is done on purpose:
* apcupsd-3.14.8-cxxld.patch
2015-07-13 - tchvatal@suse.com
- Ensure locfile is properly set bnc#929444
2015-04-18 - matwey.kornilov@gmail.com
- Move *.cgi scripts to apcupsd-cgi package (fix boo#925886)

See Also

Package Description
apfel-devel-3.0.3-2.3.i586.rpm Development files for Apfel, a PDF Evolution Library
apfel-devel-3.0.3-2.3.x86_64.rpm Development files for Apfel, a PDF Evolution Library
apfel-doc-3.0.3-2.3.i586.rpm Documentation for APFEL, a PDF evolution library
apfel-doc-3.0.3-2.3.x86_64.rpm Documentation for APFEL, a PDF evolution library
apg-2.2.3-1.7.i586.rpm Tool Set for Random Password Generation
apg-2.2.3-1.7.x86_64.rpm Tool Set for Random Password Generation
apiguardian-1.0.0-1.1.noarch.rpm API Guardian Java annotation
apiguardian-javadoc-1.0.0-1.1.noarch.rpm Javadoc for apiguardian
apparmor-abstractions-2.13.2-8.1.noarch.rpm AppArmor abstractions and directory structure
apparmor-docs-2.13.2-8.1.noarch.rpm AppArmor Documentation package
apparmor-parser-2.13.2-8.1.i586.rpm AppArmor userlevel parser utility
apparmor-parser-2.13.2-8.1.x86_64.rpm AppArmor userlevel parser utility
apparmor-parser-lang-2.13.2-8.1.noarch.rpm Translations for package apparmor
apparmor-profiles-2.13.2-8.1.noarch.rpm AppArmor profiles that are loaded into the apparmor kernel module
apparmor-rpm-macros-1.0-4.2.noarch.rpm RPM macros used to setup apparmor profiles
Advertisement
Advertisement