apache2-mod_uwsgi-2.0.18-2.1.i586.rpm


Advertisement

Description

apache2-mod_uwsgi - uWSGI Module for Apache 2.0

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename apache2-mod_uwsgi-2.0.18-2.1.i586.rpm
Package name apache2-mod_uwsgi
Package version 2.0.18
Package release 2.1
Package architecture i586
Package type rpm
Category Productivity/Networking/Web/Servers
Homepage https://uwsgi-docs.readthedocs.io/en/latest/
License Apache-2.0 AND GPL-2.0-only WITH GCC-exception-2.0
Maintainer -
Download size 32.79 KB
Installed size 21.65 KB
uWSGI is a self-healing application container server coded in pure C.
This package contains an Apache 2.0 module for uWSGI.

Alternatives

Package Version Architecture Repository
apache2-mod_uwsgi-2.0.18-2.1.x86_64.rpm 2.0.18 x86_64 openSUSE Oss
apache2-mod_uwsgi - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
uwsgi = 2.0.18

Provides

Name Value
apache2-mod_uwsgi = 2.0.18-2.1
apache2-mod_uwsgi(x86-32) = 2.0.18-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package apache2-mod_uwsgi-2.0.18-2.1.i586.rpm
Source Package uwsgi-2.0.18-2.1.src.rpm

Install Howto

Install apache2-mod_uwsgi rpm package:

# zypper install apache2-mod_uwsgi

Files

Path
/usr/lib/apache2/mod_uwsgi.so

Changelog

2019-03-16 - James Oakley <jfunk@funktronics.ca>
- Add patch uwsgi-2.0.18-postgresql-config.patch to use pkg-config
instead of pg_config as it was removed in postgres11-devel
2019-02-09 - Michael Ströder <michael@stroeder.com>
- HTTPS URL for source
- update to upstream release 2.0.18
* Fixed support for Python 3.7
* Allow to use autoport (socket :0) with custom socket backlog
* pyuwsgi ported to python3
* pyuwsgi packages fixes
* pyuwsginossl build configuration for building pyuwsgi without ssl support
* Fix unix socket inheritance after reload on FreeBSD
* Fix crashes with --wsgi-env-behavior=holy (#1950)
* Fix invalid free in python plugin (#1942)
* Fix compilation warnings with gcc-8 (#1819)
* Fix spooler python references
* Don't generate build warnings in systemd_logger
* Fix segmentation fault during worker shutdown (#1651)
2018-08-02 - michael@stroeder.com
- Trimmed package description
2018-07-23 - jfunk@funktronics.ca
- Work around missing include dir in glusterfs pkg-config
2018-07-09 - michael@stroeder.com
- update to upstream release 2.0.17.1
* Fixed memory leak in HTTPS_CLIENT_CERTIFICATE
* TLSv1 is now disabled by default
* Improved daemons throttle system
* Add ?secs? log formatting variable
* Improved snprintf() usage to be OpenBSD-friendly
* Improved glibc crypt/crypt_r management
* Fixed websocket pong timeout check
* Add the ?License? classifier to setup.py
* Add support for php user.ini
* Official support for Python 3.7
2018-05-31 - jfunk@funktronics.ca
- Don't create a /run directory for Apache on startup. It fails if Apache is
not installed and sockets are defined per-application anyway (bnc#1082002)
- Fix broken build dependency on Leap 15
2018-04-24 - michael@stroeder.com
- Require Apache 2.4.33 for Leap 15 and Tumbleweed
because otherwise mod_proxy_uwsgi is not available (bsc#1090695)
2018-04-18 - guillaume.gardet@opensuse.org
- Handle aarch64 arch
2018-04-16 - jfunk@funktronics.ca
- Disable apache2-mod_proxy_uwsgi on Leap 15 since upstream Apache includes
the module now
2018-04-16 - jfunk@funktronics.ca
- Update to 2.0.17:
* The Emperor throttling subsystem does not make use anymore of blocking
functions, like usleep(), this should fix stats serving and should improve
vassals startup time
* [Security/PHP] enforce DOCUMENT_ROOT check when using --php-docroot to
avoid directory traversal (Marios Nicolaides)
* added --shutdown-sockets to improve graceful shutdowns (Andrew Wason)

See Also

Package Description
apache2-mod_wsgi-4.6.5-1.1.i586.rpm A WSGI interface for Python web applications in Apache
apache2-mod_wsgi-4.6.5-1.1.x86_64.rpm A WSGI interface for Python web applications in Apache
apache2-mod_wsgi-python3-4.6.5-1.1.i586.rpm A WSGI interface for Python3 web applications in Apache
apache2-mod_wsgi-python3-4.6.5-1.1.x86_64.rpm A WSGI interface for Python3 web applications in Apache
apache2-prefork-2.4.39-1.1.i586.rpm Apache 2 "prefork" MPM (Multi-Processing Module)
apache2-prefork-2.4.39-1.1.x86_64.rpm Apache 2 "prefork" MPM (Multi-Processing Module)
apache2-utils-2.4.39-1.1.i586.rpm Apache 2 utilities
apache2-utils-2.4.39-1.1.x86_64.rpm Apache 2 utilities
apache2-worker-2.4.39-1.1.i586.rpm Apache 2 worker MPM (Multi-Processing Module)
apache2-worker-2.4.39-1.1.x86_64.rpm Apache 2 worker MPM (Multi-Processing Module)
apcupsd-3.14.14-7.4.i586.rpm APC UPS Daemon (Powerful Daemon for APC UPSs)
apcupsd-3.14.14-7.4.x86_64.rpm APC UPS Daemon (Powerful Daemon for APC UPSs)
apcupsd-cgi-3.14.14-7.4.i586.rpm Web interface for apcupsd
apcupsd-cgi-3.14.14-7.4.x86_64.rpm Web interface for apcupsd
apcupsd-gui-3.14.14-7.4.i586.rpm APC UPS Monitor GUI (for APC UPSs)
Advertisement
Advertisement