apache2-mod_nss-1.0.18-1.2.x86_64.rpm


Advertisement

Description

apache2-mod_nss - SSL/TLS module for the Apache HTTP server

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename apache2-mod_nss-1.0.18-1.2.x86_64.rpm
Package name apache2-mod_nss
Package version 1.0.18
Package release 1.2
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Web/Servers
Homepage https://pagure.io/mod_nss
License Apache-2.0
Maintainer -
Download size 113.17 KB
Installed size 347.87 KB
The mod_nss module provides strong cryptography for the Apache Web
server via the Secure Sockets Layer (SSL) and Transport Layer
Security (TLS) protocols using the Network Security Services (NSS)
security library.

Alternatives

Package Version Architecture Repository
apache2-mod_nss-1.0.18-75.14.x86_64.rpm 1.0.18 x86_64 Apache Modules
apache2-mod_nss-1.0.18-21.11.x86_64.rpm 1.0.18 x86_64 Mozilla
apache2-mod_nss-1.0.18-21.11.i586.rpm 1.0.18 i586 Mozilla
apache2-mod_nss-1.0.18-1.2.i586.rpm 1.0.18 i586 openSUSE Oss
apache2-mod_nss - - -

Requires

Name Value
/bin/bash -
/usr/bin/perl -
apache2 >= 2.2.12
apache_mmn_20120211 -
findutils -
iproute2 -
libc.so.6(GLIBC_2.14)(64bit) -
libnspr4.so()(64bit) -
libnss3.so()(64bit) -
libnss3.so(NSS_3.10)(64bit) -
libnss3.so(NSS_3.10.2)(64bit) -
libnss3.so(NSS_3.11.7)(64bit) -
libnss3.so(NSS_3.12)(64bit) -
libnss3.so(NSS_3.2)(64bit) -
libnss3.so(NSS_3.3)(64bit) -
libnss3.so(NSS_3.4)(64bit) -
libnss3.so(NSS_3.5)(64bit) -
libnss3.so(NSS_3.6)(64bit) -
libnss3.so(NSS_3.9)(64bit) -
libnss3.so(NSS_3.9.2)(64bit) -
libplc4.so()(64bit) -
libssl3.so()(64bit) -
libssl3.so(NSS_3.12.6)(64bit) -
libssl3.so(NSS_3.14)(64bit) -
libssl3.so(NSS_3.2)(64bit) -
libssl3.so(NSS_3.4)(64bit) -
libssl3.so(NSS_3.7.4)(64bit) -
mozilla-nss >= 3.25
mozilla-nss-tools -
suse_maintenance_mmn_0 -

Provides

Name Value
apache2-mod_nss = 1.0.18-1.2
apache2-mod_nss(x86-64) = 1.0.18-1.2
config(apache2-mod_nss) = 1.0.18-1.2
libmodnss.so()(64bit) -
mod_nss -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package apache2-mod_nss-1.0.18-1.2.x86_64.rpm
Source Package apache2-mod_nss-1.0.18-1.2.src.rpm

Install Howto

Install apache2-mod_nss rpm package:

# zypper install apache2-mod_nss

Files

Path
/etc/apache2/listen_nss.conf
/etc/apache2/conf.d/mod_nss.conf
/etc/apache2/mod_nss.d/cert9.db
/etc/apache2/mod_nss.d/install.log
/etc/apache2/mod_nss.d/key4.db
/etc/apache2/mod_nss.d/pkcs11.txt
/etc/apache2/vhosts.d/vhost-nss.template
/usr/lib64/apache2/mod_nss.so
/usr/sbin/gencert
/usr/sbin/mod_nss_migrate.pl
/usr/sbin/nss_pcache
/usr/share/doc/packages/apache2-mod_nss/README
/usr/share/doc/packages/apache2-mod_nss/README-SUSE.txt
/usr/share/doc/packages/apache2-mod_nss/mod_nss.html
/usr/share/licenses/apache2-mod_nss/LICENSE

Changelog

2018-12-05 - Vít?zslav ?í?ek <vcizek@suse.com>
- Update to 1.0.18
* Initial support for new mod_proxy function ssl_engine_set
* Fix some warnings from clang
2018-03-27 - vcizek@suse.com
- Update to 1.0.17
* Add TLSv1.3 support
* Update documentation for TLS 1.3
* Add TLS 1.3 support to the cipher tests
* PEP-8 fixups
* Change the default certificate database format to SQLite.
2018-03-19 - vcizek@suse.com
- Use fixed upstream 1.0.16 tarball
* https://pagure.io/mod_nss/issue/44
2018-03-19 - vcizek@suse.com
- Update to 1.0.16
* Fix up some broken cipher strings from a bad merge
- adjust distro detection, Tumbleweed has NSS 3.35, Leap 15 has 3.34
- drop 0001-Fix-up-some-broken-cipher-strings-from-a-bad-merge.patch
(upstream)
2018-03-08 - vcizek@suse.com
- Since the update to NSS 3.35, the default NSS certificate
database format changed from Berkley DB to SQLite
- use %license tag
2018-03-07 - vcizek@suse.com
- Update to 1.0.15
* Try to auto-detect the NSS database format if not specified
* Update nss_pcache.8 man page to drop directory and prefix
* When a token is configured in password file only authenticate once
* Return an error when NSSPassPhraseDialog is invalid
* Move 3DES ciphers down from HIGH to MEDIUM to match OpenSSL 1.0.2k+
* Add -Werror=implicit-function-declaration to CFLAGS
* Handle group membership when testing for file permissions
* NSS system-wide policy now disables SSLv3, don't use it in tests
* Add missing error messages for libssl errors
* Fix doc typo in SSL_[SERVER|CLIENT]_SAN_IPaddr env variable name
* When including additional test config use specific extension
* Fix the TLS Session ID cache
* Make an invalid protocol setting fatal
* Don't use same NSS db in nss_pcache as mod_nss, use NSS_NoDB_Init()
* Add info log message when FIPS is enabled
* Add AES-256 and drop DES, CAST128, SKIPJACK as wrapping key types
* Fix removal of CR from PEM certificates
* Add OCSP caching and timeout tuning knobs
* Check the NSS database directory permissions as well as the files
inside it for read access on startup.
* Add in simple aliases for ciphers to fix those that
don't follow the pattern (dhe_rsa_aes_128_sha256,
dhe_rsa_aes_256_sha256) and those with typos
(camelia_128_sha, camelia_256_sha)
* Fix semaphore leak
* Don't set remote user in fixup hook
* Drop SSLv2 tests because it is completely disabled now
- drop 0001-Handle-group-membership-when-testing-for-file-permis.patch
(upstream)
- add 0001-Fix-up-some-broken-cipher-strings-from-a-bad-merge.patch
2017-12-19 - pgajdos@suse.com
- buildrequire apr-devel instead of libapr1-devel
- buildrequire apr-util-devel instead of libapr-util1-devel
2017-12-11 - vcizek@suse.com
- Fix NSS database startup permission check (bsc#1057776)
* add 0001-Handle-group-membership-when-testing-for-file-permis.patch
2017-12-07 - vcizek@suse.com
- drop obsolete mod_nss-dont_disable_SSLV2.patch
* bump up minimal NSS version to 3.25, which we now have everywhere
- Require iproute2 for ss, which is used by gencert to gather noise
2017-10-23 - vcizek@suse.com
- Use ss instead of the deprecated netstat in gencert (bsc#1064415)
* add mod_nss-gencert_use_ss_instead_of_netstat.patch
- spec: cleanup and fix URLs

See Also

Package Description
apache2-mod_perl-2.0.10-2.7.i586.rpm Embedded Perl for Apache
apache2-mod_perl-2.0.10-2.7.x86_64.rpm Embedded Perl for Apache
apache2-mod_perl-devel-2.0.10-2.7.i586.rpm Embedded Perl for Apache - Development package
apache2-mod_perl-devel-2.0.10-2.7.x86_64.rpm Embedded Perl for Apache - Development package
apache2-mod_php7-7.3.4-2.1.i586.rpm PHP7 module for the Apache 2.x webserver
apache2-mod_php7-7.3.4-2.1.x86_64.rpm PHP7 module for the Apache 2.x webserver
apache2-mod_security2-2.9.2-1.6.i586.rpm Web Application Firewall for apache httpd
apache2-mod_security2-2.9.2-1.6.x86_64.rpm Web Application Firewall for apache httpd
apache2-mod_uwsgi-2.0.18-2.1.i586.rpm uWSGI Module for Apache 2.0
apache2-mod_uwsgi-2.0.18-2.1.x86_64.rpm uWSGI Module for Apache 2.0
apache2-mod_wsgi-4.6.5-1.1.i586.rpm A WSGI interface for Python web applications in Apache
apache2-mod_wsgi-4.6.5-1.1.x86_64.rpm A WSGI interface for Python web applications in Apache
apache2-mod_wsgi-python3-4.6.5-1.1.i586.rpm A WSGI interface for Python3 web applications in Apache
apache2-mod_wsgi-python3-4.6.5-1.1.x86_64.rpm A WSGI interface for Python3 web applications in Apache
apache2-prefork-2.4.39-1.1.i586.rpm Apache 2 "prefork" MPM (Multi-Processing Module)
Advertisement
Advertisement