antlr-devel-2.7.7-117.1.i586.rpm


Advertisement

Description

antlr-devel - ANother Tool for Language Recognition (c++ runtime)

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename antlr-devel-2.7.7-117.1.i586.rpm
Package name antlr-devel
Package version 2.7.7
Package release 117.1
Package architecture i586
Package type rpm
Category Development/Tools/Other
Homepage http://www.antlr.org/
License GPL-2.0-or-later AND SUSE-Public-Domain AND MIT
Maintainer -
Download size 1.90 MB
Installed size 4.29 MB
ANTLR, Another Tool for Language Recognition, (formerly PCCTS) is a
language tool that provides a framework for constructing recognizers,
compilers, and translators from grammatical descriptions containing C++
or Java actions (you can use PCCTS 1.xx to generate C-based parsers).
This package provides the C++ runtime (libantlr.a) and a headers files
of antlr

Alternatives

Package Version Architecture Repository
antlr-devel-2.7.7-180.7.x86_64.rpm 2.7.7 x86_64 JAVA
antlr-devel-2.7.7-180.7.i586.rpm 2.7.7 i586 JAVA
antlr-devel-2.7.7-117.1.x86_64.rpm 2.7.7 x86_64 openSUSE Oss
antlr-devel - - -

Requires

Name Value
antlr -

Provides

Name Value
antlr-devel = 2.7.7-117.1
antlr-devel(x86-32) = 2.7.7-117.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package antlr-devel-2.7.7-117.1.i586.rpm
Source Package antlr-2.7.7-117.1.src.rpm

Install Howto

Install antlr-devel rpm package:

# zypper install antlr-devel

Files

Path
/usr/include/antlr/ANTLRException.hpp
/usr/include/antlr/ANTLRUtil.hpp
/usr/include/antlr/AST.hpp
/usr/include/antlr/ASTArray.hpp
/usr/include/antlr/ASTFactory.hpp
/usr/include/antlr/ASTNULLType.hpp
/usr/include/antlr/ASTPair.hpp
/usr/include/antlr/ASTRefCount.hpp
/usr/include/antlr/BaseAST.hpp
/usr/include/antlr/BitSet.hpp
/usr/include/antlr/CharBuffer.hpp
/usr/include/antlr/CharInputBuffer.hpp
/usr/include/antlr/CharScanner.hpp
/usr/include/antlr/CharStreamException.hpp
/usr/include/antlr/CharStreamIOException.hpp
/usr/include/antlr/CircularQueue.hpp
/usr/include/antlr/CommonAST.hpp
/usr/include/antlr/CommonASTWithHiddenTokens.hpp
/usr/include/antlr/CommonHiddenStreamToken.hpp
/usr/include/antlr/CommonToken.hpp
/usr/include/antlr/IOException.hpp
/usr/include/antlr/InputBuffer.hpp
/usr/include/antlr/LLkParser.hpp
/usr/include/antlr/LexerSharedInputState.hpp
/usr/include/antlr/MismatchedCharException.hpp
/usr/include/antlr/MismatchedTokenException.hpp
/usr/include/antlr/NoViableAltException.hpp
/usr/include/antlr/NoViableAltForCharException.hpp
/usr/include/antlr/Parser.hpp
/usr/include/antlr/ParserSharedInputState.hpp
/usr/include/antlr/RecognitionException.hpp
/usr/include/antlr/RefCount.hpp
/usr/include/antlr/SemanticException.hpp
/usr/include/antlr/String.hpp
/usr/include/antlr/Token.hpp
/usr/include/antlr/TokenBuffer.hpp
/usr/include/antlr/TokenRefCount.hpp
/usr/include/antlr/TokenStream.hpp
/usr/include/antlr/TokenStreamBasicFilter.hpp
/usr/include/antlr/TokenStreamException.hpp
/usr/include/antlr/TokenStreamHiddenTokenFilter.hpp
/usr/include/antlr/TokenStreamIOException.hpp
/usr/include/antlr/TokenStreamRecognitionException.hpp
/usr/include/antlr/TokenStreamRetryException.hpp
/usr/include/antlr/TokenStreamRewriteEngine.hpp
/usr/include/antlr/TokenStreamSelector.hpp
/usr/include/antlr/TokenWithIndex.hpp
/usr/include/antlr/TreeParser.hpp
/usr/include/antlr/TreeParserSharedInputState.hpp
/usr/include/antlr/config.hpp
/usr/lib/libantlr.a

Changelog

2018-11-18 - Fridrich Strba <fstrba@suse.com>
- Install as maven artifact using the pom file from maven central
2018-09-13 - Tomá? Chvátal <tchvatal@suse.com>
- Do not create compat symlink for python stuff as it was not working
before anyway
- Rename python package to python2-antlr (provide old symbol)
2018-07-20 - tchvatal@suse.com
- Do not use old compat macros for python directories
2018-05-15 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
2018-01-12 - tchvatal@suse.com
- Add condition about python2 module, the rewrite happened in antlr4
for python3 support and it is completely different than the antlr2
* The python module is not used by any package in TW bsc#1068226
2017-12-07 - dimstar@opensuse.org
- Fix build with RPM 4.14: a command that exits with error > 0
aborts the build (and grep not finding a string is retval 1).
2017-11-03 - mpluskal@suse.com
- Explicitly require python2 [bsc#1068226, fate#323526]
2017-09-29 - fstrba@suse.com
- Require java-devel >= 1.6 to build, because of the source and
target level
2017-09-06 - fstrba@suse.com
- fixes necessary to compile with Java 9
* set javac source and target to 1.6
2017-06-09 - tchvatal@suse.com
- Drop the javadoc so we can be build with java bootstrapping reducing
the cycle/failures

See Also

Package Description
antlr-java-2.7.7-117.1.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr-manual-2.7.7-117.1.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr3c-devel-3.4-4.8.i586.rpm C runtime for the ANTLR parsing library
antlr3c-devel-3.4-4.8.x86_64.rpm C runtime for the ANTLR parsing library
aom-tools-1.0.0-1.3.i586.rpm AV1 Codec Library Tools
aom-tools-1.0.0-1.3.x86_64.rpm AV1 Codec Library Tools
aop-0.6-1.12.i586.rpm Ncurses based arcade game with only 64 lines of code
aop-0.6-1.12.x86_64.rpm Ncurses based arcade game with only 64 lines of code
aopalliance-1.0-1.1.noarch.rpm Java/J2EE AOP standards
aopalliance-javadoc-1.0-1.1.noarch.rpm API documentation for aopalliance
apache-commons-beanutils-1.9.3-2.3.noarch.rpm Utility methods for accessing and modifying the properties of JavaBeans
apache-commons-beanutils-javadoc-1.9.3-2.3.noarch.rpm Javadoc for jakarta-commons-beanutils
apache-commons-chain-1.2-1.1.noarch.rpm An implementation of the GoF Chain of Responsibility pattern
apache-commons-chain-javadoc-1.2-1.1.noarch.rpm Javadoc for apache-commons-chain
apache-commons-cli-1.4-3.1.noarch.rpm Command Line Interface Library for Java
Advertisement
Advertisement