alsa-oss-1.1.8-1.2.x86_64.rpm


Advertisement

Description

alsa-oss - LD_PRELOAD-able library that translates OSS into ALSA calls

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename alsa-oss-1.1.8-1.2.x86_64.rpm
Package name alsa-oss
Package version 1.1.8
Package release 1.2
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.alsa-project.org/
License GPL-2.0-or-later
Maintainer -
Download size 40.36 KB
Installed size 91.85 KB
A preloadable library that intercepts Open Sound System API calls
in applications and translates them into ALSA API calls.
A convenience script to launch such applications with the preloaded
library is provided as well, called "aoss".

Alternatives

Package Version Architecture Repository
alsa-oss-1.1.8-58.4.x86_64.rpm 1.1.8 x86_64 Multimedia Libs
alsa-oss-1.1.8-58.4.i586.rpm 1.1.8 i586 Multimedia Libs
alsa-oss-1.1.8-1.2.i586.rpm 1.1.8 i586 openSUSE Oss
alsa-oss - - -

Requires

Name Value
/sbin/ldconfig -
libasound.so.2()(64bit) -
libasound.so.2(ALSA_0.9)(64bit) -
libasound.so.2(ALSA_0.9.0rc4)(64bit) -
libasound.so.2(ALSA_0.9.0rc8)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -

Provides

Name Value
alsa-oss = 1.1.8-1.2
alsa-oss(x86-64) = 1.1.8-1.2
libalsatoss.so.0()(64bit) -
libaoss.so.0()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package alsa-oss-1.1.8-1.2.x86_64.rpm
Source Package alsa-oss-1.1.8-1.2.src.rpm

Install Howto

Install alsa-oss rpm package:

# zypper install alsa-oss

Files

Path
/usr/bin/aoss
/usr/lib64/libalsatoss.so.0
/usr/lib64/libalsatoss.so.0.0.0
/usr/lib64/libaoss.so
/usr/lib64/libaoss.so.0
/usr/lib64/libaoss.so.0.0.0
/usr/share/licenses/alsa-oss/COPYING
/usr/share/man/man1/aoss.1.gz

Changelog

2019-01-09 - Jan Engelhardt <jengelh@inai.de>
- Avoid repetition of name in summary. Update description.
2019-01-08 - tiwai@suse.de
- Update to alsa-oss 1.1.8:
Fix the build with the recent glibc
- Remove obsoleted patch:
remove-libio.patch:
2018-08-06 - schwab@suse.de
- remove-libio.patch: don't use obsolete <libio.h>
2018-04-04 - tiwai@suse.de
- Remove old kludges
- Run spec-cleaner
2018-04-04 - tiwai@suse.de
- Update to alsa-oss 1.1.6:
* Change FSF address (Franklin Street)
- Use %license file tag
2014-06-18 - tiwai@suse.de
- Updated to alsa-oss 1.0.28:
All pervious fix patches are obsoleted:
0002-Add-AM_MAINTAINER_MODE-enable-to-configure.in.patch
0003-Fix-the-argument-passed-to-snd_pcm_dump_setup.patch
0004-Workaround-for-aoss-dmix-with-unaligned-rates.patch
2014-04-28 - tiwai@suse.de
- Fix for dmix with unaligned sample rate:
0003-Fix-the-argument-passed-to-snd_pcm_dump_setup.patch
0004-Workaround-for-aoss-dmix-with-unaligned-rates.patch
2014-04-28 - tiwai@suse.de
- Revert 0001-Fix-path-to-libaoss.so.patch, as this causes
regressions on multi-arch (bnc#874331)
2013-05-23 - tiwai@suse.de
- Backport upstream fixes:
0001-Fix-path-to-libaoss.so.patch
0002-Add-AM_MAINTAINER_MODE-enable-to-configure.in.patch
2012-03-29 - reddwarf@opensuse.org
- stop recommending alsa-oss-32bit

See Also

Package Description
alsa-oss-32bit-1.1.8-1.2.x86_64.rpm LD_PRELOAD-able library that translates OSS into ALSA calls
alsa-plugins-1.1.8-2.1.i586.rpm Extra Plug-Ins for the ALSA Library
alsa-plugins-1.1.8-2.1.x86_64.rpm Extra Plug-Ins for the ALSA Library
alsa-plugins-32bit-1.1.8-2.1.x86_64.rpm Extra Plug-Ins for the ALSA Library
alsa-plugins-a52-1.1.8-2.1.i586.rpm A52 Output Plug-In for the ALSA Library
alsa-plugins-a52-1.1.8-2.1.x86_64.rpm A52 Output Plug-In for the ALSA Library
alsa-plugins-aaf-1.1.8-2.1.i586.rpm AVTP Audio Format PCM Plug-In for the ALSA Library
alsa-plugins-aaf-1.1.8-2.1.x86_64.rpm AVTP Audio Format PCM Plug-In for the ALSA Library
alsa-plugins-jack-1.1.8-2.1.i586.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-jack-1.1.8-2.1.x86_64.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-jack-32bit-1.1.8-2.1.x86_64.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-lavrate-1.1.8-2.1.i586.rpm Rate Converter Plug-In for the ALSA Library using libavcodec
alsa-plugins-lavrate-1.1.8-2.1.x86_64.rpm Rate Converter Plug-In for the ALSA Library using libavcodec
alsa-plugins-maemo-1.1.8-2.1.i586.rpm Maemo Plug-Ins for the ALSA Library
alsa-plugins-maemo-1.1.8-2.1.x86_64.rpm Maemo Plug-Ins for the ALSA Library
Advertisement
Advertisement