alacarte-3.11.91-12.1.i586.rpm


Advertisement

Description

alacarte - Menu editor for GNOME

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename alacarte-3.11.91-12.1.i586.rpm
Package name alacarte
Package version 3.11.91
Package release 12.1
Package architecture i586
Package type rpm
Category System/GUI/GNOME
Homepage http://www.realistanew.com/projects/alacarte
License LGPL-2.1-or-later
Maintainer -
Download size 102.37 KB
Installed size 284.67 KB
Alacarte is a simple freedesktop.org compliant menu editor for GNOME
that lets you change your menus, simply and quickly. Just click and
type to edit, add, and delete any menu entry.

Alternatives

Package Version Architecture Repository
alacarte-3.11.91-137.1.i586.rpm 3.11.91 i586 GNOME Next
alacarte-3.11.91-137.1.x86_64.rpm 3.11.91 x86_64 GNOME Next
alacarte-3.11.91-112.1.i586.rpm 3.11.91 i586 GNOME Factory
alacarte-3.11.91-112.1.x86_64.rpm 3.11.91 x86_64 GNOME Factory
alacarte-3.11.91-12.1.x86_64.rpm 3.11.91 x86_64 openSUSE Oss
alacarte - - -

Requires

Name Value
/usr/bin/python3.7 -
python(abi) = 3.7
python3-gobject-Gdk -
typelib(GLib) -
typelib(GMenu) -
typelib(GObject) -
typelib(Gdk) -
typelib(GdkPixbuf) -
typelib(Gtk) = 3.0

Provides

Name Value
alacarte = 3.11.91-12.1
alacarte(x86-32) = 3.11.91-12.1
application() -
application(alacarte.desktop) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package alacarte-3.11.91-12.1.i586.rpm
Source Package alacarte-3.11.91-12.1.src.rpm

Install Howto

Install alacarte rpm package:

# zypper install alacarte

Files

Path
/usr/bin/alacarte
/usr/lib/python3.7/site-packages/Alacarte/ItemEditor.py
/usr/lib/python3.7/site-packages/Alacarte/MainWindow.py
/usr/lib/python3.7/site-packages/Alacarte/MenuEditor.py
/usr/lib/python3.7/site-packages/Alacarte/__init__.py
/usr/lib/python3.7/site-packages/Alacarte/config.py
/usr/lib/python3.7/site-packages/Alacarte/util.py
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/ItemEditor.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/ItemEditor.cpython-37.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/MainWindow.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/MainWindow.cpython-37.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/MenuEditor.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/MenuEditor.cpython-37.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/config.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/config.cpython-37.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/util.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/Alacarte/__pycache__/util.cpython-37.pyc
/usr/share/alacarte/alacarte.ui
/usr/share/alacarte/directory-editor.ui
/usr/share/alacarte/launcher-editor.ui
/usr/share/applications/alacarte.desktop
/usr/share/doc/packages/alacarte/AUTHORS
/usr/share/doc/packages/alacarte/ChangeLog
/usr/share/doc/packages/alacarte/NEWS
/usr/share/doc/packages/alacarte/README
/usr/share/icons/hicolor/16x16/apps/alacarte.png
/usr/share/icons/hicolor/22x22/apps/alacarte.png
/usr/share/icons/hicolor/24x24/apps/alacarte.png
/usr/share/icons/hicolor/256x256/apps/alacarte.png
/usr/share/icons/hicolor/32x32/apps/alacarte.png
/usr/share/icons/hicolor/48x48/apps/alacarte.png
/usr/share/licenses/alacarte/COPYING
/usr/share/man/man1/alacarte.1.gz

Changelog

2019-01-29 - Dominique Leuenberger <dimstar@opensuse.org>
- Update alacarte-python3.patch: Add support for python 3.7.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2018-01-15 - mgorse@suse.com
- Migrate to python3 (bsc#1075771):
+ Add alacarte-python3.patch: convert the code to be py3
compatible.
+ Update alacarte-trans.patch: Don't use tab for indentation.
+ Add autoconf and automake BuildRequires and call autoreconf in
build section: needed, since above patches touch the build
system.
+ Replace python BuildRequires with python3.
+ Add python3-gobject-Gdk Requires: new dependency.
2017-09-14 - qzheng@suse.com
- Added fix-bad-command-validation.patch which fix bad command
validation, backported from commit hash 665b471 and ca7d05c
(bsc#1057908, bgo#728372).
2016-05-20 - alarrosa@suse.com
- Update to GNOME 3.20.2 (Fate#318572)
2016-05-03 - dimstar@opensuse.org
- Require python-gobject-Gdk: pygobject was further split in order
to be able to install it without X-dependencies. Alacarte imports
Gdk from gi.repository, thus also requires python-gobject-Gdk.
2016-04-14 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572
2015-11-27 - qzhao@suse.org
- Updated alacarte-trans.patch to modify alacarte.ui:
use original text, translate all PO tranlation files.
Modified under Stanislav Brabec's review result.
(bnc#947793)
2015-10-13 - qzhao@suse.org
- Added alacarte-trans.patch which adds a gettext function
to ItemEditor.py to make alacarte translatable (bnc#947793)
2014-10-05 - zaitor@opensuse.org
- Move .desktopfile from X-GNOME-SystemSettings to
X-GNOME-PersonalSettings, since the only values one can change is
for active user. Having it under System gives the impression that
changes are systemwide.

See Also

Package Description
alacarte-lang-3.11.91-12.1.noarch.rpm Translations for package alacarte
alacritty-0.2.1-1.2.i586.rpm A GPU-accelerated terminal emulator
alacritty-0.2.1-1.2.x86_64.rpm A GPU-accelerated terminal emulator
alacritty-bash-completion-0.2.1-1.2.noarch.rpm Bash Completion for alacritty
alacritty-fish-completion-0.2.1-1.2.noarch.rpm Fish Completion for alacritty
alacritty-zsh-completion-0.2.1-1.2.noarch.rpm ZSH Completion for alacritty
albert-0.16.1-2.1.i586.rpm Desktop agnostic launcher
albert-0.16.1-2.1.x86_64.rpm Desktop agnostic launcher
aldusleaf-crimson-text-fonts-20111206-11.11.noarch.rpm Crimson Text Serif Font
alee-fonts-13-5.12.noarch.rpm Korean TrueType fonts
alevt-1.6.2-95.5.i586.rpm Teletext and Videotext Decoder for the BTTV Driver
alevt-1.6.2-95.5.x86_64.rpm Teletext and Videotext Decoder for the BTTV Driver
alevtd-3.103-8.1.i586.rpm HTTP server for Teletext pages
alevtd-3.103-8.1.x86_64.rpm HTTP server for Teletext pages
alex-3.2.4-5.3.i586.rpm Alex is a tool for generating lexical analysers in Haskell
Advertisement
Advertisement