OpenShadingLanguage-devel-1.9.13-2.2.x86_64.rpm


Advertisement

Description

OpenShadingLanguage-devel - Development files for OpenShadingLanguage

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename OpenShadingLanguage-devel-1.9.13-2.2.x86_64.rpm
Package name OpenShadingLanguage-devel
Package version 1.9.13
Package release 2.2
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/imageworks/OpenShadingLanguage
License BSD-3-Clause
Maintainer -
Download size 57.06 KB
Installed size 303.11 KB
The OpenShadingLanguage-devel package contains libraries and header files for
developing applications that use OpenShadingLanguage.

Alternatives

Package Version Architecture Repository
OpenShadingLanguage-devel-1.9.13-2.2.i586.rpm 1.9.13 i586 openSUSE Oss
OpenShadingLanguage-devel - - -

Requires

Name Value
OpenShadingLanguage = 1.9.13
liboslcomp1_9 = 1.9.13
liboslexec1_9 = 1.9.13
liboslnoise1_9 = 1.9.13
liboslquery1_9 = 1.9.13
libtestshade1_9 = 1.9.13
osl.imageio1_9 = 1.9.13

Provides

Name Value
OpenShadingLanguage-devel = 1.9.13-2.2
OpenShadingLanguage-devel(x86-64) = 1.9.13-2.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package OpenShadingLanguage-devel-1.9.13-2.2.x86_64.rpm
Source Package OpenShadingLanguage-1.9.13-2.2.src.rpm

Install Howto

Install OpenShadingLanguage-devel rpm package:

# zypper install OpenShadingLanguage-devel

Files

Path
/usr/include/OSL/Imathx.h
/usr/include/OSL/accum.h
/usr/include/OSL/dual.h
/usr/include/OSL/dual_vec.h
/usr/include/OSL/export.h
/usr/include/OSL/genclosure.h
/usr/include/OSL/llvm_util.h
/usr/include/OSL/matrix22.h
/usr/include/OSL/optautomata.h
/usr/include/OSL/oslclosure.h
/usr/include/OSL/oslcomp.h
/usr/include/OSL/oslconfig.h
/usr/include/OSL/oslexec.h
/usr/include/OSL/oslnoise.h
/usr/include/OSL/oslquery.h
/usr/include/OSL/oslversion.h
/usr/include/OSL/rendererservices.h
/usr/include/OSL/shaderglobals.h
/usr/lib64/liboslcomp.so
/usr/lib64/liboslexec.so
/usr/lib64/liboslnoise.so
/usr/lib64/liboslquery.so
/usr/lib64/libtestshade.so
/usr/lib64/osl.imageio.so
/usr/share/licenses/OpenShadingLanguage-devel/LICENSE

Changelog

2019-01-13 - Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Fix lookup of stdosl.h from oslc (bnc#1123254):
Dropped OpenShadingLanguage-shaderinstalldir.patch
Added 0001-Generalize-lookup-of-stdosl.h-in-install-directory-a.patch
- Cleaned up spec file (defattr)
- Correct LLVM_MCJIT_LIBRARY value, add comment
- Use current LLVM for building (bnc#1123252)
- Split shaders in common-headers, MaterialX-shaders and example-shaders
subpackages. stdosl.h in common-headers is required by oslc in
the main package (bnc#1123254).
- Correct clang-devel package name for Leap 42.3
2019-01-08 - Jan Engelhardt <jengelh@inai.de>
- Spruce up descriptions a bit.
2018-12-31 - davejplater@gmail.com
- Initial version 1.9.13 created for blender see boo#1120406
- Blender fails to build with 1.10.x versions
- Added OpenShadingLanguage-shaderinstalldir.patch shaders are
installed directly under /usr see:
https://github.com/imageworks/OpenShadingLanguage/issues/955

See Also

Package Description
OpenShadingLanguage-doc-1.9.13-2.2.i586.rpm Documentation for OpenShadingLanguage
OpenShadingLanguage-doc-1.9.13-2.2.x86_64.rpm Documentation for OpenShadingLanguage
OpenShadingLanguage-example-shaders-source-1.9.13-2.2.i586.rpm OSL shader examples
OpenShadingLanguage-example-shaders-source-1.9.13-2.2.x86_64.rpm OSL shader examples
PackageKit-1.1.12-7.1.i586.rpm Simple software installation management software
PackageKit-1.1.12-7.1.x86_64.rpm Simple software installation management software
PackageKit-Qt-devel-1.0.1-2.1.i586.rpm Simple software installation management software
PackageKit-Qt-devel-1.0.1-2.1.x86_64.rpm Simple software installation management software
PackageKit-backend-zypp-1.1.12-7.1.i586.rpm Zypp backend for the PackageKit installation management software
PackageKit-backend-zypp-1.1.12-7.1.x86_64.rpm Zypp backend for the PackageKit installation management software
PackageKit-branding-openSUSE-42.1-2.5.noarch.rpm Simple software installation management software -- openSUSE default configuration
PackageKit-branding-upstream-1.1.12-7.1.noarch.rpm Upstream configuration for the PackageKit installation management software
PackageKit-devel-1.1.12-7.1.i586.rpm Header files for development with PackageKit
PackageKit-devel-1.1.12-7.1.x86_64.rpm Header files for development with PackageKit
PackageKit-gstreamer-plugin-1.1.12-7.1.i586.rpm GStreamer plugin for the PackageKit installation management software
Advertisement
Advertisement