NetworkManager-pptp-1.2.8-1.2.x86_64.rpm


Advertisement

Description

NetworkManager-pptp - NetworkManager VPN support for PPTP

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename NetworkManager-pptp-1.2.8-1.2.x86_64.rpm
Package name NetworkManager-pptp
Package version 1.2.8
Package release 1.2
Package architecture x86_64
Package type rpm
Category Productivity/Networking/System
Homepage https://wiki.gnome.org/Projects/NetworkManager
License GPL-2.0-or-later
Maintainer -
Download size 44.02 KB
Installed size 119.17 KB
NetworkManager-pptp provides VPN support to NetworkManager for PPTP.

Alternatives

Package Version Architecture Repository
NetworkManager-pptp-1.2.8-106.10.x86_64.rpm 1.2.8 x86_64 GNOME Next
NetworkManager-pptp-1.2.8-106.10.i586.rpm 1.2.8 i586 GNOME Next
NetworkManager-pptp-1.2.8-80.9.x86_64.rpm 1.2.8 x86_64 GNOME Factory
NetworkManager-pptp-1.2.8-80.9.i586.rpm 1.2.8 i586 GNOME Factory
NetworkManager-pptp-1.2.8-1.2.i586.rpm 1.2.8 i586 openSUSE Oss
NetworkManager-pptp - - -

Requires

Name Value
NetworkManager >= 1.2.0
libc.so.6(GLIBC_2.4)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libnm.so.0()(64bit) -
libnm.so.0(libnm_1_0_0)(64bit) -
libnm.so.0(libnm_1_2_0)(64bit) -
libpthread.so.0()(64bit) -
ppp = 2.4.7
pptp -

Provides

Name Value
NetworkManager-pptp = 1.2.8-1.2
NetworkManager-pptp(x86-64) = 1.2.8-1.2
config(NetworkManager-pptp) = 1.2.8-1.2
libnm-vpn-plugin-pptp.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package NetworkManager-pptp-1.2.8-1.2.x86_64.rpm
Source Package NetworkManager-pptp-1.2.8-1.2.src.rpm

Install Howto

Install NetworkManager-pptp rpm package:

# zypper install NetworkManager-pptp

Files

Path
/etc/dbus-1/system.d/nm-pptp-service.conf
/usr/lib/nm-pptp-service
/usr/lib/NetworkManager/
/usr/lib/NetworkManager/VPN/nm-pptp-service.name
/usr/lib64/NetworkManager/libnm-vpn-plugin-pptp.so
/usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so
/usr/share/doc/packages/NetworkManager-pptp/README
/usr/share/licenses/NetworkManager-pptp/COPYING

Changelog

2018-10-04 - bjorn.lie@gmail.com
- Update to version 1.2.8:
+ Fix build without GTK/Gnome.
+ Updated translations.
2018-04-14 - bjorn.lie@gmail.com
- Following changes in NetworkManager: pass without-libnm-glib to
configure, no longer build deprecated libnm-glib support.
- Following the above changes: Drop no longer needed
pkgconfig(NetworkManager), pkgconfig(libnm-glib),
pkgconfig(libnm-glib-vpn), pkgconfig(libnm-gtk) and
pkgconfig(libnm-util) BuildRequires.
- Package missing COPYING file.
- Package m-pptp-service.conf as config, silence rpmlint.
- Drop unnneeded NetworkManager-gnome Requires from gnome
sub-package, it is not longer of use for us.
2018-03-30 - luc14n0@linuxmail.org
- Update to version 1.2.6:
+ Fix passing "user" and set "remotename" (bgo#794695)
+ Use gresources for UI file
+ Updated translations.
- Update URL tag to https://wiki.gnome.org/Projects/NetworkManager:
currently the Network Manager project's web page.
- Drop icon_theme_cache_* post/postun scriptlets: its fucntionality
has been moved to RPM file triggers (4.13, suse_version 1330).
- Add gio-2.0, gio-unix-2.0 and glib-2.0 pkgconfig modules
BuildRequires to avoid implicit dependencies.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-10-04 - zaitor@opensuse.org
- Update to version 1.2.4:
+ Prefer building against stable libsecret API.
+ Split libnm-vpn-plugin-pptp.so into a GTK-free core plugin
usable by nmcli and a UI plugin for nm-applet and gnome
components.
+ Support NM_VPN_LOG_LEVEL environment variable to control debug
logging from NetworkManager.
+ Various cleanups.
+ Updated translations.
- Replace pkgconfig(libsecret-unstable) for pkgconfig(libsecret-1)
BuildRequires following upstreams changes.
- Drop NetworkManager-frontend Requires from main package.
2016-05-15 - zaitor@opensuse.org
- Update to version 1.2.2:
+ Fixed the D-Bus API for multiple concurrent connections.
+ Use a proper name for the AppStream metadata.
+ Updated translations.
2016-05-02 - dimstar@opensuse.org
- Update to version 1.2.0:
+ nm-pppd-plugin: fix crash.
+ Updated translations.
- Drop --disable-more-warnings from configure line: no longer
needed.
2016-04-07 - dimstar@opensuse.org
- Update to version 1.1.93 (1.2-rc1):
+ No changes.
- Changes from version 1.1.92:
+ Bugs fixed: bgo#762938.
+ Updated translations.
2016-04-07 - dimstar@opensuse.org
- Update to version 1.1.91:
+ Updated translations.
2016-04-07 - dimstar@opensuse.org
- Update to version 1.1.90:
+ Ported to libnm, libnma and GDBus.
+ Enhanced the GUI to support agent-owned and always-ask
passwords.
+ Update the UI to use modern GTK witgets instead of deprecated
ones.
+ Updated translations.
- Add pkgconfig(libnm) and pkgconfig(libnma) BuildRequires: new
dependencies.
- Drop nm-pptp-desktop.patch: no longer needed.
- Drop icon sources: as there is no .desktop file, we also do not
need an icon for it.

See Also

Package Description
NetworkManager-pptp-gnome-1.2.8-1.2.i586.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-gnome-1.2.8-1.2.x86_64.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-lang-1.2.8-1.2.noarch.rpm Translations for package NetworkManager-pptp
NetworkManager-strongswan-1.4.4-2.3.i586.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-1.4.4-2.3.x86_64.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-gnome-1.4.4-2.3.i586.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-gnome-1.4.4-2.3.x86_64.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-lang-1.4.4-2.3.noarch.rpm Translations for package NetworkManager-strongswan
NetworkManager-vpnc-1.2.6-1.2.i586.rpm NetworkManager VPN Support for vpnc
NetworkManager-vpnc-1.2.6-1.2.x86_64.rpm NetworkManager VPN Support for vpnc
NetworkManager-vpnc-gnome-1.2.6-1.2.i586.rpm NetworkManager VPN Support for vpnc
NetworkManager-vpnc-gnome-1.2.6-1.2.x86_64.rpm NetworkManager VPN Support for vpnc
NetworkManager-vpnc-lang-1.2.6-1.2.noarch.rpm Translations for package NetworkManager-vpnc
OOKiedokie-0.0.0+git.20151230-1.5.i586.rpm A tool for transmitting and receiving OOK-modulated data with SDRs
OOKiedokie-0.0.0+git.20151230-1.5.x86_64.rpm A tool for transmitting and receiving OOK-modulated data with SDRs
Advertisement
Advertisement