NetworkManager-openconnect-gnome-1.2.4-3.3.i586.rpm


Advertisement

Description

NetworkManager-openconnect-gnome - NetworkManager VPN support for OpenConnect

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename NetworkManager-openconnect-gnome-1.2.4-3.3.i586.rpm
Package name NetworkManager-openconnect-gnome
Package version 1.2.4
Package release 3.3
Package architecture i586
Package type rpm
Category Productivity/Networking/System
Homepage http://www.gnome.org/projects/NetworkManager
License GPL-2.0-or-later AND LGPL-2.1-only
Maintainer -
Download size 38.76 KB
Installed size 128.68 KB
NetworkManager-openconnect provides VPN support to NetworkManager for
OpenConnect, an implementation of the Cisco AnyConnect VPN system.

Alternatives

Package Version Architecture Repository
NetworkManager-openconnect-gnome-1.2.4-74.21.x86_64.rpm 1.2.4 x86_64 GNOME Next
NetworkManager-openconnect-gnome-1.2.4-74.21.i586.rpm 1.2.4 i586 GNOME Next
NetworkManager-openconnect-gnome-1.2.4-51.19.x86_64.rpm 1.2.4 x86_64 GNOME Factory
NetworkManager-openconnect-gnome-1.2.4-51.19.i586.rpm 1.2.4 i586 GNOME Factory
NetworkManager-openconnect-gnome-1.2.4-3.3.x86_64.rpm 1.2.4 x86_64 openSUSE Oss
NetworkManager-openconnect-gnome - - -

Requires

Name Value
NetworkManager-openconnect = 1.2.4
libc.so.6(GLIBC_2.4) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -
libnm.so.0 -
libnm.so.0(libnm_1_0_0) -
libnm.so.0(libnm_1_2_0) -
libopenconnect.so.5 -
libopenconnect.so.5(OPENCONNECT_5.0) -
libopenconnect.so.5(OPENCONNECT_5_2) -
libpthread.so.0 -
libsecret-1.so.0 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -

Provides

Name Value
NetworkManager-openconnect-frontend -
NetworkManager-openconnect-gnome = 1.2.4-3.3
NetworkManager-openconnect-gnome(x86-32) = 1.2.4-3.3
libnm-vpn-plugin-openconnect-editor.so -
metainfo() -
metainfo(network-manager-openconnect.metainfo.xml) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package NetworkManager-openconnect-gnome-1.2.4-3.3.i586.rpm
Source Package NetworkManager-openconnect-1.2.4-3.3.src.rpm

Install Howto

Install NetworkManager-openconnect-gnome rpm package:

# zypper install NetworkManager-openconnect-gnome

Files

Path
/usr/lib/nm-openconnect-auth-dialog
/usr/lib/NetworkManager/libnm-vpn-plugin-openconnect-editor.so
/usr/share/appdata/network-manager-openconnect.metainfo.xml
/usr/share/gnome-vpn-properties/
/usr/share/gnome-vpn-properties/openconnect/nm-openconnect-dialog.ui

Changelog

2018-04-14 - bjorn.lie@gmail.com
- Following changes in NetworkManager: pass without-libnm-glib to
configure, no longer build deprecated libnm-glib support.
- Following the above changes: Drop no longer needed
pkgconfig(NetworkManager), pkgconfig(libnm-glib),
pkgconfig(libnm-glib-vpn) and pkgconfig(libnm-util)
BuildRequires.
- Drop no longer needed export CFLAGS="%%{optflags}
- Wno-deprecated-declarations".
- Drop unnneeded NetworkManager-gnome Requires from gnome
sub-package, it is not longer of use for us.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-12-06 - dimstar@opensuse.org
- Update to version 1.2.4:
+ Split libnm-vpn-plugin-openconnect.so into a GTK-free core
plugin usable by nmcli and a UI plugin for nm-applet and GNOME
components.
+ Support NM_VPN_LOG_LEVEL environment variable to control debug
logging from NetworkManager.
+ Support Juniper Network Connect / Junos Pulse Secure VPN.
+ Add Yubikey OATH support.
+ Added support for automatic login when all needed data is
known.
+ Fixed support for IPv6-only VPNs.
+ Updated translations.
2016-05-14 - zaitor@opensuse.org
- Update to version 1.2.2:
+ Use a proper name for the AppStream metadata.
+ Updated translations.
2016-05-02 - dimstar@opensuse.org
- Update to version 1.2.0:
+ build: don't include the full path to a plugin by default.
+ Updated translations.
2016-04-06 - dimstar@opensuse.org
- Update to version 1.1.93 (1.2-rc1):
+ No changes.
- Changes from version 1.1.92:
+ plugin: avoid calling GetAll on service object.
+ Updated translations.
2016-03-01 - dimstar@opensuse.org
- Update to version 1.1.91:
+ service: drop off the bus if the peer vanishes or we're
unneeded.
+ Updated translations.
2016-01-21 - dimstar@opensuse.org
- Update to version 1.1.90:
+ Ported to libnm, libnma and GDBus.
+ Support multiple concurrent VPN connections.
+ Updated translations.
- Add pkgconfig(libnm) BuildRequires: new dependency.
2015-11-22 - zaitor@opensuse.org
- Update to version 1.0.8:
+ Updated translations.
2015-05-06 - dimstar@opensuse.org
- Update to version 1.0.2:
+ Updated translations.

See Also

Package Description
NetworkManager-openconnect-lang-1.2.4-3.3.noarch.rpm Translations for package NetworkManager-openconnect
NetworkManager-openvpn-1.8.10-1.1.i586.rpm NetworkManager VPN support for OpenVPN
NetworkManager-openvpn-1.8.10-1.1.x86_64.rpm NetworkManager VPN support for OpenVPN
NetworkManager-openvpn-gnome-1.8.10-1.1.i586.rpm NetworkManager VPN support for OpenVPN
NetworkManager-openvpn-gnome-1.8.10-1.1.x86_64.rpm NetworkManager VPN support for OpenVPN
NetworkManager-openvpn-lang-1.8.10-1.1.noarch.rpm Translations for package NetworkManager-openvpn
NetworkManager-pptp-1.2.8-1.2.i586.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-1.2.8-1.2.x86_64.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-gnome-1.2.8-1.2.i586.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-gnome-1.2.8-1.2.x86_64.rpm NetworkManager VPN support for PPTP
NetworkManager-pptp-lang-1.2.8-1.2.noarch.rpm Translations for package NetworkManager-pptp
NetworkManager-strongswan-1.4.4-2.3.i586.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-1.4.4-2.3.x86_64.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-gnome-1.4.4-2.3.i586.rpm NetworkManager VPN support for strongSwan
NetworkManager-strongswan-gnome-1.4.4-2.3.x86_64.rpm NetworkManager VPN support for strongSwan
Advertisement
Advertisement