NetworkManager-connection-editor-1.8.20-1.1.x86_64.rpm


Advertisement

Description

NetworkManager-connection-editor - GUI to configure connections for NetworkManager

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename NetworkManager-connection-editor-1.8.20-1.1.x86_64.rpm
Package name NetworkManager-connection-editor
Package version 1.8.20
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/GUI/GNOME
Homepage https://gnome.org/projects/NetworkManager
License GPL-2.0-or-later
Maintainer -
Download size 196.43 KB
Installed size 829.67 KB
NetworkManager Configuration tool - take control over your
connection settings.

Alternatives

Package Version Architecture Repository
NetworkManager-connection-editor-1.8.20-119.8.x86_64.rpm 1.8.20 x86_64 GNOME Next
NetworkManager-connection-editor-1.8.20-119.8.i586.rpm 1.8.20 i586 GNOME Next
NetworkManager-connection-editor-1.8.20-59.7.x86_64.rpm 1.8.20 x86_64 GNOME Factory
NetworkManager-connection-editor-1.8.20-59.7.i586.rpm 1.8.20 i586 GNOME Factory
NetworkManager-connection-editor-1.8.20-1.1.i586.rpm 1.8.20 i586 openSUSE Oss
NetworkManager-connection-editor - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libgdk-3.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libjansson.so.4()(64bit) -
libnm.so.0()(64bit) -
libnm.so.0(libnm_1_0_0)(64bit) -
libnm.so.0(libnm_1_2_0)(64bit) -
libnm.so.0(libnm_1_4_0)(64bit) -
libnm.so.0(libnm_1_6_0)(64bit) -
libnm.so.0(libnm_1_8_0)(64bit) -
libnma.so.0()(64bit) -
libnma.so.0(libnma_1_2_0)(64bit) -
libnma.so.0(libnma_1_8_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -

Provides

Name Value
NetworkManager-connection-editor = 1.8.20-1.1
NetworkManager-connection-editor(x86-64) = 1.8.20-1.1
application() -
application(nm-connection-editor.desktop) -
metainfo() -
metainfo(nm-connection-editor.appdata.xml) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package NetworkManager-connection-editor-1.8.20-1.1.x86_64.rpm
Source Package NetworkManager-applet-1.8.20-1.1.src.rpm

Install Howto

Install NetworkManager-connection-editor rpm package:

# zypper install NetworkManager-connection-editor

Files

Path
/usr/bin/nm-connection-editor
/usr/share/applications/nm-connection-editor.desktop
/usr/share/man/man1/nm-connection-editor.1.gz
/usr/share/metainfo/nm-connection-editor.appdata.xml

Changelog

2019-02-08 - bjorn.lie@gmail.com
- Update to version 1.8.20:
+ Build of libnm-gtk, a libnm-glib compatibility library, is
disabled by default. It can be enabled by passing
- -with-libnm-gtk to configure script. Nobody should need it by
now. Users that still use this are encouraged to let us know
before the libnm-glib support is removed for good.
+ Improve the mobile broadband wizard.
+ Fix a bug in the wifi dialog that made widgets disappear when
selecting a different device.
+ Support secret agent hints needed when using IWD as wireless
backend.
+ Updated translations.
- Drop nm-applet-revert-no-show-all.patch: Fixed upstream.
2018-11-07 - sckang@suse.com
- Add nm-applet-revert-no-show-all.patch: libnma: fix wrongly
showing hidden GUI elements (bsc#1106705,
glgo#GNOME/network-manager-applet#20).
2018-09-07 - bjorn.lie@gmail.com
- Update to version 1.8.18:
+ libnma:
- Fix wrongly showing hidden GUI elements, which causes
connection editing to behave wrong
(glgo#GNOME/network-manager-applet!20).
- c-e: Fix translation issues in GUI due to missing gettext
domain (bgo#792285).
+ Updated translations.
2018-08-07 - bjorn.lie@gmail.com
- Update to version 1.8.16:
+ Fix various issues that causes GtkApplication to quit at the
wrong time.
+ Read the Mobile Providers database from a build-time determined
location.
+ Modernize Gtk+ 3.0 use in preparations for Gtk+ 4.0.
+ Updated translations.
- Add pkgconfig(mobile-broadband-provider-info) BuildRequires: New
dependency.
2018-06-25 - bjorn.lie@gmail.com
- Update to version 1.8.14:
+ Fix an applet crash on disconnect.
+ Fix VPN icons in AppIndicator mode.
+ Provide (limited) secret agent service even when a keyring is
unavailable.
+ Fix saving of connections with "always ask" EAP secrets.
+ Register editor windows as GtkApplication windows, so that the
editor quits at the right time with --edit option.
+ The AppStream metadata is now in /usr/share/metainfo as
recommended by the specification.
+ Updated translations.
- Drop nma-fix-applet-segfault.patch: Fixed upstream.
2018-06-17 - bjorn.lie@gmail.com
- Add nma-fix-applet-segfault.patch: NMNetworkMenuItem: Don't
double-free priv->dupes, fix segfault on startup (boo#1097908,
glgo#GNOME/network-manager-applet#2).
2018-05-28 - bjorn.lie@gmail.com
- Update to version 1.8.12:
+ Allow creation of PPPoE connection without a parent interface.
+ Add an option to set a connection as Metered.
+ Make the form layout consistent with GNOME UI style.
+ Convert editor into a GtkApplication with an app menu.
+ Fix a potential crash in the certificate picker with no
modules.
+ Fix build warnings with GCC 8.
+ Support building against Ayatana AppIndicator.
+ Updated translations.
- Drop upstream fixed patches:
+ 0001-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch
+ 0002-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch
2018-04-14 - bjorn.lie@gmail.com
- Following changes in NetworkManager:
+ Pass libnm_gtk=false and without-libnm-gtk to meson/configure.
+ Drop no longer needed pkgconfig(NetworkManager),
pkgconfig(libnm-glib), pkgconfig(libnm-glib-vpn) and
pkgconfig(libnm-util) BuildRequires.
+ Drop no longer built subpackages: libnm-gtk%%{sover},
typelib-1_0-NMGtk-1_0 and libnm-gtk-devel.
+ No longer handle libnm-gtk%%{sover} in post(un).
+ Drop currently disabled
nm-applet-probe-radius-server-cert.patch: Obsolete since patch
is no longer present in NetworkManager, following this, drop
define with_cacert_patch and conditionals.
2018-03-28 - sflees@suse.de
- Re enable appindicator in autotools BuildRequires
- Add feature-app-indicator-desktop-file.patch to launch the startup
application with appindicator support and add a delay to ensure
that the desktop's systray service is running beforehand.

See Also

Package Description
NetworkManager-devel-1.16.0-3.1.i586.rpm Libraries and headers for adding NetworkManager support to applications
NetworkManager-devel-1.16.0-3.1.x86_64.rpm Libraries and headers for adding NetworkManager support to applications
NetworkManager-devel-32bit-1.16.0-3.1.x86_64.rpm Libraries and headers for adding NetworkManager support to applications
NetworkManager-fortisslvpn-1.2.10-1.1.i586.rpm NetworkManager VPN plugin for Fortinet compatible SSLVPN
NetworkManager-fortisslvpn-1.2.10-1.1.x86_64.rpm NetworkManager VPN plugin for Fortinet compatible SSLVPN
NetworkManager-fortisslvpn-gnome-1.2.10-1.1.i586.rpm GNOME files for the NetworkManager SSLVPN plugin
NetworkManager-fortisslvpn-gnome-1.2.10-1.1.x86_64.rpm GNOME files for the NetworkManager SSLVPN plugin
NetworkManager-fortisslvpn-lang-1.2.10-1.1.noarch.rpm Translations for package NetworkManager-fortisslvpn
NetworkManager-iodine-1.2.0-3.3.i586.rpm NetworkManager VPN support for iodine
NetworkManager-iodine-1.2.0-3.3.x86_64.rpm NetworkManager VPN support for iodine
NetworkManager-iodine-gnome-1.2.0-3.3.i586.rpm NetworkManager VPN support for iodine
NetworkManager-iodine-gnome-1.2.0-3.3.x86_64.rpm NetworkManager VPN support for iodine
NetworkManager-iodine-lang-1.2.0-3.3.noarch.rpm Translations for package NetworkManager-iodine
NetworkManager-l2tp-1.2.12-1.1.i586.rpm NetworkManager VPN support for L2TP and L2TP/IPsec
NetworkManager-l2tp-1.2.12-1.1.x86_64.rpm NetworkManager VPN support for L2TP and L2TP/IPsec
Advertisement
Advertisement