DevIL-devel-1.7.8-8.6.i586.rpm


Advertisement

Description

DevIL-devel - Development package

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename DevIL-devel-1.7.8-8.6.i586.rpm
Package name DevIL-devel
Package version 1.7.8
Package release 8.6
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://openil.sourceforge.net/
License LGPL-2.1
Maintainer -
Download size 23.62 KB
Installed size 62.36 KB
Developer's Image Library (DevIL) is a programmer's library to develop
applications with very powerful image loading capabilities, yet is easy
for a developer to learn and use. Ultimate control of images is left
to the developer, so unnecessary conversions, etc. are not performed.
DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save,
convert, manipulate, filter and display a wide variety of image formats.
Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg,
.lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm,
.psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal,
.pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
DevIL currently supports the following APIs for display: OpenGL,
Windows GDI, SDL, DirectX and Allegro. Compilers that can compile
DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual
Basic, Power Basic and Dev-C++.
This package contains the development libraries and headers.

Alternatives

Package Version Architecture Repository
DevIL-devel-1.7.8-33.20.x86_64.rpm 1.7.8 x86_64 Games
DevIL-devel-1.7.8-33.20.i586.rpm 1.7.8 i586 Games
DevIL-devel-1.7.8-8.6.x86_64.rpm 1.7.8 x86_64 openSUSE Oss
DevIL-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libIL1 = 1.7.8
pkgconfig(IL) -

Provides

Name Value
DevIL-devel = 1.7.8-8.6
DevIL-devel(x86-32) = 1.7.8-8.6
libdevil-devel = 1.7.8
pkgconfig(IL) = 1.7.8
pkgconfig(ILU) = 1.7.8
pkgconfig(ILUT) = 1.7.8

Obsoletes

Name Value
libdevil-devel < 1.7.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package DevIL-devel-1.7.8-8.6.i586.rpm
Source Package libdevil-1.7.8-8.6.src.rpm

Install Howto

Install DevIL-devel rpm package:

# zypper install DevIL-devel

Files

Path
/usr/include/IL/devil_cpp_wrapper.hpp
/usr/include/IL/il.h
/usr/include/IL/ilu.h
/usr/include/IL/ilu_region.h
/usr/include/IL/ilut.h
/usr/lib/libIL.so
/usr/lib/libILU.so
/usr/lib/libILUT.so
/usr/lib/pkgconfig/IL.pc
/usr/lib/pkgconfig/ILU.pc
/usr/lib/pkgconfig/ILUT.pc

Changelog

2018-05-12 - antoine.belvire@opensuse.org
- Fix %install_info_delete usage:
* It has to be performed in %preun, not %postun.
* See https://en.opensuse.org/openSUSE:Packaging_Conventions_RPM_Macros#.25install_info_delete.
2018-04-07 - wbauer@tmo.at
- Add jp2-remove-use-of-uchar-define.patch to fix build with newer
jasPer
2017-05-29 - dimstar@opensuse.org
- Drop lcms-devel BuildRequires and pass --disable-lcms to
configure: lcms upstream explicitly recommends no longer to use
this outdated version of the library (DevIL 1.8.0 seems to gain
lcms2 support).
2015-06-26 - antoine.belvire@laposte.net
- Fix compilation with GCC 5: add DevIL-1.7.8-gcc5.patch.
2013-10-02 - lnussel@suse.de
- make sure to not use il_wdp.c
2013-09-07 - tchvatal@suse.com
- Kill the mandriva code as they are not using it anyway.
- Add missing deps to build all features possible
- Move the ilur binary to separate tools package as it is GPL-3.0+
licensed.
2013-08-26 - tchvatal@suse.com
- Fix wrong require on -devel package.
2013-08-23 - mhrusecky@suse.cz
- Renamed spec and main package to be consistent
2012-02-19 - jengelh@medozas.de
- Remove redundant tags/sections from specfile
2011-08-30 - reddwarf@opensuse.org
- Remove false Requires from the devel package
- Add the full URL to the Source tag
- Use the original tarball without recompression

See Also

Package Description
DisplayCAL-3.7.2.0-2.1.i586.rpm Display calibration and profiling with a focus on accuracy and versatility
DisplayCAL-3.7.2.0-2.1.x86_64.rpm Display calibration and profiling with a focus on accuracy and versatility
FAudio-devel-19.03-1.1.i586.rpm FAudio Development Libraries
FAudio-devel-19.03-1.1.x86_64.rpm FAudio Development Libraries
FAudio-devel-32bit-19.03-1.1.x86_64.rpm FAudio Development Libraries
FastCGI-2.4.0-172.5.i586.rpm A Scalable, Open Extension to CGI
FastCGI-2.4.0-172.5.x86_64.rpm A Scalable, Open Extension to CGI
FastCGI-devel-2.4.0-172.5.i586.rpm A scalable, open extension to CGI
FastCGI-devel-2.4.0-172.5.x86_64.rpm A scalable, open extension to CGI
FirmwareUpdateKit-1.6-8.2.i586.rpm Assist with DOS-based firmware updates
FirmwareUpdateKit-1.6-8.2.x86_64.rpm Assist with DOS-based firmware updates
FlightGear-2018.3.2-1.2.i586.rpm Flight Simulator
FlightGear-2018.3.2-1.2.x86_64.rpm Flight Simulator
FlightGear-data-2018.3.2-1.1.noarch.rpm FlightGear base scenery and data files
FlightGear-docs-2018.3.2-1.1.noarch.rpm FlightGear Documentation
Advertisement
Advertisement