libexempi-devel-2.4.5-36.7.i586.rpm


Advertisement

Description

libexempi-devel - Development files for the Exempi XMP support library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Multimedia Libs all
Package name libexempi-devel
Package version 2.4.5
Package release 36.7
Package architecture i586
Package type rpm
Installed size 48.66 KB
Download size 25.39 KB
Official Mirror ftp.gwdg.de
Exempi is a library for XMP metadata parsing and doing I/O with it.
This subpackage contains the header files for building applications
with Exempi.

Alternatives

Package Version Architecture Repository
libexempi-devel-2.4.5-36.7.x86_64.rpm 2.4.5 x86_64 openSUSE Multimedia Libs
libexempi-devel-2.4.5-1.1.i586.rpm 2.4.5 i586 openSUSE Oss
libexempi-devel-2.4.5-1.1.x86_64.rpm 2.4.5 x86_64 openSUSE Oss
libexempi-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
libexempi3 = 2.4.5

Provides

Name Value
libexempi-devel = 2.4.5-36.7
libexempi-devel(x86-32) = 2.4.5-36.7
pkgconfig(exempi-2.0) = 2.4.5

Download

Type URL
Binary Package libexempi-devel-2.4.5-36.7.i586.rpm
Source Package exempi-2.4.5-36.7.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ opensuse-multimedia-libs
  2. Install libexempi-devel rpm package:
    # zypper install libexempi-devel

Files

Path
/usr/include/exempi-2.0/
/usr/include/exempi-2.0/exempi/xmp++.hpp
/usr/include/exempi-2.0/exempi/xmp.h
/usr/include/exempi-2.0/exempi/xmpconsts.h
/usr/include/exempi-2.0/exempi/xmperrors.h
/usr/lib/libexempi.so
/usr/lib/pkgconfig/exempi-2.0.pc
/usr/share/doc/packages/libexempi-devel/COPYING
/usr/share/doc/packages/libexempi-devel/ChangeLog
/usr/share/doc/packages/libexempi-devel/README

Changelog

2018-03-14 - jengelh@inai.de
- Extend descriptions.
2018-03-14 - kbabioch@suse.com
- Update to 2.4.5:
* Fix a buffer overflow in the PSD parser. (CVE-2018-7730 bnc#1085295)
* Fix a buffer overflow in the TIFF parser. (CVE-2018-7728 bnc#1085297)
* Fix a buffer overflow in PostScript parser. (CVE-2018-7729 bnc#1085296)
* Fix a null dereference in WEBP parser. (CVE-2018-7731 bnc#1085294)
* Properly initialize pointers in WEBP.
* Fix an infinite loop in RIFF parser.
* Fix an infinite loop in QuickTime parser.
* Fix an infinite loop in ASF parser.
* Adjust minimum version for gcc in documentation.
* Fix a buffer overrun, memcpy() on overlapping regions, use after free in
the exception handling.  Fix a fatal assert with corrupt WEBP.
* Fix a crash on a corrupt file.
* Upgrade XMPCore to Adobe XMP CC 2014.12.
* New flag to optimize layout on MPEG4 files.
* GoPro MPEG4 video files support.
* Improved JPEG support.
* iXML support in WAVE files.
* Several bugs and memory leaks fixes.
* Changes from Adobe XMP CC 2013.06.
* Pluggable file handlers (not exposed yet in Exempi)
* Support for Exif 2.3 properties
* New RIFF file handler
* Better Postscript support.
* Lot of bug fixes.
* Now require (partial) C++11 support to compile (gcc 4.4.7 tested)
* WebP format handler (contributed: Frankie Dintino, The Atlantic)
* Several API improvements
* Fix potential crash with corrupt TIFF file.
* Fix header to pass -Wstrict-prototypes
2017-02-01 - adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
2015-11-22 - mpluskal@suse.com
- Add gpg signature
- Cleanup spec file with spec-cleaner
2014-12-26 - zaitor@opensuse.org
- Update to version 2.2.2:
+ Public header cleanup and documentation update.
+ Update Doxygen config.
+ fdo#73058: Add missing include for MacOS.
+ fdo#72810: Fix typo in date test in MP3 handler.
+ fdo#83313: Fix crash on invalid Exif (from Samsung).
+ Fix valgrind testing for xmpcore.sh.
+ Fix delete / delete[] mismatch in ID3_Support.hpp.
- Add baselibs.conf to Source to comply with current rules in
Factory.
2013-06-30 - zaitor@opensuse.org
- Update to version 2.2.1:
+ fdo#54011: Use POSIX API for files on MacOS.
+ fdo#58175: Replace OS X FlatCarbon headers.
+ Added a manpage for exempi(1).
+ Added the -n option to the command line for arbitrary
namespaces.
2012-02-26 - dmueller@suse.de
- fix build under qemu
2012-02-23 - vuntz@opensuse.org
- Update to version 2.2.0:
+ New 'exempi' command line tool.
+ Upgrade XMPCore to Adobe XMP 5.1.2
- Quicktime support now works without Quicktime.
- Reconciliation with ID3v2.
- "Blessed" 64-bits support (we already had it in exempi).
- Slight change in the way XMP are written for MWG compliance.
- Fixed a serious bug with RIFF.
- Change in the way local text encoding is dealt with.
- Alternative languages behave slightly differently by changing
how the default language property is managed.
- Probably a bunch of bugs fixed that I don't know about.
+ Update unit tests.
- Refactor the fixtures.
+ Use automake silent rules instead of shave. (build only)
+ "make dist" generate a bzip2 archive as well. (build only)
+ Remove some obsolete warning flags. (build only)
+ Build xmpcommandtool
+ Several new APIs.
+ Bug fixes: fdo#37747.
- Drop exempi-no-shave.patch: shave is not used upstream anymore.
- Drop libtool BuildRequires, autoreconf call and
- -disable-silent-rules that were used because of patch above.
- Create a tools subpackage for new exempi command line tool.
- Change group of libexempi3 from "Development/Libraries/C and C++"
to System/Libraries.
- Use V=1 during the build to get a verbose build.
2011-09-30 - coolo@suse.com
- use original tar
2011-09-30 - coolo@suse.com
- add libtool as buildrequire to make the spec file more reliable

See Also

Package Description
libexempi3-2.4.5-36.7.i586.rpm XMP support library
libexempi3-2.4.5-36.7.x86_64.rpm XMP support library
libexempi3-32bit-2.4.5-36.7.x86_64.rpm XMP support library
libffado-devel-2.4.0-88.19.i586.rpm Development files for ffado
libffado-devel-2.4.0-88.19.x86_64.rpm Development files for ffado
libffado2-2.4.0-88.19.i586.rpm FireWire 1394 support for audio devices
libffado2-2.4.0-88.19.x86_64.rpm FireWire 1394 support for audio devices
libffado2-32bit-2.4.0-88.19.x86_64.rpm FireWire 1394 support for audio devices
libffms2-4-2.23.1-4.20.i586.rpm Wrapper library around libffmpeg
libffms2-4-2.23.1-4.20.x86_64.rpm Wrapper library around libffmpeg
libffms2-4-32bit-2.23.1-4.20.x86_64.rpm Wrapper library around libffmpeg
libffms2-devel-2.23.1-4.20.i586.rpm Wrapper library around libffmpeg
libffms2-devel-2.23.1-4.20.x86_64.rpm Wrapper library around libffmpeg
libfftw3-3-3.3.6-81.3.i586.rpm Discrete Fourier Transform (DFT) C Subroutine Library
libfftw3-3-3.3.6-81.3.x86_64.rpm Discrete Fourier Transform (DFT) C Subroutine Library
Advertisement
Advertisement