fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-81.5.i586.rpm


Advertisement

Description

fftw3_3_3_6-gnu-mpich-hpc-devel-static - Static libraries for fftw3

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Multimedia Libs all
Package name fftw3_3_3_6-gnu-mpich-hpc-devel-static
Package version 3.3.6
Package release 81.5
Package architecture i586
Package type rpm
Installed size 23.65 MB
Download size 12.67 MB
Official Mirror ftp.gwdg.de
Libraries to build statically linked applications with fftw3.

Alternatives

Package Version Architecture Repository
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-81.5.x86_64.rpm 3.3.6 x86_64 openSUSE Multimedia Libs
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-10.6.i586.rpm 3.3.6 i586 openSUSE Education
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-10.6.x86_64.rpm 3.3.6 x86_64 openSUSE Education
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-7.1.i586.rpm 3.3.6 i586 openSUSE Oss
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-7.1.x86_64.rpm 3.3.6 x86_64 openSUSE Oss
fftw3_3_3_6-gnu-mpich-hpc-devel-static - - -

Requires

Name Value
fftw3_3_3_6-gnu-mpich-hpc-devel -

Provides

Name Value
fftw3_3_3_6-gnu-mpich-hpc-devel-static = 3.3.6-81.5
fftw3_3_3_6-gnu-mpich-hpc-devel-static(x86-32) = 3.3.6-81.5
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_mpi.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_omp.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_threads.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_mpi.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_omp.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_threads.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_mpi.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_omp.la) -
libtool(/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_threads.la) -

Download

Type URL
Binary Package fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-81.5.i586.rpm
Source Package fftw3_3_3_6-gnu-mpich-hpc-3.3.6-81.5.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ opensuse-multimedia-libs
  2. Install fftw3_3_3_6-gnu-mpich-hpc-devel-static rpm package:
    # zypper install fftw3_3_3_6-gnu-mpich-hpc-devel-static

Files

Path
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3.a
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_mpi.a
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_mpi.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_omp.a
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_omp.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_threads.a
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3_threads.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_mpi.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_omp.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3f_threads.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_mpi.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_omp.la
/usr/lib/hpc/gnu8/mpich/fftw3/3.3.6/lib/libfftw3l_threads.la

Changelog

2018-05-31 - antoine.belvire@opensuse.org
- Fix %install_info_delete usage.
2018-02-26 - eich@suse.com
- Add support for openmpi2 for the HPC build (FATE#325089).
2018-02-22 - nmoreychaisemartin@suse.com
- Switch to openmpi2 instead of openmpi (bsc#1082302),
apart from ppc64 as openmpi2 does not support it.
2018-01-22 - eich@suse.com
- Fix typo in flavor gnu7-hpc settings.
2018-01-19 - eich@suse.com
- Change the name of the MPI version of the module file directory
to pfftw3 to distinguish it from the 'serial' one (boo#1075933).
2018-01-12 - eich@suse.com
- Disable the openmpi3 flavor in some products.
2018-01-05 - eich@suse.com
- Add gcc7 as additional compiler flavor for HPC on SLES.
- Fix library package requires - use HPC macro (boo#1074890).
- Add support for mpich and openmpi3 for HPC.
2017-11-14 - eich@suse.com
- Fix library package dependencies - limit certain
dependencies to HPC packages.
2017-11-12 - eich@suse.com
- Fix HPC library requires package and modules file.
2017-11-07 - eich@suse.com
- update to 3.3.6-pl2
* Bugfix: MPI Fortran-03 headers were missing in FFTW 3.3.6-pl1.
* Bugfix: FFTW 3.3.6 had the wrong libtool version number, and generated
shared libraries of the form libfftw3.so.2.6.6 instead of
libfftw3.so.3.*.
* The fftw_make_planner_thread_safe() API introduced in 3.3.5 didn't
work, and this 3.3.6 fixes it.  Sorry about that.
* compilation fixes for IBM XLC
* compilation fixes for threads on Windows
* fix SIMD autodetection on amd64 when (_MSC_VER > 1500)

See Also

Package Description
fftw3_3_3_6-gnu-mvapich2-hpc-devel-3.3.6-81.5.i586.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-mvapich2-hpc-devel-3.3.6-81.5.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-mvapich2-hpc-devel-static-3.3.6-81.5.i586.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-mvapich2-hpc-devel-static-3.3.6-81.5.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi1-hpc-devel-3.3.6-81.5.i586.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi1-hpc-devel-3.3.6-81.5.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi1-hpc-devel-static-3.3.6-81.5.i586.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi1-hpc-devel-static-3.3.6-81.5.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi2-hpc-devel-3.3.6-81.5.i586.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi2-hpc-devel-3.3.6-81.5.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi2-hpc-devel-static-3.3.6-81.5.i586.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi2-hpc-devel-static-3.3.6-81.5.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi3-hpc-devel-3.3.6-81.6.i586.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi3-hpc-devel-3.3.6-81.6.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi3-hpc-devel-static-3.3.6-81.6.i586.rpm Static libraries for fftw3
Advertisement
Advertisement