alsa-plugins-1.1.6-129.1.i586.rpm


Advertisement

Description

alsa-plugins - Extra Plug-Ins for the ALSA Library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Multimedia Libs all
Package name alsa-plugins
Package version 1.1.6
Package release 129.1
Package architecture i586
Package type rpm
Installed size 135.42 KB
Download size 62.73 KB
Official Mirror ftp.gwdg.de
This package contains the extra plug-ins for the ALSA library.

Alternatives

Package Version Architecture Repository
alsa-plugins-1.1.6-129.1.x86_64.rpm 1.1.6 x86_64 openSUSE Multimedia Libs
alsa-plugins-1.1.5-1.1.i586.rpm 1.1.5 i586 openSUSE Oss
alsa-plugins-1.1.5-1.1.x86_64.rpm 1.1.5 x86_64 openSUSE Oss
alsa-plugins - - -

Requires

Name Value
libasound.so.2 -
libasound.so.2(ALSA_0.9) -
libc.so.6(GLIBC_2.15) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -

Provides

Name Value
alsa-plugins = 1.1.6-129.1
alsa-plugins(x86-32) = 1.1.6-129.1
libasound_module_ctl_arcam_av.so -
libasound_module_ctl_oss.so -
libasound_module_pcm_oss.so -
libasound_module_pcm_upmix.so -
libasound_module_pcm_usb_stream.so -
libasound_module_pcm_vdownmix.so -
libasound_module_rate_speexrate.so -

Download

Type URL
Binary Package alsa-plugins-1.1.6-129.1.i586.rpm
Source Package alsa-plugins-1.1.6-129.1.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ opensuse-multimedia-libs
  2. Install alsa-plugins rpm package:
    # zypper install alsa-plugins

Files

Path
/usr/lib/alsa-lib/libasound_module_ctl_arcam_av.so
/usr/lib/alsa-lib/libasound_module_ctl_oss.so
/usr/lib/alsa-lib/libasound_module_pcm_oss.so
/usr/lib/alsa-lib/libasound_module_pcm_upmix.so
/usr/lib/alsa-lib/libasound_module_pcm_usb_stream.so
/usr/lib/alsa-lib/libasound_module_pcm_vdownmix.so
/usr/lib/alsa-lib/libasound_module_rate_speexrate.so
/usr/lib/alsa-lib/libasound_module_rate_speexrate_best.so
/usr/lib/alsa-lib/libasound_module_rate_speexrate_medium.so
/usr/share/doc/packages/alsa-plugins/README-arcam-av
/usr/share/doc/packages/alsa-plugins/README-pcm-oss
/usr/share/doc/packages/alsa-plugins/speexrate.txt
/usr/share/doc/packages/alsa-plugins/upmix.txt
/usr/share/doc/packages/alsa-plugins/vdownmix.txt
/usr/share/licenses/alsa-plugins/COPYING

Changelog

2018-05-04 - olaf@aepfle.de
- Use ffmpeg3 versions of pkgconfig(libav*)
2018-04-23 - bjorn.lie@gmail.com
- Replace libavcodec-devel with pkgconfig(libavcodec),
pkgconfig(libavutil) and pkgconfig(libavresample) BuildRequires
and version them to less than the symbol versions provided by
ffmpeg4 branch until upstream catches up. Currently provided by
new ffmpeg3 compatability package.
2018-04-04 - tiwai@suse.de
- Update to alsa-plugins 1.1.6:
* Change FSF address (Franklin Street)
* jack: Write only valid values to the internal hw_ptr
* jack: Use boundary as hw_ptr wrap around
* jack: Do not Xrun the ALSA buffer
* jack: Report Xruns to user application
* jack: Use correct parameter order for snd_pcm_areas_silence()
- Remove the build conditions for too old distros
- Use %license file tag
- Enable avcodec build for SLE15, too
2017-11-14 - tiwai@suse.de
- Update to alsa-plugins 1.1.5:
* pulse: prevent double-free when pulse_hw_constraint returns
error
2017-08-29 - tiwai@suse.de
- Disable avcodec-related plugins for SLE packages
2017-05-16 - tiwai@suse.de
- Update to alsa-plugins 1.1.4:
* extend configure script to disable more stuff
* including previous fix for libavcodec
- Obsoleted patch:
0001-configure-Fix-detection-of-avcodec.h.patches
2017-05-03 - tiwai@suse.de
- Fix the detection of libavcodec header files:
0001-configure-Fix-detection-of-avcodec.h.patches
- Enable the build of a52 and lavcrate plugins for openSUSE
2016-12-09 - zaitor@opensuse.org
- Own alsa-lib dir, needed due to changes in alsa.
2016-03-31 - tiwai@suse.de
- Update to alsa-plugins 1.1.1:
including all previous fixes, fixes of a52 plugin for the recent
ffmpeg versions
- Delete obsoleted patches:
0001-speex-Add-missing-include-config.h.patch
0002-a52-fix-reported-input-channel-order.patch
0003-pph-include-config.h-from-rate_speexrate.c.patch
2016-02-03 - tiwai@suse.de
- Backport upstream fixes: build fixes with the recent ffmpeg
0001-speex-Add-missing-include-config.h.patch
0002-a52-fix-reported-input-channel-order.patch
0003-pph-include-config.h-from-rate_speexrate.c.patch
- Drop the obsoleted patch:
alsa-plugins-include-config.h.patch

See Also

Package Description
alsa-plugins-32bit-1.1.6-129.1.x86_64.rpm Extra Plug-Ins for the ALSA Library
alsa-plugins-a52-1.1.6-129.1.i586.rpm A52 Output Plug-In for the ALSA Library
alsa-plugins-a52-1.1.6-129.1.x86_64.rpm A52 Output Plug-In for the ALSA Library
alsa-plugins-jack-1.1.6-129.1.i586.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-jack-1.1.6-129.1.x86_64.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-jack-32bit-1.1.6-129.1.x86_64.rpm JACK I/O Plug-In for the ALSA Library
alsa-plugins-lavcrate-1.1.6-129.1.i586.rpm Rate Converter Plug-In for the ALSA Library using libavcodec
alsa-plugins-lavcrate-1.1.6-129.1.x86_64.rpm Rate Converter Plug-In for the ALSA Library using libavcodec
alsa-plugins-maemo-1.1.6-129.1.i586.rpm Maemo Plug-Ins for the ALSA Library
alsa-plugins-maemo-1.1.6-129.1.x86_64.rpm Maemo Plug-Ins for the ALSA Library
alsa-plugins-maemo-32bit-1.1.6-129.1.x86_64.rpm Maemo Plug-Ins for the ALSA Library
alsa-plugins-pulse-1.1.6-129.1.i586.rpm Pulseaudio Plug-In for the ALSA Library
alsa-plugins-pulse-1.1.6-129.1.x86_64.rpm Pulseaudio Plug-In for the ALSA Library
alsa-plugins-pulse-32bit-1.1.6-129.1.x86_64.rpm Pulseaudio Plug-In for the ALSA Library
alsa-plugins-samplerate-1.1.6-129.1.i586.rpm Samplerate Plug-In for the ALSA Library
Advertisement
Advertisement