rhino-1.7R3-61.1.noarch.rpm


Advertisement

Description

rhino - JavaScript for Java

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE JAVA all
Package name rhino
Package version 1.7R3
Package release 61.1
Package architecture noarch
Package type rpm
Installed size 1.17 MB
Download size 1.09 MB
Official Mirror ftp.gwdg.de
Rhino is an open-source implementation of JavaScript written entirely
in Java. It is typically embedded into Java applications to provide
scripting to end users.

Alternatives

Package Version Architecture Repository
rhino-1.7R3-20.3.noarch.rpm 1.7R3 noarch openSUSE Oss
rhino - - -

Requires

Name Value
bea-stax-api -
jline -
xmlbeans -

Provides

Name Value
rhino = 1.7R3-61.1

Download

Type URL
Binary Package rhino-1.7R3-61.1.noarch.rpm
Source Package rhino-1.7R3-61.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Tumbleweed/ opensuse-java
  2. Install rhino rpm package:
    # zypper install rhino

Files

Path
/usr/bin/rhino
/usr/bin/rhino-debugger
/usr/bin/rhino-idswitch
/usr/bin/rhino-jsc
/usr/share/doc/packages/rhino/LICENSE.txt
/usr/share/java/js.jar
/usr/share/java/rhino-examples.jar
/usr/share/java/rhino.jar

Changelog

2017-10-03 - fstrba@suse.com
- Don't require java-1_5_0-gcj-compat-devel, since it is bound to
go
- Require java-devel >= 1.6
- Specify java source and target level 6 to allow buiding with jdk9
2017-09-15 - fstrba@suse.com
- Make build with the new version of java-1_5_0-gcj-compat, where
javac is not just a simple link to gcj, but a wrapper script that
runs Eclipse Compiler for Java(tm)
- Make buildable with different versions of OpenJDK
2017-06-09 - tchvatal@suse.com
- Drop maven depmap so we can actually bootstrap
2017-05-19 - dziolkowski@suse.com
- New build dependency: javapackages-local
- spec cleaned using spec-cleaner
2017-02-10 - dimstar@opensuse.org
- Revert back to using gcj: it is going to stay around for a while
longer and it helps avoiding bootstrap cycles.
2017-01-05 - tchvatal@suse.com
- Build with java not gcj as it gets deprecated
2015-03-18 - tchvatal@suse.com
- Fix build with new javapackages-tools
2013-09-09 - tchvatal@suse.com
- Move from jpackage-utils to javapackage-tools
2013-08-23 - mvyskocil@suse.com
- disable javadoc build
- use add_maven_depmap from new javapackages-tools
- workaround xbean.jar definition problem
2013-01-07 - mvyskocil@suse.com
- remove xerces-j2-bootstrap depenency (bnc#789163)

See Also

Package Description
rhino-demo-1.7R3-61.1.noarch.rpm JavaScript for Java
sat4j-2.3.2-46.1.noarch.rpm A library of SAT solvers written in Java
saxon6-6.5.5-39.1.noarch.rpm The SAXON XSLT Processor from Michael Kay
saxon6-aelfred-6.5.5-39.1.noarch.rpm Java XML parser
saxon6-demo-6.5.5-39.1.noarch.rpm Demos for saxon6
saxon6-fop-6.5.5-39.1.noarch.rpm FOP support for saxon6
saxon6-javadoc-6.5.5-39.1.noarch.rpm Javadoc for saxon6
saxon6-jdom-6.5.5-39.1.noarch.rpm JDOM support for saxon6
saxon6-manual-6.5.5-39.1.noarch.rpm Manual for saxon6
saxon6-scripts-6.5.5-39.1.noarch.rpm Utility scripts for saxon6
saxon8-B.8.8-252.1.noarch.rpm Java Basic XPath 2.0, XSLT 2.0, and XQuery 1.0 implementation
saxon8-demo-B.8.8-252.1.noarch.rpm Demos for saxon8
saxon8-dom-B.8.8-252.1.noarch.rpm DOM support for saxon8
saxon8-javadoc-B.8.8-252.1.noarch.rpm Javadoc for saxon8
saxon8-jdom-B.8.8-252.1.noarch.rpm JDOM support for saxon8
Advertisement
Advertisement