neard-0.15-26.18.x86_64.rpm


Advertisement

Description

neard - NFC for Linux

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Hardware all
Package name neard
Package version 0.15
Package release 26.18
Package architecture x86_64
Package type rpm
Installed size 489.58 KB
Download size 163.85 KB
Official Mirror ftp.gwdg.de
NFC support for Linux.

Alternatives

Package Version Architecture Repository
neard-0.15-26.18.i586.rpm 0.15 i586 openSUSE Hardware
neard-0.15-2.2.i586.rpm 0.15 i586 openSUSE Oss
neard-0.15-2.2.x86_64.rpm 0.15 x86_64 openSUSE Oss
neard - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libdbus-1.so.3()(64bit) -
libdbus-1.so.3(LIBDBUS_1_3)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libglib-2.0.so.0()(64bit) -
libnl-3.so.200()(64bit) -
libnl-3.so.200(libnl_3)(64bit) -
libnl-genl-3.so.200()(64bit) -
libnl-genl-3.so.200(libnl_3)(64bit) -
systemd -

Provides

Name Value
config(neard) = 0.15-26.18
neard = 0.15-26.18
neard(x86-64) = 0.15-26.18

Download

Type URL
Binary Package neard-0.15-26.18.x86_64.rpm
Source Package neard-0.15-26.18.src.rpm

Install Howto

  1. Add the openSUSE Hardware repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/hardware/openSUSE_Tumbleweed/ opensuse-hardware
  2. Install neard rpm package:
    # zypper install neard

Files

Path
/etc/dbus-1/system.d/org.neard.conf
/usr/bin/nfctool
/usr/lib/nfc/neard
/usr/lib/systemd/system/neard.service
/usr/lib/udev/rules.d/99-neard.rules
/usr/share/doc/packages/neard/AUTHORS
/usr/share/doc/packages/neard/COPYING
/usr/share/doc/packages/neard/ChangeLog
/usr/share/doc/packages/neard/README
/usr/share/man/man1/nfctool.1.gz
/usr/share/man/man5/neard.conf.5.gz
/usr/share/man/man8/neard.8.gz

Changelog

2015-03-06 - dimstar@opensuse.org
- BuildRequire pkgconfig(systemd) in place of systemd-devel: the
smaller dependency is perfectly sufficient for this package.
2015-03-05 - p.drouand@gmail.com
- Update to version 0.15
* Added iso15693 (NFC type5) support.
* Added Secure Element support (seeld).
* Added iso14443-B (NFC type4b) support.
* Added NFC type5 RMB (Read Multiple Block) support.
* Fixed NFC type1 dynamic read.
* Fixed NFC type1 check_presence to only read the tag ID.
* Fixed NFC type2 CC magic number check.
* Fixed NFC type4 NDEF detection and handling code.
* Fixed NFC type4 check_presence implementation.
* Fixed PHDC coding style and potential bugs.
* Fixed the constant poll loop to retry on busy adapters.
* Fixed an agent memory leak.
* Fixed and cleaned the build system.
- Remove obsolete macros
2014-06-10 - acho@susue.com
- Move nfctool from neard-test to neard and neard-test Require neard.
(bnc#881554)
2014-05-21 - jsegitz@novell.com
- added necessary macros for systemd files
2014-02-02 - jengelh@inai.de
- Use libnl3 instead of libnl1
- Remove redundant %clean section, more robust make install call,
and a simplified file list
2014-01-22 - acho@suse.com
- add %doc AUTHORS COPYING ChangeLog README
2014-01-17 - acho@suse.com
- Remove Unnecessary BuildRequires:  systemd and systemd-devel.
2014-01-16 - acho@suse.com
- Clean empty %post.(bnc#837978)
- Add 'send_destination' to org.neard.conf.(bnc#837978)
- Add 'ACTION=="add"' for udev rule.(bnc#837978)
2014-01-15 - acho@suse.com
- use --prefix=%_prefix, kill the %clean section. kill has_systemd.
(bnc#837978)
- add udev rules to enable this service by systemd.
- remove systemctl from %post.
2013-12-18 - cfarrell@suse.com
- license update: GPL-2.0
majority of files have GPL-2.0 (only) license

See Also

Package Description
neard-devel-0.15-26.18.i586.rpm Files needed for NFC development
neard-devel-0.15-26.18.x86_64.rpm Files needed for NFC development
neard-test-0.15-26.18.i586.rpm Files needed for NFC development
neard-test-0.15-26.18.x86_64.rpm Files needed for NFC development
nfc-eventd-0.1.7-16.38.i586.rpm NFC event daemon
nfc-eventd-0.1.7-16.38.x86_64.rpm NFC event daemon
nfcutils-0.3.2-10.30.i586.rpm Near Field Communication (NFC) utilities
nfcutils-0.3.2-10.30.x86_64.rpm Near Field Communication (NFC) utilities
nodejs-mraa-1.9.0-27.4.i586.rpm Nodes bindings for mraa
nodejs-mraa-1.9.0-27.4.x86_64.rpm Nodes bindings for mraa
nodejs-upm-1.6.0-15.4.i586.rpm Nodejs bindings for upm
nodejs-upm-1.6.0-15.4.x86_64.rpm Nodejs bindings for upm
numad-0.5.20130522-10.24.i586.rpm Userspace daemon that automatically binds workloads to NUMA nodes
numad-0.5.20130522-10.24.x86_64.rpm Userspace daemon that automatically binds workloads to NUMA nodes
nut-2.7.4-96.1.i586.rpm Network UPS Tools Core (Uninterruptible Power Supply Monitoring)
Advertisement
Advertisement