libirman-devel-0.5.2-17.20.i586.rpm


Advertisement

Description

libirman-devel - Development files for libirman

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Hardware all
Package name libirman-devel
Package version 0.5.2
Package release 17.20
Package architecture i586
Package type rpm
Installed size 54.25 KB
Download size 24.01 KB
Official Mirror ftp.gwdg.de
libirman is a general purpose library for programs to use in order to
receive infrared signals via irman-compatible hardware.
Devel files for libirman from the lirc project.

Alternatives

Package Version Architecture Repository
libirman-devel-0.5.2-17.20.x86_64.rpm 0.5.2 x86_64 openSUSE Hardware
libirman-devel-0.5.2-3.4.i586.rpm 0.5.2 i586 openSUSE Oss
libirman-devel-0.5.2-3.4.x86_64.rpm 0.5.2 x86_64 openSUSE Oss
libirman-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libirman0 = 0.5.2

Provides

Name Value
libirman-devel = 0.5.2-17.20
libirman-devel(x86-32) = 0.5.2-17.20
pkgconfig(libirman) = 0.5.2

Download

Type URL
Binary Package libirman-devel-0.5.2-17.20.i586.rpm
Source Package libirman-0.5.2-17.20.src.rpm

Install Howto

  1. Add the openSUSE Hardware repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/hardware/openSUSE_Tumbleweed/ opensuse-hardware
  2. Install libirman-devel rpm package:
    # zypper install libirman-devel

Files

Path
/usr/include/irman.h
/usr/lib/libirman.so
/usr/lib/pkgconfig/libirman.pc
/usr/share/doc/packages/libirman-devel/COPYING
/usr/share/doc/packages/libirman-devel/COPYING.lib
/usr/share/doc/packages/libirman-devel/NEWS
/usr/share/doc/packages/libirman-devel/README

Changelog

2017-03-05 - mpluskal@suse.com
- Make building of lirc plugin conditional (boo#1027687)
2017-02-21 - mpluskal@suse.com
- Build lirc plugin
- Rename common and utils subpackages
2016-11-27 - jengelh@inai.de
- Update descriptions
2016-11-24 - mpluskal@suse.com
- Update to version 0.5.2:
* Plugin: Fix logging issues.
* Configure the sys/file.h header (Debian #436563).
* Build: Fix parallel make glitch.
- Changes for version 0.5.1:
* Fix FTBS bug for --enable-swtest
* Clean up plugin installation.
- Update project and download url
- Move config file to subpackage
2015-10-24 - mpluskal@suse.com
- Update to 0.5.0
* Always build the irman.test* tools.
* If compiled with lirc > 0.9.3, builds the irman lirc plugin
(i. e., driver).
* Add ChangeLog, AUTHORS + INSTALL to make package GNU-compatible
* Using a GNU make extension $(shell ...).
2015-09-07 - p.drouand@gmail.com
- Update to version 0.4.6
* Refreshing automake files and installation
* Add a pkgconfig file
- Remove obsolete dependencies
* autoconf
* automake
* libtool
- Add a dependency to pkg-config
2015-08-18 - mpluskal@suse.com
- Update license
2015-08-17 - mpluskal@suse.com
- Initial package for version 0.4.5 (based on
home:wolfi323:irman/libirman)

See Also

Package Description
libirman0-0.5.2-17.20.i586.rpm Library for irman access
libirman0-0.5.2-17.20.x86_64.rpm Library for irman access
libiw-devel-30.pre9-68.9.i586.rpm Tools for a wireless LAN
libiw-devel-30.pre9-68.9.x86_64.rpm Tools for a wireless LAN
libiw30-30.pre9-68.9.i586.rpm Tools for a wireless LAN
libiw30-30.pre9-68.9.x86_64.rpm Tools for a wireless LAN
libjaylink-0.2.0~git.20170831-13.5.i586.rpm USB interface library for J-Link
libjaylink-0.2.0~git.20170831-13.5.x86_64.rpm USB interface library for J-Link
libjaylink-devel-0.2.0~git.20170831-13.5.i586.rpm USB interface library for J-Link -- development files
libjaylink-devel-0.2.0~git.20170831-13.5.x86_64.rpm USB interface library for J-Link -- development files
libjaylink0-0.2.0~git.20170831-13.5.i586.rpm USB interface library for J-Link
libjaylink0-0.2.0~git.20170831-13.5.x86_64.rpm USB interface library for J-Link
liblittleb0-0.1.2-8.10.i586.rpm Bluetooth Low Energy library
liblittleb0-0.1.2-8.10.x86_64.rpm Bluetooth Low Energy library
liblur3-0.9.902-6.1.i586.rpm Logitech Unifying Receiver configuration library
Advertisement
Advertisement