libfprint-devel-0.6.0-51.73.x86_64.rpm


Advertisement

Description

libfprint-devel - Library for fingerprint reader support (developer files)

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Hardware all
Package name libfprint-devel
Package version 0.6.0
Package release 51.73
Package architecture x86_64
Package type rpm
Installed size 13.91 KB
Download size 15.91 KB
Official Mirror ftp.gwdg.de
This package contains the header files, static libraries and
development documentation for libfprint. If you like to develop
programs using libfprint, you will need to install this package.

Alternatives

Package Version Architecture Repository
libfprint-devel-0.6.0-51.73.i586.rpm 0.6.0 i586 openSUSE Hardware
libfprint-devel-0.6.0-1.12.i586.rpm 0.6.0 i586 openSUSE Oss
libfprint-devel-0.6.0-1.12.x86_64.rpm 0.6.0 x86_64 openSUSE Oss
libfprint-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
libfprint = 0.6.0
libfprint0 = 0.6.0

Provides

Name Value
libfprint-devel = 0.6.0-51.73
libfprint-devel(x86-64) = 0.6.0-51.73
pkgconfig(libfprint) = 0.6.0

Download

Type URL
Binary Package libfprint-devel-0.6.0-51.73.x86_64.rpm
Source Package libfprint-0.6.0-51.73.src.rpm

Install Howto

  1. Add the openSUSE Hardware repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/hardware/openSUSE_Tumbleweed/ opensuse-hardware
  2. Install libfprint-devel rpm package:
    # zypper install libfprint-devel

Files

Path
/usr/include/libfprint/fprint.h
/usr/lib64/libfprint.so
/usr/lib64/pkgconfig/libfprint.pc

Changelog

2015-02-07 - p.drouand@gmail.com
- Update to version 0.6.0
* Drivers:
- Reduce duplication between AES3500 and AES4000 drivers and
add support for AES3500 device
- Add support for UPEK 147e:2020 and Upek Eikon 2 devices
- Add EgisTec ES603 driver
- Add VFS5011 driver
- Always perform 5 scans for image enrollment
- Better verification with AES1660 driver
- Better verification for a number of AES drivers
* Library:
- Always use Pixman for image manipulation, gdk-pixbuf and ImageMagick
are not supported any more.
* Udev rules:
- Fix warning when USB hub or system does not support power management
- Add pkgconfig(pixman-1) build require; new upstream dependency
- Remove pkgconfig(gdk-pixbuf-2.0) build require; not needed anymore
2013-11-24 - crrodriguez@opensuse.org
-  define _udevrulesdir only if not already in place.
- run %udev_rules_update if such macro is defined
2013-09-21 - mailaender@opensuse.org
- Update to version 0.5.1:
+ Add support for 147e:2020 to upeke2 driver
+ Fix possible race condition, and cancellation in uru4000 driver
+ Add Microsoft keyboard to the suspend blacklist
+ Plenty of build fixes
- Adhere to https://en.opensuse.org/SourceUrls
- Rebased libfprint-install_examples.patch
- Removed libfprint-upeke2_add_147e_2020_id_support.patch as it is included now.
2013-05-20 - suse@bugs.jan.ritzerfeld.org
- upeke2: Add support for 147e:2020 ID (fdo#59320)
2013-04-17 - idonmez@suse.com
- Fix file conflicts
2013-04-14 - crrodriguez@opensuse.org
- fix -devel package requires,nowhere this library requires
pkgconfig(ImageMagick), pkgconfig(glib-2.0), pkgconfig(libusb-1.0)
pkgconfig(openssl), pkgconfig(zlib), not at linking time, not at
the headers..
2013-04-11 - crrodriguez@opensuse.org
- Place udev rules in the correct directory.
2013-04-01 - fisiu@opensuse.org
- Update to version 0.5.0:
+ Drivers:
- New VFS300/VFS301 driver
- New AES2550/AES2810 drivers
- New AES1660 driver
- New AES2660 driver
- New DigitalPersona URU4500 driver
- Avoid empty capture and improve image contrast in the
AES2501 and AES2550 drivers
- Update upektc driver, add support for Eikon Touch 300
- Fix UrU4000 image capture on ARM
+ Library:
- Fix global variable collisions with libusb and other system
headers
- Fix possible crash in NBIS image processing with some
fingerprints
+ Udev rules:
- Fix power control path for newer kernels
- Move udev rules to the correct directory
- Don't print duplicated udev rules
- Include udev rules in the tarball
- Allow disabling of udev rules for cross-compiling
- Add driver names in the generated rules
2012-09-05 - p.drouand@gmail.com
- Release 0.4.0 :
* Add support for Validity VFS101 (USB ID 138a:0001)
* Fix crasher when resizing a fingerprint image
* Fix wrong timeout being returned when either of
libusb or libfprint doesn't have a timeout
- Remove unnecessary "obsoletes" and "provides" libfprint0 package entries
- Fix URL
2012-08-27 - cfarrell@suse.com
- license update: LGPL-2.1+
No LGPL-2.1 "only" licenses found in the package

See Also

Package Description
libfprint-examples-0.6.0-51.73.i586.rpm Library for fingerprint reader support (example programs)
libfprint-examples-0.6.0-51.73.x86_64.rpm Library for fingerprint reader support (example programs)
libfprint0-0.6.0-51.73.i586.rpm Library for fingerprint reader support
libfprint0-0.6.0-51.73.x86_64.rpm Library for fingerprint reader support
libfprint0-32bit-0.6.0-51.73.x86_64.rpm Library for fingerprint reader support
libfreefare-devel-0.4.0-17.47.i586.rpm Development files for the Mifare card manipulation library
libfreefare-devel-0.4.0-17.47.x86_64.rpm Development files for the Mifare card manipulation library
libfreefare-tools-0.4.0-17.47.i586.rpm Tools for Mifare cards
libfreefare-tools-0.4.0-17.47.x86_64.rpm Tools for Mifare cards
libfreefare0-0.4.0-17.47.i586.rpm Library for Mifare card manipulations
libfreefare0-0.4.0-17.47.x86_64.rpm Library for Mifare card manipulations
libftdi0-binding-python-0.20-3.17.i586.rpm Python binding for libftdi
libftdi0-binding-python-0.20-3.17.x86_64.rpm Python binding for libftdi
libftdi0-devel-0.20-3.17.i586.rpm Header files and static libraries for libftdi
libftdi0-devel-0.20-3.17.x86_64.rpm Header files and static libraries for libftdi
Advertisement
Advertisement