mgba-0.6.3-7.5.i586.rpm


Advertisement

Description

mgba - Game Boy Advance emulator

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Emulators all
Package name mgba
Package version 0.6.3
Package release 7.5
Package architecture i586
Package type rpm
Installed size 6.49 MB
Download size 2.26 MB
Official Mirror ftp.gwdg.de
mGBA is a new generation of Game Boy Advance emulator with the goal
of being fast enough to run on lower end hardware.
Other goals include accurate enough emulation to provide a development
environment for homebrew software, a good workflow for tool-assist
runners, and a modern feature set for emulators that older emulators
may not support.

Alternatives

Package Version Architecture Repository
mgba-0.6.3-7.5.x86_64.rpm 0.6.3 x86_64 openSUSE Emulators
mgba - - -

Requires

Name Value
hicolor-icon-theme -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.11) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Multimedia.so.5 -
libQt5Multimedia.so.5(Qt_5) -
libQt5OpenGL.so.5 -
libQt5OpenGL.so.5(Qt_5) -
libQt5Widgets.so.5 -
libQt5Widgets.so.5(Qt_5) -
libSDL2-2.0.so.0 -
libc.so.6(GLIBC_2.3) -
libepoxy.so.0 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3.1) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.27) -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.12) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libz.so.1 -
libz.so.1(ZLIB_1.2.0) -
libzip.so.5 -

Provides

Name Value
application() -
application(mgba-qt.desktop) -
libmgba.so.0.6 -
mgba = 0.6.3-7.5
mgba(x86-32) = 0.6.3-7.5
mimehandler(application/x-agb-rom) -
mimehandler(application/x-gameboy-advance-rom) -
mimehandler(application/x-gba-rom) -

Download

Type URL
Binary Package mgba-0.6.3-7.5.i586.rpm
Source Package mgba-0.6.3-7.5.src.rpm

Install Howto

  1. Add the openSUSE Emulators repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Emulators/openSUSE_Tumbleweed/ opensuse-emulators
  2. Install mgba rpm package:
    # zypper install mgba

Files

Path
/usr/bin/mgba-qt
/usr/lib/libmgba.so.0.6
/usr/lib/libmgba.so.0.6.1
/usr/share/applications/mgba-qt.desktop
/usr/share/doc/packages/mgba/CHANGES
/usr/share/doc/packages/mgba/LICENSE
/usr/share/doc/packages/mgba/README.md
/usr/share/icons/hicolor/128x128/apps/mgba.png
/usr/share/icons/hicolor/16x16/apps/mgba.png
/usr/share/icons/hicolor/24x24/apps/mgba.png
/usr/share/icons/hicolor/256x256/apps/mgba.png
/usr/share/icons/hicolor/32x32/apps/mgba.png
/usr/share/icons/hicolor/48x48/apps/mgba.png
/usr/share/icons/hicolor/512x512/apps/mgba.png
/usr/share/icons/hicolor/64x64/apps/mgba.png
/usr/share/icons/hicolor/96x96/apps/mgba.png
/usr/share/man/man6/mgba-qt.6.gz
/usr/share/mgba/nointro.dat
/usr/share/mgba/shaders/
/usr/share/mgba/shaders/agb001.shader/agb001.fs
/usr/share/mgba/shaders/agb001.shader/manifest.ini
/usr/share/mgba/shaders/ags001.shader/ags001-light.fs
/usr/share/mgba/shaders/ags001.shader/ags001.fs
/usr/share/mgba/shaders/ags001.shader/manifest.ini
/usr/share/mgba/shaders/fish.shader/fish.fs
/usr/share/mgba/shaders/fish.shader/manifest.ini
/usr/share/mgba/shaders/gba-color.shader/gba-color.fs
/usr/share/mgba/shaders/gba-color.shader/manifest.ini
/usr/share/mgba/shaders/lcd.shader/lcd.fs
/usr/share/mgba/shaders/lcd.shader/manifest.ini
/usr/share/mgba/shaders/motion_blur.shader/manifest.ini
/usr/share/mgba/shaders/motion_blur.shader/motion_blur.fs
/usr/share/mgba/shaders/pixelate.shader/manifest.ini
/usr/share/mgba/shaders/scanlines.shader/manifest.ini
/usr/share/mgba/shaders/scanlines.shader/scanlines.fs
/usr/share/mgba/shaders/soften.shader/manifest.ini
/usr/share/mgba/shaders/soften.shader/soften.fs
/usr/share/mgba/shaders/vba_pixelate.shader/manifest.ini
/usr/share/mgba/shaders/vba_pixelate.shader/vba_pixelate.fs
/usr/share/mgba/shaders/vignette.shader/manifest.ini
/usr/share/mgba/shaders/vignette.shader/vignette.fs
/usr/share/mgba/shaders/wiiu.shader/manifest.ini
/usr/share/mgba/shaders/wiiu.shader/wiiu.fs
/usr/share/mgba/shaders/xbr-lv2.shader/manifest.ini
/usr/share/mgba/shaders/xbr-lv2.shader/xbr.fs
/usr/share/mgba/shaders/xbr-lv2.shader/xbr.vs
/usr/share/mgba/shaders/xbr-lv3.shader/manifest.ini
/usr/share/mgba/shaders/xbr-lv3.shader/xbr.fs
/usr/share/mgba/shaders/xbr-lv3.shader/xbr.vs

Changelog

2018-06-10 - opensuse-packaging@opensuse.org
- Update to version 0.6.3:
* CHANGES: Update for 0.6.3
* CHANGES: Update
* GBA Video: Fix OBJ blending regression (fix #1037)
* Revert "GBA Audio: Increase PSG volume (fixes #932)"
* Revert "GB Audio: Make audio unsigned with bias (fixes #749)"
* GB Video: Fix bad merge
* CHANGES: Update for 0.6.2
* Res: Update patrons for April
* Revert "GB: Cancel IRQs if interrupt is unasserted before dispatch (fixes #1000, #1003)"
* CMake: Add CMP0025 policy
2018-06-10 - kamikazow@opensuse.org
- Add Qt5.11_fix.patch to fix building with Qt 5.11
2018-04-15 - kamikazow@opensuse.org
- New upstream release 0.6.3
* GB Audio: Revert unsigned audio changes
* GB Video: Fix bad merge (fixes #1040)
* GBA Video: Fix OBJ blending regression (fixes #1037)
2018-04-04 - kamikazow@opensuse.org
- New upstream release 0.6.2
* https://mgba.io/2018/04/03/mgba-0.6.2/
2018-03-31 - kamikazow@opensuse.org
- Fix TW build
- Update to version 0.6.1.20180322+git.c623970d:
* Wii: Drawing polish (closes #988)
* Windows: Build fix
* CMake: Disable 'editline' for Win32 (#1017)
* Doc: Add "libepoxy" to msys/mingw-w64 dependencies
* GB Memory: Fix OAM DMA blocking regions (fixes #1013)
* GB: Cancel IRQs if interrupt is unasserted before dispatch (fixes #1000, #1003)
* Python: Fix package directory
* Qt: Fix opening in fullscreen (fixes #993)
* All: Update copyright year to 2018
* Doc: Fix the total download size of the msys toolchain
2017-11-27 - kamikazow@opensuse.org
- Update to version 0.6.1:
* VFS: Make VFile.truncate work growing files on PSV (fixes #885)
* GB Video: Fix read mode when enabling LCD
* GBA Cheats: Improve detection of raw cheats
* GBA Cheats: Slightly improve PARv3 detection
* GBA Cheats: Fix PARv3 multiline blocks (fixes #889)
* Test: Fix test suite post-Cheats
* Qt: Hide mouse immediately when loading
* Update CHANGES for 0.6.1
* CMake: Update patch level
* Res: Update patrons for October
- Fix Fedora 27 build
2017-07-16 - kamikazow@opensuse.org
- Update to version 0.6.0:
* Drop mgba-0.5.0-linkage.patch
* All: Do not install hicolor icons on Haiku.
* All: Use more GNUInstallDirs & don't install shaders if no GL.
* Core: Fix exiting rewind thread
* Qt: Updated Spanish translation
* SDL: Fix showing version number (fixes #794)
* All: Minor text fixes
* SDL: Fix cheats not loading
* Qt: Fix screen background improperly stretching
* All: Minor text fixes
* All: Update CHANGES for 0.6.0
2017-07-12 - kamikazow@opensuse.org
- Update to version 0.6b1:
* Fixes compilation on recent Tumbleweed snapshots
* Core: Improved threading interrupted detection
* GB MBC: Fix MBC7 sampling
* Python: GB core should expose memory
* Python: Improve GB SIO bindings
* LR35902: Fix decoding CB commands
* LR35902: Switch memory disassembly syntax to rgbds-style
* Core: Fix directory sets crashing on close if base isn't properly detached
* All: Revert setting minimum macOS version to 10.5
* GB Timer: Fix order-of-operations between & and +
* All: Update changes for 0.6 beta 1
2017-01-24 - kamikazow@opensuse.org
- Ported ROSA Linux package to Fedora and openSUSE

See Also

Package Description
mgba-sdl-0.6.3-7.5.i586.rpm Game Boy Advance (GBA) emulator (SDL2-based CLI version)
mgba-sdl-0.6.3-7.5.x86_64.rpm Game Boy Advance (GBA) emulator (SDL2-based CLI version)
mupen64plus-2.5-1.36.i586.rpm Nintendo 64 Emulator
mupen64plus-2.5-1.36.x86_64.rpm Nintendo 64 Emulator
mupen64plus-plugin-audio-sdl-2.5-1.36.i586.rpm SDL Audio Plugin for the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-audio-sdl-2.5-1.36.x86_64.rpm SDL Audio Plugin for the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-audio-sdl-2.5-2.5.i586.rpm SDL Audio Plugin for the Mupen64plus Nintendo 64 Emulator
mupen64plus-plugin-audio-sdl-2.5-2.5.x86_64.rpm SDL Audio Plugin for the Mupen64plus Nintendo 64 Emulator
mupen64plus-plugin-input-sdl-2.5-1.36.i586.rpm SDL Input Plugin for the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-input-sdl-2.5-1.36.x86_64.rpm SDL Input Plugin for the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-input-sdl-2.5-2.5.i586.rpm SDL Input Plugin for the Mupen64plus Nintendo 64 Emulator
mupen64plus-plugin-input-sdl-2.5-2.5.x86_64.rpm SDL Input Plugin for the Mupen64plus Nintendo 64 Emulator
mupen64plus-plugin-rsp-hle-2.5-1.36.i586.rpm RSP High-Level Emulation Plugin For the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-rsp-hle-2.5-1.36.x86_64.rpm RSP High-Level Emulation Plugin For the Mupen64Plus Nintendo 64 Emulator
mupen64plus-plugin-rsp-hle-2.5-2.5.i586.rpm RSP High-Level Emulation Plugin For the Mupen64plus Nintendo 64 Emulator
Advertisement
Advertisement