libspectrum8-1.4.4-1.2.i586.rpm


Advertisement

Description

libspectrum8 - Library for reading and writing ZX Spectrum disk/tape images and snapshots

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Emulators all
Package name libspectrum8
Package version 1.4.4
Package release 1.2
Package architecture i586
Package type rpm
Installed size 358.76 KB
Download size 119.02 KB
Official Mirror ftp.gwdg.de
Libspectrum is a library designed to make the input and output of some
ZX Spectrum emulator files slightly easier. It is intended to be usable
on Unix variants, Win32 and Mac OS X. Currently, it is mainly used by
Fuse, but other Spectrum emulator and utility authors are encouraged to
use it.

Alternatives

Package Version Architecture Repository
libspectrum8-1.4.4-1.2.x86_64.rpm 1.4.4 x86_64 openSUSE Emulators
libspectrum8 - - -

Requires

Name Value
/sbin/ldconfig -
libaudiofile.so.1 -
libbz2.so.1 -
libc.so.6(GLIBC_2.7) -
libgcrypt.so.20 -
libgcrypt.so.20(GCRYPT_1.6) -
libglib-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libz.so.1 -

Provides

Name Value
libspectrum.so.8 -
libspectrum8 = 1.4.4-1.2
libspectrum8(x86-32) = 1.4.4-1.2

Download

Type URL
Binary Package libspectrum8-1.4.4-1.2.i586.rpm
Source Package libspectrum-1.4.4-1.2.src.rpm

Install Howto

  1. Add the openSUSE Emulators repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Emulators/openSUSE_Tumbleweed/ opensuse-emulators
  2. Install libspectrum8 rpm package:
    # zypper install libspectrum8

Files

Path
/usr/lib/libspectrum.so.8
/usr/lib/libspectrum.so.8.8.14
/usr/share/doc/packages/libspectrum8/COPYING
/usr/share/man/man3/libspectrum.3.gz

Changelog

2018-07-06 - serbalgi@gmail.com
- Update to version 1.4.4
* Fix memory allocation in g_array_set_size().
* Fix TC2048 and TC2068 timings regression.
* Add peek block function for tape iterators.
2018-05-01 - serbalgi@gmail.com
- Update to version 1.4.2
* RZX files containing a snapshot which cannot be compressed are now
written correctly.
2017-10-12 - serbalgi@gmail.com
- Update to version 1.4.1
* Add support for MMC / SD card emulation in SPI mode.
* Add class recognition for MLT files.
2017-07-10 - serbalgi@gmail.com
- Update to version 1.3.5
* Add Multiface One/128/3 support.
* Add self-inflating buffer for writing binary files.
* Add class recognition for SCR files.
* Fix crash when saving CSW tapes.
* Work around invalid "used bits in last byte" field in TZX tapes.
* Save SpecDrum level as unsigned in SZX snapshots.
* Add support for storing Covox interface state.
2017-04-30 - serbalgi@gmail.com
- Update to version 1.3.3
* Silently skip PLTT blocks in SZX snapshots.
* Validate "used bits in last byte" field in TZX tapes.
* Fix the load of PZX tapes with malformed strings.
* Various minor bug fixes/improvements.
2016-12-10 - serbalgi@gmail.com
- Update to version 1.3.2
* Make glib replacement protect global data structures against
modification from multiple threads (BogDan Vatra).
2016-08-22 - serbalgi@gmail.com
- Update to version 1.2.2
* Support for reading zip files (Patrik Rak and Sergio Baldoví).
* Support for converting PZX data blocks with asymmetric pulses to TZX
GDB blocks (Fredrick Meunier).
* Various minor bug fixes/improvements:
2016-06-07 - serbalgi@gmail.com
- Update to version 1.2.0
* Allow finalising RZX recordings (Sergio Baldoví).
* Support for Didaktik D80 disk class (Gergely Szasz).
* Use SZX format for interspersed snapshots in RZX recordings (Sergio
Baldoví).
* Add libspectrum_{new,new0,renew}(), libspectrum_{m,re}alloc_n()
memory macros (Stuart Brady).
* Rename libspectrum_calloc() to libspectrum_malloc0_n() (Stuart Brady).
* Various minor bug fixes/improvements.
- Move devel to Development/Libraries/C and C++ group.
- Fix the build on RHEL_7 and SLE_11_SP3.
- Distribute COPYING file.
- Several spec fixes.
2013-09-16 - serbalgi@gmail.com
- Update to version 1.1.1
* Decreased libtool version to allow binaries built against
libspectrum 1.0.0 to run with libspectrum 1.1.1.
* Support for Spectranet in snapshots (Philip Kendall).
* Support for Cheetah SpecDrum in snapshots (Fredrick Meunier).
* Support reading PZX files (Fredrick Meunier).
* Support for the TZX set signal level block (Fredrick Meunier).
- Add libbz2-devel BuildRequires to enable reading from compressed files
- Modernize package license
2011-10-04 - nmarques@opensuse.org
- Update to version 1.0.0
- Several spec fixes

See Also

Package Description
libvorbis-devel-1.3.6-74.2.i586.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis-devel-1.3.6-74.2.x86_64.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis-devel-32bit-1.3.6-74.2.x86_64.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis0-1.3.6-74.2.i586.rpm The Vorbis General Audio Compression Codec
libvorbis0-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbis0-32bit-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-1.3.6-74.2.i586.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-32bit-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-1.3.6-74.2.i586.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-32bit-1.3.6-74.2.x86_64.rpm The Vorbis General Audio Compression Codec
libwx_baseu-suse3_1_1-3.1.1.g3-26.6.i586.rpm wxWidgets Library
libwx_baseu-suse3_1_1-3.1.1.g3-26.6.x86_64.rpm wxWidgets Library
libwx_baseu_net-suse3_1_1-3.1.1.g3-26.6.i586.rpm wxWidgets Library
Advertisement
Advertisement