vlc-devel-3.0.6-283.1.i586.rpm


Advertisement

Description

vlc-devel - Development files for the VLC media player system

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename vlc-devel-3.0.6-283.1.i586.rpm
Package name vlc-devel
Package version 3.0.6
Package release 283.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.videolan.org
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 235.43 KB
Installed size 970.52 KB
These development headers are required if you plan on coding against VLC.

Alternatives

Package Version Architecture Repository
vlc-devel-3.0.8-322.3.i586.rpm 3.0.8 i586 VLC
vlc-devel-3.0.8-322.3.x86_64.rpm 3.0.8 x86_64 VLC
vlc-devel-3.0.8-5.4.i586.rpm 3.0.8 i586 Packman
vlc-devel-3.0.8-5.4.x86_64.rpm 3.0.8 x86_64 Packman
vlc-devel-3.0.6-283.1.x86_64.rpm 3.0.6 x86_64 Multimedia Libs
vlc-devel-3.0.6-6.1.x86_64.rpm 3.0.6 x86_64 openSUSE Oss
vlc-devel-3.0.6-6.1.i586.rpm 3.0.6 i586 openSUSE Oss
vlc-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
vlc = 3.0.6
vlc-jack = 3.0.6
vlc-vdpau = 3.0.6

Provides

Name Value
pkgconfig(libvlc) = 3.0.6
pkgconfig(vlc-plugin) = 3.0.6
vlc-devel = 3.0.6-283.1
vlc-devel(x86-32) = 3.0.6-283.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package vlc-devel-3.0.6-283.1.i586.rpm
Source Package vlc-3.0.6-283.1.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install vlc-devel rpm package:
    # zypper install vlc-devel

Files

Path
/usr/include/vlc/deprecated.h
/usr/include/vlc/libvlc.h
/usr/include/vlc/libvlc_dialog.h
/usr/include/vlc/libvlc_events.h
/usr/include/vlc/libvlc_media.h
/usr/include/vlc/libvlc_media_discoverer.h
/usr/include/vlc/libvlc_media_library.h
/usr/include/vlc/libvlc_media_list.h
/usr/include/vlc/libvlc_media_list_player.h
/usr/include/vlc/libvlc_media_player.h
/usr/include/vlc/libvlc_renderer_discoverer.h
/usr/include/vlc/libvlc_version.h
/usr/include/vlc/libvlc_vlm.h
/usr/include/vlc/vlc.h
/usr/include/vlc/plugins/vlc_about.h
/usr/include/vlc/plugins/vlc_access.h
/usr/include/vlc/plugins/vlc_actions.h
/usr/include/vlc/plugins/vlc_addons.h
/usr/include/vlc/plugins/vlc_aout.h
/usr/include/vlc/plugins/vlc_aout_volume.h
/usr/include/vlc/plugins/vlc_arrays.h
/usr/include/vlc/plugins/vlc_atomic.h
/usr/include/vlc/plugins/vlc_avcodec.h
/usr/include/vlc/plugins/vlc_bits.h
/usr/include/vlc/plugins/vlc_block.h
/usr/include/vlc/plugins/vlc_block_helper.h
/usr/include/vlc/plugins/vlc_boxes.h
/usr/include/vlc/plugins/vlc_charset.h
/usr/include/vlc/plugins/vlc_codec.h
/usr/include/vlc/plugins/vlc_common.h
/usr/include/vlc/plugins/vlc_config.h
/usr/include/vlc/plugins/vlc_config_cat.h
/usr/include/vlc/plugins/vlc_configuration.h
/usr/include/vlc/plugins/vlc_cpu.h
/usr/include/vlc/plugins/vlc_demux.h
/usr/include/vlc/plugins/vlc_dialog.h
/usr/include/vlc/plugins/vlc_epg.h
/usr/include/vlc/plugins/vlc_es.h
/usr/include/vlc/plugins/vlc_es_out.h
/usr/include/vlc/plugins/vlc_events.h
/usr/include/vlc/plugins/vlc_filter.h
/usr/include/vlc/plugins/vlc_fingerprinter.h
/usr/include/vlc/plugins/vlc_fourcc.h
/usr/include/vlc/plugins/vlc_fs.h
/usr/include/vlc/plugins/vlc_gcrypt.h
/usr/include/vlc/plugins/vlc_http.h
/usr/include/vlc/plugins/vlc_httpd.h
/usr/include/vlc/plugins/vlc_image.h
/usr/include/vlc/plugins/vlc_inhibit.h
/usr/include/vlc/plugins/vlc_input.h
/usr/include/vlc/plugins/vlc_input_item.h
/usr/include/vlc/plugins/vlc_interface.h
/usr/include/vlc/plugins/vlc_interrupt.h
/usr/include/vlc/plugins/vlc_keystore.h
/usr/include/vlc/plugins/vlc_main.h
/usr/include/vlc/plugins/vlc_md5.h
/usr/include/vlc/plugins/vlc_media_library.h
/usr/include/vlc/plugins/vlc_memstream.h
/usr/include/vlc/plugins/vlc_messages.h
/usr/include/vlc/plugins/vlc_meta.h
/usr/include/vlc/plugins/vlc_meta_fetcher.h
/usr/include/vlc/plugins/vlc_mime.h
/usr/include/vlc/plugins/vlc_modules.h
/usr/include/vlc/plugins/vlc_mouse.h
/usr/include/vlc/plugins/vlc_mtime.h
/usr/include/vlc/plugins/vlc_network.h
/usr/include/vlc/plugins/vlc_objects.h
/usr/include/vlc/plugins/vlc_opengl.h
/usr/include/vlc/plugins/vlc_picture.h
/usr/include/vlc/plugins/vlc_picture_fifo.h
/usr/include/vlc/plugins/vlc_picture_pool.h
/usr/include/vlc/plugins/vlc_playlist.h
/usr/include/vlc/plugins/vlc_plugin.h
/usr/include/vlc/plugins/vlc_probe.h
/usr/include/vlc/plugins/vlc_rand.h
/usr/include/vlc/plugins/vlc_renderer_discovery.h
/usr/include/vlc/plugins/vlc_services_discovery.h
/usr/include/vlc/plugins/vlc_sout.h
/usr/include/vlc/plugins/vlc_spu.h
/usr/include/vlc/plugins/vlc_stream.h
/usr/include/vlc/plugins/vlc_stream_extractor.h
/usr/include/vlc/plugins/vlc_strings.h
/usr/include/vlc/plugins/vlc_subpicture.h
/usr/include/vlc/plugins/vlc_text_style.h
/usr/include/vlc/plugins/vlc_threads.h
/usr/include/vlc/plugins/vlc_timestamp_helper.h
/usr/include/vlc/plugins/vlc_tls.h
/usr/include/vlc/plugins/vlc_url.h
/usr/include/vlc/plugins/vlc_variables.h
/usr/include/vlc/plugins/vlc_video_splitter.h
/usr/include/vlc/plugins/vlc_viewpoint.h
/usr/include/vlc/plugins/vlc_vlm.h
/usr/include/vlc/plugins/vlc_vout.h
/usr/include/vlc/plugins/vlc_vout_display.h
/usr/include/vlc/plugins/vlc_vout_osd.h
/usr/include/vlc/plugins/vlc_vout_window.h
/usr/include/vlc/plugins/vlc_xlib.h
/usr/include/vlc/plugins/vlc_xml.h
/usr/lib/libvlc.so
/usr/lib/libvlccore.so
/usr/lib/pkgconfig/libvlc.pc
/usr/lib/pkgconfig/vlc-plugin.pc
/usr/lib/vlc/libcompat.a
/usr/lib/vlc/libvlc_vdpau.so

Changelog

2019-05-02 - olaf@aepfle.de
- The license of fdk-aac is not GPL compatible, therefore this pkg
can not possibly be built with fdk-aac by default
To gain fdk-aac support, recompile it at home and keep it there
2019-04-24 - Martin Li?ka <mliska@suse.cz>
- Disable LTO (boo#1133290).
2019-03-20 - Dominique Leuenberger <dimstar@opensuse.org>
- Add vlc-libssh2-ECDSA-version.patch: sftp: fix version for ECDSA
known hosts (fixes vlc#22060).
2019-03-16 - Bjørn Lie <bjorn.lie@gmail.com>
- Add conditional pkgconfig(dav1d) BuildRequires: build av1
decoding via dav1d decoder.
2019-03-05 - Dominique Leuenberger <dimstar@opensuse.org>
- Limit the use of projectM-qt5 to suse_version > 1320 < 1550.
On Tumbleweed, we now have projectM 3.1.0, which is equivalent
to what our projectM-qt5 used to be.
2019-02-18 - bjorn.lie@gmail.com
- Move vdpau sub-package and it's dependencies out of BUILD_ORIG
conditional, everything it needs is provided by openSUSE.
- Refresh patches with refresh_patches service.
- Drop BUILD_ORIG guarded faad2-devel and libfaac-devel
BuildRequires and stop passing conditional --enable-faad to
configure, libfdkaac is sufficient for aac encoding/decoding.
- Add pkgconfig(aom), pkgconfig(libnfs) and pkgconfig(soxr)
BuildRequires, build the codecs/filters/plugins.
2019-02-12 - Antonio Larrosa <alarrosa@suse.com>
- Add fix-build-with-fdk-2.0.patch to fix building vlc with
libfdk-aac v2
- Add 0001-codec-vpx-Detect-libvpx-1.8.0.patch to fix building vlc
with libvpx 1.8.0
- Add the libx26410b_plugin.so codec plugin when building with
BUILD_ORIG
2019-01-10 - seanlew@opensuse.org
- Update to version 3.0.6:
+ Core:
* Fix potential subtitle picture allocation failures
+ Codec:
* Add support for 12 bits decoding of AV1
* Fix HDR support in AV1 when the container provides the metadata
2019-01-03 - Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Add support for Chromecast discovery with Avahi. The current upstream
implementation uses microdns, which is not available in openSUSE, and
would also cause problems (2 mDNS implemenations running concurrently).
* Add 0001-Fix-leaking-AvahiServiceResolver-in-the-error-paths.patch
* Add 0002-Add-Avahi-implementation-for-chromecast-renderer-dis.patch
- Spec file cleanup, remove obsolete suse_version checks
2018-12-29 - sean@suspend.net
- Update to version 3.0.5:
+ Access:
* Improve RTSP playback
* BluRay fixes and improvements, notably for menus and seeking
* Improve the UDP/RTP truncated issue
+ Codec:
* Add a new AVI decoder based on the davld library
* Enable libaom decoder by default
* Fix decoding of some HEVC streams with macOS hardware decoding
+ Demux:
* MP4: Fix reading of some HDR metadata
* Miscellaneous AV1 demuxing improvements
* Fix CAF integer-underflow
* Fix an MKV crash on iOS 12.0 on iPhone XS phones
+ Packetizer:
* Add an AV1 packetizer
+ Audio output:
* Fix corking when the playback state is paused
* Improve corking on Android
+ Video Output:
* Fix Direct3D11 tone-mapping when HDR is displayed on SDR screen
* More accurate colors for SD sources in Direct3D11
* Disable hardware decoding on some old Intel GPUs
* Fix zero-copy GPU acceleration on AMD RX Vega
* Misc Direct3D11 fixes
+ Miscellaneous
* Improve ChromeCast
* Update numerous 3P libraries, including for minor security issues
* Update YouTube support
* Fix subtitles rendering with specific fonts with negative HA

See Also

Package Description
vlc-jack-3.0.6-283.1.i586.rpm Jack integration for the VLC media player
vlc-jack-3.0.6-283.1.x86_64.rpm Jack integration for the VLC media player
vlc-lang-3.0.6-283.1.noarch.rpm Translations for package vlc
vlc-noX-3.0.6-283.1.i586.rpm VLC without X dependencies
vlc-noX-3.0.6-283.1.x86_64.rpm VLC without X dependencies
vlc-qt-3.0.6-283.1.i586.rpm Qt interface for the VLC media player
vlc-qt-3.0.6-283.1.x86_64.rpm Qt interface for the VLC media player
vlc-vdpau-3.0.6-283.1.i586.rpm Additional vdpau codecs for the VLC media player
vlc-vdpau-3.0.6-283.1.x86_64.rpm Additional vdpau codecs for the VLC media player
vobsub2srt-1.0pre7+r9_d4c34ca002d8-1.14.i586.rpm VobSub to SubRip subtitle converter
vobsub2srt-1.0pre7+r9_d4c34ca002d8-1.14.x86_64.rpm VobSub to SubRip subtitle converter
vobsub2srt-bash-completion-1.0pre7+r9_d4c34ca002d8-1.14.noarch.rpm Bash completion for vobsub2srt
vpx-tools-1.8.0-112.1.i586.rpm Utilies from the VP8/VP9 codec library
vpx-tools-1.8.0-112.1.x86_64.rpm Utilies from the VP8/VP9 codec library
vsxu-artiste-0.6.2-4.7.i586.rpm VSXu graphic effects creator
Advertisement
Advertisement