libvlc5-3.0.6-283.1.x86_64.rpm


Advertisement

Description

libvlc5 - Shared code for the VLC media player program

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libvlc5-3.0.6-283.1.x86_64.rpm
Package name libvlc5
Package version 3.0.6
Package release 283.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.videolan.org
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 89.78 KB
Installed size 151.73 KB
This subpackage contains libraries that are part of VLC.

Alternatives

Package Version Architecture Repository
libvlc5-4.0.0-2018031302.4.x86_64.rpm 4.0.0 x86_64 VLC
libvlc5-4.0.0-2018031302.4.i586.rpm 4.0.0 i586 VLC
libvlc5-3.0.8-322.3.i586.rpm 3.0.8 i586 VLC
libvlc5-3.0.8-322.3.x86_64.rpm 3.0.8 x86_64 VLC
libvlc5-3.0.8-5.5.i586.rpm 3.0.8 i586 Packman
libvlc5-3.0.8-5.5.x86_64.rpm 3.0.8 x86_64 Packman
libvlc5-3.0.6-283.1.i586.rpm 3.0.6 i586 Multimedia Libs
libvlc5-3.0.6-6.1.x86_64.rpm 3.0.6 x86_64 openSUSE Oss
libvlc5-3.0.6-6.1.i586.rpm 3.0.6 i586 openSUSE Oss
libvlc5 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
libvlccore.so.9()(64bit) -

Provides

Name Value
libvlc.so.5()(64bit) -
libvlc5 = 3.0.6-283.1
libvlc5(x86-64) = 3.0.6-283.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libvlc5-3.0.6-283.1.x86_64.rpm
Source Package vlc-3.0.6-283.1.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libvlc5 rpm package:
    # zypper install libvlc5

Files

Path
/usr/lib64/libvlc.so.5
/usr/lib64/libvlc.so.5.6.0

Changelog

2019-05-02 - olaf@aepfle.de
- The license of fdk-aac is not GPL compatible, therefore this pkg
can not possibly be built with fdk-aac by default
To gain fdk-aac support, recompile it at home and keep it there
2019-04-24 - Martin Li?ka <mliska@suse.cz>
- Disable LTO (boo#1133290).
2019-03-20 - Dominique Leuenberger <dimstar@opensuse.org>
- Add vlc-libssh2-ECDSA-version.patch: sftp: fix version for ECDSA
known hosts (fixes vlc#22060).
2019-03-16 - Bjørn Lie <bjorn.lie@gmail.com>
- Add conditional pkgconfig(dav1d) BuildRequires: build av1
decoding via dav1d decoder.
2019-03-05 - Dominique Leuenberger <dimstar@opensuse.org>
- Limit the use of projectM-qt5 to suse_version > 1320 < 1550.
On Tumbleweed, we now have projectM 3.1.0, which is equivalent
to what our projectM-qt5 used to be.
2019-02-18 - bjorn.lie@gmail.com
- Move vdpau sub-package and it's dependencies out of BUILD_ORIG
conditional, everything it needs is provided by openSUSE.
- Refresh patches with refresh_patches service.
- Drop BUILD_ORIG guarded faad2-devel and libfaac-devel
BuildRequires and stop passing conditional --enable-faad to
configure, libfdkaac is sufficient for aac encoding/decoding.
- Add pkgconfig(aom), pkgconfig(libnfs) and pkgconfig(soxr)
BuildRequires, build the codecs/filters/plugins.
2019-02-12 - Antonio Larrosa <alarrosa@suse.com>
- Add fix-build-with-fdk-2.0.patch to fix building vlc with
libfdk-aac v2
- Add 0001-codec-vpx-Detect-libvpx-1.8.0.patch to fix building vlc
with libvpx 1.8.0
- Add the libx26410b_plugin.so codec plugin when building with
BUILD_ORIG
2019-01-10 - seanlew@opensuse.org
- Update to version 3.0.6:
+ Core:
* Fix potential subtitle picture allocation failures
+ Codec:
* Add support for 12 bits decoding of AV1
* Fix HDR support in AV1 when the container provides the metadata
2019-01-03 - Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Add support for Chromecast discovery with Avahi. The current upstream
implementation uses microdns, which is not available in openSUSE, and
would also cause problems (2 mDNS implemenations running concurrently).
* Add 0001-Fix-leaking-AvahiServiceResolver-in-the-error-paths.patch
* Add 0002-Add-Avahi-implementation-for-chromecast-renderer-dis.patch
- Spec file cleanup, remove obsolete suse_version checks
2018-12-29 - sean@suspend.net
- Update to version 3.0.5:
+ Access:
* Improve RTSP playback
* BluRay fixes and improvements, notably for menus and seeking
* Improve the UDP/RTP truncated issue
+ Codec:
* Add a new AVI decoder based on the davld library
* Enable libaom decoder by default
* Fix decoding of some HEVC streams with macOS hardware decoding
+ Demux:
* MP4: Fix reading of some HDR metadata
* Miscellaneous AV1 demuxing improvements
* Fix CAF integer-underflow
* Fix an MKV crash on iOS 12.0 on iPhone XS phones
+ Packetizer:
* Add an AV1 packetizer
+ Audio output:
* Fix corking when the playback state is paused
* Improve corking on Android
+ Video Output:
* Fix Direct3D11 tone-mapping when HDR is displayed on SDR screen
* More accurate colors for SD sources in Direct3D11
* Disable hardware decoding on some old Intel GPUs
* Fix zero-copy GPU acceleration on AMD RX Vega
* Misc Direct3D11 fixes
+ Miscellaneous
* Improve ChromeCast
* Update numerous 3P libraries, including for minor security issues
* Update YouTube support
* Fix subtitles rendering with specific fonts with negative HA

See Also

Package Description
libvlccore9-3.0.6-283.1.i586.rpm Shared code for the VLC media player program
libvlccore9-3.0.6-283.1.x86_64.rpm Shared code for the VLC media player program
libvorbis-devel-1.3.6-73.8.i586.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis-devel-1.3.6-73.8.x86_64.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis-devel-32bit-1.3.6-73.8.x86_64.rpm Include Files and Libraries mandatory for Ogg Vorbis Development
libvorbis0-1.3.6-73.8.i586.rpm The Vorbis General Audio Compression Codec
libvorbis0-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbis0-32bit-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-1.3.6-73.8.i586.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisenc2-32bit-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-1.3.6-73.8.i586.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvorbisfile3-32bit-1.3.6-73.8.x86_64.rpm The Vorbis General Audio Compression Codec
libvpx-devel-1.8.0-112.1.i586.rpm Development files for libvpx, a VP8/VP9 codec library
Advertisement
Advertisement