libunicap2-32bit-0.9.12-41.15.x86_64.rpm


Advertisement

Description

libunicap2-32bit - Library to access different kinds of (video) capture devices

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libunicap2-32bit-0.9.12-41.15.x86_64.rpm
Package name libunicap2-32bit
Package version 0.9.12
Package release 41.15
Package architecture x86_64
Package type rpm
Category Hardware/Camera
Homepage http://www.unicap-imaging.org/
License GPL-2.0+
Maintainer -
Download size 92.19 KB
Installed size 334.18 KB
Unicap provides a uniform interface to video capture devices. It allows
applications to use any supported video capture device via a single API.
The included ucil library provides easy to use functions to render text
and graphic overlays onto video images.

Alternatives

Package Version Architecture Repository
libunicap2-32bit-0.9.12-21.4.x86_64.rpm 0.9.12 x86_64 openSUSE Oss
libunicap2-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.7) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.3) -
libraw1394.so.11 -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libv4l2.so.0 -

Provides

Name Value
libdcam.so -
libeuvccam_cpi.so -
libunicap.so.2 -
libunicap2-32bit = 0.9.12-41.15
libunicap2-32bit(x86-32) = 0.9.12-41.15
libv4l.so -
libv4l2cpi.so -
libvid21394.so -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libunicap2-32bit-0.9.12-41.15.x86_64.rpm
Source Package libunicap-0.9.12-41.15.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libunicap2-32bit rpm package:
    # zypper install libunicap2-32bit

Files

Path
/usr/lib/libunicap.so.2
/usr/lib/libunicap.so.2.2.0
/usr/lib/unicap2/
/usr/lib/unicap2/cpi/libdcam.so
/usr/lib/unicap2/cpi/libeuvccam_cpi.so
/usr/lib/unicap2/cpi/libv4l.so
/usr/lib/unicap2/cpi/libv4l2cpi.so
/usr/lib/unicap2/cpi/libvid21394.so

Changelog

2017-09-28 - davejplater@gmail.com
- Fix Factory build by disable gtk-doc html build due to
gtkdoc-mktmpl having been removed.
2015-04-13 - dimstar@opensuse.org
- Call libtoolize during build phase: after running autoreconf,
we get the new macros installed but do not take into account that
there was a minor change between intltool 0.50 and 0.51.
2014-10-01 - crrodriguez@opensuse.org
- Remove x11 libs buildrequires, never directly linked.
2013-05-02 - crrodriguez@opensuse.org
- While we are at this, place the udev rules in the
correct localtion (extends libunicap-udev.patch)
2013-05-02 - crrodriguez@opensuse.org
- Fix build with new automake
2012-11-22 - crrodriguez@opensuse.org
- Fix implicit declarations rpmlint warning/errors.
- Fix build Requires.
2012-03-16 - sbrabec@suse.cz
- Port rules to the new udev (bnc#726471).
2011-10-14 - andrea.turrini@gmail.com
- Fixed typos in libunicap.spec
2011-10-11 - toddrme2178@gmail.com
- Add a patch to not used the reserved keyword "private".  This
prevents C++ programs from building against this library
See: https://bugs.launchpad.net/unicap/+bug/656229
https://bugs.launchpad.net/unicap/+bug/658739
- Removed deprecated %clean macro
- Did some trivial spec file cleanups
2011-08-23 - toddrme2178@gmail.com
- Fixed typos in spec file that was causing a build error
- Added -32bit compatibility package.  This will be needed
by some packages using this library.

See Also

Package Description
libvamp-hostsdk3-2.7.1-23.26.i586.rpm Library for Vamp audio analysis plugin hosts
libvamp-hostsdk3-2.7.1-23.26.x86_64.rpm Library for Vamp audio analysis plugin hosts
libvamp-hostsdk3-32bit-2.7.1-23.26.x86_64.rpm Library for Vamp audio analysis plugin hosts
libvamp-sdk2-2.7.1-23.26.i586.rpm Library for Vamp audio analysis plugins
libvamp-sdk2-2.7.1-23.26.x86_64.rpm Library for Vamp audio analysis plugins
libvamp-sdk2-32bit-2.7.1-23.26.x86_64.rpm Library for Vamp audio analysis plugins
libvapoursynth-45-45-18.7.i586.rpm A video processing framework
libvapoursynth-45-45-18.7.x86_64.rpm A video processing framework
libvapoursynth-script0-45-18.7.i586.rpm Library for interfacing Python with VapourSynth
libvapoursynth-script0-45-18.7.x86_64.rpm Library for interfacing Python with VapourSynth
libvcdinfo0-2.0.1-56.9.i586.rpm Video CD (VCD) authoring software
libvcdinfo0-2.0.1-56.9.x86_64.rpm Video CD (VCD) authoring software
libvcdinfo0-32bit-2.0.1-56.9.x86_64.rpm Video CD (VCD) authoring software
libvidstab-devel-1.1.0-10.5.i586.rpm Development files for libvidstab1_1
libvidstab-devel-1.1.0-10.5.x86_64.rpm Development files for libvidstab1_1
Advertisement
Advertisement