libtheoradec1-1.1.1-54.42.i586.rpm


Advertisement

Description

libtheoradec1 - Theora video decompression library

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libtheoradec1-1.1.1-54.42.i586.rpm
Package name libtheoradec1
Package version 1.1.1
Package release 54.42
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.theora.org/
License BSD-3-Clause
Maintainer -
Download size 50.38 KB
Installed size 109.57 KB
Theora is a free and open video compression format from the Xiph.org Foundation. Like all our
multimedia technology it can be used to distribute film and video online and on disc without
the licensing and royalty fees or vendor lock-in associated with other formats.
This subpackage contains the decoder library.

Alternatives

Package Version Architecture Repository
libtheoradec1-1.1.1-54.42.x86_64.rpm 1.1.1 x86_64 Multimedia Libs
libtheoradec1-1.1.1-29.15.x86_64.rpm 1.1.1 x86_64 openSUSE Oss
libtheoradec1-1.1.1-29.15.i586.rpm 1.1.1 i586 openSUSE Oss
libtheoradec1 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -

Provides

Name Value
libtheoradec.so.1 -
libtheoradec.so.1(libtheora.so.1.0) -
libtheoradec.so.1(libtheoradec_1.0) -
libtheoradec1 = 1.1.1-54.42
libtheoradec1(x86-32) = 1.1.1-54.42

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libtheoradec1-1.1.1-54.42.i586.rpm
Source Package libtheora-1.1.1-54.42.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libtheoradec1 rpm package:
    # zypper install libtheoradec1

Files

Path
/usr/lib/libtheoradec.so.1
/usr/lib/libtheoradec.so.1.1.4

Changelog

2014-08-30 - jengelh@inai.de
- Split libtheoradec/enc from libtheora0 as they have different
SO numbers
- Trim huge description; improve on RPM group classificaiton
2013-05-23 - idonmez@suse.com
- Update descriptions, thanks to Perry Werneck
2011-11-20 - coolo@suse.com
- add libtool as buildrequire to avoid implicit dependency
2011-08-29 - crrodriguez@opensuse.org
- remove examples that fail to build, also SDL and png
are only needed for those, so remove from buildrequires.
2011-07-27 - crrodriguez@opensuse.org
- remove fno-strict-aliasing from CFLAGS as it is no longer
needed and will slow down things.
2011-05-23 - crrodriguez@opensuse.org
- Disable doxygen documentation to avoid build dates in
- devel packages.
- add missing BuildRequires libpng-devel
2009-12-18 - jengelh@medozas.de
- add baselibs.conf as a source
2009-10-07 - adrian@suse.de
- update to version 1.1.1
* minor bugfixes
2009-09-26 - adrian@suse.de
- update to version 1.1.0
* minor fixes since beta 3
2009-08-27 - adrian@suse.de
- update to version 1.1 beta 3
* Much better encoder
(faster and more details at same compressions level)
* Playback received speed improvements, but bitstream format is
untouched
- no package split yet for dec/enc/legacy libs due to 11.2 freeze

See Also

Package Description
libtheoradec1-32bit-1.1.1-54.42.x86_64.rpm Theora video decompression library
libtheoraenc1-1.1.1-54.42.i586.rpm Theora video compression library
libtheoraenc1-1.1.1-54.42.x86_64.rpm Theora video compression library
libtheoraenc1-32bit-1.1.1-54.42.x86_64.rpm Theora video compression library
libtiger-devel-0.3.4-4.21.i586.rpm Development files for libtiger
libtiger-devel-0.3.4-4.21.x86_64.rpm Development files for libtiger
libtiger5-0.3.4-4.21.i586.rpm Rendering library for Kate streams using Pango and Cairo
libtiger5-0.3.4-4.21.x86_64.rpm Rendering library for Kate streams using Pango and Cairo
libtimidity-devel-0.2.2-22.22.i586.rpm MIDI to WAVE converter library - Development Files
libtimidity-devel-0.2.2-22.22.x86_64.rpm MIDI to WAVE converter library - Development Files
libtimidity2-0.2.2-22.22.i586.rpm MIDI to WAVE converter library
libtimidity2-0.2.2-22.22.x86_64.rpm MIDI to WAVE converter library
libtimidity2-32bit-0.2.2-22.22.x86_64.rpm MIDI to WAVE converter library
libtinycompress0-1.1.8-1.4.i586.rpm A library for ALSA compressed API
libtinycompress0-1.1.8-1.4.x86_64.rpm A library for ALSA compressed API
Advertisement
Advertisement