libquicktime-tools-1.2.4+git20180207.666c35c-107.16.x86_64.rpm


Advertisement

Description

libquicktime-tools - Libquicktime Tools

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libquicktime-tools-1.2.4+git20180207.666c35c-107.16.x86_64.rpm
Package name libquicktime-tools
Package version 1.2.4+git20180207.666c35c
Package release 107.16
Package architecture x86_64
Package type rpm
Category Productivity/Multimedia/Video/Editors and Convertors
Homepage http://libquicktime.sf.net
License GPL-2.0-or-later
Maintainer -
Download size 49.67 KB
Installed size 210.40 KB
Tools for reading/writing quicktime movie files.

Alternatives

Package Version Architecture Repository
libquicktime-tools-1.2.4+git20180804.fff99cd-3.6.i586.rpm 1.2.4+git20180804.fff99cd i586 Packman
libquicktime-tools-1.2.4+git20180804.fff99cd-3.6.x86_64.rpm 1.2.4+git20180804.fff99cd x86_64 Packman
libquicktime-tools-1.2.4+git20180207.666c35c-107.16.i586.rpm 1.2.4+git20180207.666c35c i586 Multimedia Libs
libquicktime-tools-1.2.4+git20180207.666c35c-1.5.x86_64.rpm 1.2.4+git20180207.666c35c x86_64 openSUSE Oss
libquicktime-tools-1.2.4+git20180207.666c35c-1.5.i586.rpm 1.2.4+git20180207.666c35c i586 openSUSE Oss
libquicktime-tools - - -

Requires

Name Value
libGL.so.1()(64bit) -
libX11.so.6()(64bit) -
libXaw.so.7()(64bit) -
libXext.so.6()(64bit) -
libXt.so.6()(64bit) -
libXv.so.1()(64bit) -
libasound.so.2()(64bit) -
libasound.so.2(ALSA_0.9)(64bit) -
libasound.so.2(ALSA_0.9.0rc4)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libquicktime = 1.2.4+git20180207.666c35c
libquicktime.so.0()(64bit) -
libquicktime0 = 1.2.4+git20180207.666c35c

Provides

Name Value
libquicktime-tools = 1.2.4+git20180207.666c35c-107.16
libquicktime-tools(x86-64) = 1.2.4+git20180207.666c35c-107.16

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libquicktime-tools-1.2.4+git20180207.666c35c-107.16.x86_64.rpm
Source Package libquicktime-1.2.4+git20180207.666c35c-107.16.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libquicktime-tools rpm package:
    # zypper install libquicktime-tools

Files

Path
/usr/bin/lqt_transcode
/usr/bin/lqtplay
/usr/bin/lqtremux
/usr/bin/qt2text
/usr/bin/qtdechunk
/usr/bin/qtdump
/usr/bin/qtinfo
/usr/bin/qtrechunk
/usr/bin/qtstreamize
/usr/bin/qtyuv4toyuv
/usr/share/man/man1/lqtplay.1.gz

Changelog

2018-06-13 - tchvatal@suse.com
- Update to version 1.2.4+git20180207.666c35c:
* remove generated file that got committed somehow
* cleanup - remove all the .cvsignore files
* remove another .cvsignore file
* remove typo
* add a bunch more generated files to ignore
* more files added
* add more files
* switch to .gitignore from .cvsignore
* remove m4/avcodec.m4, not needed with changes to configure.ac
* don't need avcodec.m4 with changes to configure.ac
- Remove merged patches:
* libquicktime-1.2.4-integer_overflow.patch
* libquicktime-1.2.4-multiple_vulnerabilities.patch
- Remove all local patches:
* libquicktime-faad2.patch
* libquicktime-1.2.4-ffmpeg2.patch
* libquicktime-1.2.4-ffmpeg29.patch
* libquicktime-1.2.4-ffmpeg4.patch
- Readd patches to be rebased from the git:
* 0001-Fix-sizeof-call-in-faad2.patch
* 0002-Allow-any-avcodec-to-be-detected-by-configure.patch
* 0003-Fix-AVCODEC_HEADER-macro-replacement.patch
* 0005-ffmpeg4-conversion-fixing-the-erroring-ones-only.patch
2018-06-13 - tchvatal@suse.com
- Switch to Git snapshots as upstream moved to git, use _service
2018-06-11 - tchvatal@suse.com
- Remove redone patch:
* libquicktime-ffmpeg3.patch
- Add patch to work with ffmpeg4:
* libquicktime-1.2.4-ffmpeg2.patch
* libquicktime-1.2.4-ffmpeg29.patch
* libquicktime-1.2.4-ffmpeg4.patch
2018-05-04 - olaf@aepfle.de
- Use ffmpeg3 versions of pkgconfig(libav*)
2018-04-21 - jengelh@inai.de
- Explicitly request ffmpeg 3.x for building
2017-11-28 - zaitor@opensuse.org
- Add %%{name} Requires to orig-addon sub-package, installing the
addon-package does not make sense without the main package.
2017-11-03 - zaitor@opensuse.org
- Drop gtk2-devel BuildRequires and pass --without-gtk to
configure, no longer build gtk2 support.
- Following the above, stop using sed to remove
GTK_DISABLE_DEPRECATED from configure.ac, no longer needed.
- Add explicit pkgconfig(libpng) BuildRequries, previously pulled
in by the gtk2-devel BuildRequries.
2017-08-25 - olaf@aepfle.de
- Enable lame unconditionally
- Remove ffmpeg conditional because it is always present
2017-07-04 - kstreitova@suse.com
- adjust libquicktime-1.2.4-integer_overflow.patch to prevent
endless loop when there are less than 256 bytes to read
[bsc#1022805] CVE-2016-2399
2017-06-23 - kstreitova@suse.com
- add libquicktime-1.2.4-multiple_vulnerabilities.patch to fix the
following security issues:
* CVE-2017-9122 [bsc#1044077]
* CVE-2017-9123 [bsc#1044009]
* CVE-2017-9124 [bsc#1044008]
* CVE-2017-9125 [bsc#1044122]
* CVE-2017-9126 [bsc#1044006]
* CVE-2017-9127 [bsc#1044002]
* CVE-2017-9128 [bsc#1044000]

See Also

Package Description
libquicktime0-1.2.4+git20180207.666c35c-107.16.i586.rpm Library for Reading and Writing Quicktime Movie Files
libquicktime0-1.2.4+git20180207.666c35c-107.16.x86_64.rpm Library for Reading and Writing Quicktime Movie Files
libquicktime0-32bit-1.2.4+git20180207.666c35c-107.16.x86_64.rpm Library for Reading and Writing Quicktime Movie Files
libquvi-0_9-0_9_4-0.9.4-31.47.i586.rpm Library to parse flash media stream URLs
libquvi-0_9-0_9_4-0.9.4-31.47.x86_64.rpm Library to parse flash media stream URLs
libquvi-devel-0.9.4-31.47.i586.rpm Library to parse flash media stream URLs -- Development Files
libquvi-devel-0.9.4-31.47.x86_64.rpm Library to parse flash media stream URLs -- Development Files
libquvi-scripts-0.9.20131130-30.8.i586.rpm Lua scripts used by libquvi
libquvi-scripts-0.9.20131130-30.8.x86_64.rpm Lua scripts used by libquvi
libquvi-scripts-devel-0.9.20131130-30.8.i586.rpm Lua scripts used by libquvi -- Development Files
libquvi-scripts-devel-0.9.20131130-30.8.x86_64.rpm Lua scripts used by libquvi -- Development Files
libquvi-scripts-nsfw-0.9.20131130-30.8.i586.rpm Not Safe For Work Lua scripts used by libquvi
libquvi-scripts-nsfw-0.9.20131130-30.8.x86_64.rpm Not Safe For Work Lua scripts used by libquvi
libraw1394-11-2.1.1-33.37.i586.rpm A Firewire Interface library
libraw1394-11-2.1.1-33.37.x86_64.rpm A Firewire Interface library
Advertisement
Advertisement