libopenshot16-0.2.2-19.15.x86_64.rpm


Advertisement

Description

libopenshot16 - The core library for the OpenShot video editor

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libopenshot16-0.2.2-19.15.x86_64.rpm
Package name libopenshot16
Package version 0.2.2
Package release 19.15
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://openshot.org/
License LGPL-3.0-or-later
Maintainer -
Download size 300.67 KB
Installed size 1016.76 KB
A library for video editing, composition, animation, and playback,
which focuses on The library is written in C++ and includes full
bindings for Python and Ruby. It features:
* Multi-layer compositing
* Video and audio effects (chroma key, color adjustment,
grayscale, etc.)
* Animation curves (Bézier, linear, constant)
* Time mapping (curve-based slow-down, speed-up, reverse)
* Audio mixing & resampling (curve-based)
* Audio plug-ins (VST & AU)
* Telecine and Inverse Telecine (film to TV, TV to film)
* Frame rate conversions
* Multi-processor support
* Uses ffmpeg for format and codec support
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libopenshot16-0.2.2-19.15.i586.rpm 0.2.2 i586 Multimedia Libs
libopenshot16-0.2.2-1.3.x86_64.rpm 0.2.2 x86_64 openSUSE Oss
libopenshot16-0.2.2-1.3.i586.rpm 0.2.2 i586 openSUSE Oss
libopenshot16 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libavcodec.so.58()(64bit) -
libavcodec.so.58(LIBAVCODEC_58)(64bit) -
libavformat.so.58()(64bit) -
libavformat.so.58(LIBAVFORMAT_58)(64bit) -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgomp.so.1()(64bit) -
libgomp.so.1(GOMP_1.0)(64bit) -
libgomp.so.1(GOMP_2.0)(64bit) -
libgomp.so.1(GOMP_4.0)(64bit) -
libgomp.so.1(OMP_1.0)(64bit) -
libjsoncpp.so.19()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libopenshot-audio.so.6()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libswresample.so.3()(64bit) -
libswresample.so.3(LIBSWRESAMPLE_3)(64bit) -
libswscale.so.5()(64bit) -
libswscale.so.5(LIBSWSCALE_5)(64bit) -
libzmq.so.5()(64bit) -

Provides

Name Value
libopenshot.so.16()(64bit) -
libopenshot16 = 0.2.2-19.15
libopenshot16(x86-64) = 0.2.2-19.15

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libopenshot16-0.2.2-19.15.x86_64.rpm
Source Package libopenshot-0.2.2-19.15.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libopenshot16 rpm package:
    # zypper install libopenshot16

Files

Path
/usr/lib64/libopenshot.so.0.2.2
/usr/lib64/libopenshot.so.16
/usr/share/doc/packages/libopenshot16/AUTHORS
/usr/share/licenses/libopenshot16/COPYING

Changelog

2018-09-24 - Adrian Schröter <adrian@suse.de>
- update to version 0.2.2
* FFmpeg 3 & 4 support
* Fixed crash with masks and transitions
* Fixed many bugs around FPS and video length calculation (especially for MP3 and streaming WEBM formats)
* Protecting samples_per_frame calculation to keep from crashing on undetected FPS
* OpenMP schedule change (added stability)
* Limiting threads for both FFmpeg and OpenMP (attempting to find a good balance of parallel performance, while not spawning too many threads). Sometimes more is not always better.
* Travis CI integration
* Fix install paths for headers and effects (Jeff Shillitto - jeffski)
* Fix bug with FFmpeg > 3.2 flushing frames (Jeff Shillitto - jeffski)
* Adding "reader" property for Mask effect, to allow the user to adjust the image or video used by the mask effect.
* Fixing bitrate calculation (to be in bytes instead of bits)
* Adding in FPS detection for files which don't have valid FPS. In those cases (streaming files for example), we iterate through all packets, and average the # of frames, duration, bit rate, etc... Not ideal, but a better fallback.
- soname change to 16
2018-07-02 - adrian@suse.de
- update to version 0.2.0
* FFMPEG 3.2.0 support
* New video effects
* bugfixes
* new soname
- return to ffmpeg3-devel BuildRequires
* ffmpeg4 is not supported
* exact version numbers are bad in case of new ffmpeg3 release
2018-05-04 - olaf@aepfle.de
- Use ffmpeg3 versions of pkgconfig(libav*)
2018-04-21 - jengelh@inai.de
- Explicitly request ffmpeg 3.x for building
2018-03-06 - adrian@suse.de
- update to version 0.1.9
going back to git, as the tar is poorly named and not signed
2017-11-01 - tampakrap@opensuse.org
- Replace the _service file with the upstream tarball
2017-09-11 - adrian@suse.de
- update to version 0.1.8
2017-09-02 - zaitor@opensuse.org
- Update to version 0.1.7
- Bump so version following upstream changes.
2017-04-03 - adrian@suse.de
- update to version 0.1.4
2017-01-13 - jengelh@inai.de
- Update description

See Also

Package Description
libopus-devel-1.3-42.4.i586.rpm Opus Audio Codec Library Development Environment
libopus-devel-1.3-42.4.x86_64.rpm Opus Audio Codec Library Development Environment
libopus0-1.3-42.4.i586.rpm Opus Audio Codec Library
libopus0-1.3-42.4.x86_64.rpm Opus Audio Codec Library
libopus0-32bit-1.3-42.4.x86_64.rpm Opus Audio Codec Library
libopusenc-devel-0.2.1-6.1.i586.rpm Development package for libopusenc
libopusenc-devel-0.2.1-6.1.x86_64.rpm Development package for libopusenc
libopusenc0-0.2.1-6.1.i586.rpm Library package for libopusenc
libopusenc0-0.2.1-6.1.x86_64.rpm Library package for libopusenc
libopusfile0-0.11-16.6.i586.rpm A high-level API for decoding and seeking within .opus files
libopusfile0-0.11-16.6.x86_64.rpm A high-level API for decoding and seeking within .opus files
liborc-0_4-0-0.4.28-78.21.i586.rpm The Oil Runtime Compiler Library
liborc-0_4-0-0.4.28-78.21.x86_64.rpm The Oil Runtime Compiler Library
liborc-0_4-0-32bit-0.4.28-78.21.x86_64.rpm The Oil Runtime Compiler Library
libout123-0-1.25.10-31.8.i586.rpm MPEG audio decoder library
Advertisement
Advertisement