liblilv-0-devel-0.24.4-36.7.x86_64.rpm


Advertisement

Description

liblilv-0-devel - Development files for liblilv

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename liblilv-0-devel-0.24.4-36.7.x86_64.rpm
Package name liblilv-0-devel
Package version 0.24.4
Package release 36.7
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://drobilla.net/software/lilv/
License ISC
Maintainer -
Download size 62.38 KB
Installed size 344.05 KB
Lilv is a C library to make use of LV2 plugins in applications.
This subpackage contains the development files for liblilv.

Alternatives

Package Version Architecture Repository
liblilv-0-devel-0.24.4-36.7.i586.rpm 0.24.4 i586 Multimedia Libs
liblilv-0-devel-0.24.4-1.4.i586.rpm 0.24.4 i586 openSUSE Oss
liblilv-0-devel-0.24.4-1.4.x86_64.rpm 0.24.4 x86_64 openSUSE Oss
liblilv-0-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
liblilv-0-0 = 0.24.4
pkgconfig(lv2) -
pkgconfig(serd-0) -
pkgconfig(sord-0) -
pkgconfig(sratom-0) -

Provides

Name Value
liblilv-0-devel = 0.24.4-36.7
liblilv-0-devel(x86-64) = 0.24.4-36.7
pkgconfig(lilv-0) = 0.24.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package liblilv-0-devel-0.24.4-36.7.x86_64.rpm
Source Package lilv-0.24.4-36.7.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install liblilv-0-devel rpm package:
    # zypper install liblilv-0-devel

Files

Path
/usr/include/lilv-0/
/usr/include/lilv-0/lilv/lilv.h
/usr/include/lilv-0/lilv/lilvmm.hpp
/usr/lib64/liblilv-0.so
/usr/lib64/pkgconfig/lilv-0.pc
/usr/share/doc/packages/lilv-0/
/usr/share/doc/packages/lilv-0/html/index.html
/usr/share/doc/packages/lilv-0/html/style.css
/usr/share/man/man3/lilv.3.gz

Changelog

2018-09-14 - Tomá? Chvátal <tchvatal@suse.com>
- Version update to 0.24.4:
* Fix saving state when broken links are encountered
* Don't attempt to load remote or non-Turtle files
* lv2apply: Activate plugin before running
* lv2apply: Use default values when they are not nan
* lv2bench: Improve support for plugins with sequence ports
* lv2bench: Support running a single plugin given on the command line
* Gracefully handle plugins with missing binary URIs
* Remove use of deprecated readdir_r
* Install Python bindings when configured without tests
(thanks Clement Skau)
2017-11-04 - davejplater@gmail.com
- Revert devel package name to original, causes unresolvables.
2017-11-03 - mpluskal@suse.com
- Switch to python3
- Run spec cleaner
- Rename devel subpackage
2017-11-03 - davejplater@gmail.com
- Update to version 0.24.2
- Remove patch lilv-python-bindings-fix.diff it's now incorporated
by upstream.
- Upstream changes:
Fix saving state to paths that contain URI delimiters
Fix comparison of restored states with paths
Add new hand-crafted Pythonic bindings with full test
coverage.
Add lv2apply utility for applying plugins to audio files
Add lilv_world_get_symbol()
Add lilv_state_set_metadata() for adding state banks/comments
/etc (based on patch from Hanspeter Portner)
Fix crash when state contains non-POD properties
Fix crash if NULL predicate passed to lilv_world_find_nodes()
Fix state file versioning
Unload contained resources when bundle is unloaded
Do not instantiate plugin when data fails to parse
Support re-loading plugins
Replace bundles if bundle with newer plugin version is loaded
Fix loading dyn-manifest from bundles with spaces in path
Check lv2:binary predicate for UIs
Add LILV_URI_ATOM_PORT and LILV_URI_CV_PORT defines
Fix documentation installation
Fix outdated comment references to lilv_uri_to_path()
2017-02-02 - jengelh@inai.de
- Rename soname to sover to better reflect its use
- Update descriptions
- Since there is no %pre section, replace questionable
Requires(pre) by Requires.
2017-01-12 - olaf@aepfle.de
- Add baselibs.conf for gstreamer-plugins-bad-32bit
2015-12-19 - davejplater@gmail.com
- Force lilv package to use the version of sord that it was built
against.
2015-12-08 - someuniquename@gmail.com
- Add runtime requirement of sord 0.13 (new API required since 0.22)
2015-12-08 - someuniquename@gmail.com
- Update to version 0.22.0, Added lilv-python-bindings-fix.diff
backported from unreleased v 0.22.1
- Upstream changes :
* Fix loading files with spaces in their path
* Add lilv_file_uri_parse() for correct URI to path conversion
* Add lilv_node_get_path() for convenient file URI path access
* Add lilv_state_emit_port_values() for special port value handling
* Add lilv_state_get_uri()
* Add lilv_state_delete() for deleting user saved presets
* Add lilv_free() for systems picky about such things
* Fix lilv_world_ask() to work with wildcards
* Fix creation of duplicate manifest entries when saving state
* Fix bindings for Python 3
* Load discovered owl ontologies as specifications
* Expose lilv_world_load_specifications() and
lilv_world_load_plugin_classes()
* Tolerate passing NULL to lilv_state_restore()
* Preserve absolute paths in state if no link directory is given
* Fix a few minor/unlikely memory errors
* Configure based on compiler target OS for cross-compilation
* Fix lilv_realpath() on pre-POSIX-2008 systems
* Fix directory walking on some systems (thanks Matt Fischer)
* Windows fixes (thanks John Emmas)
* Minor documentation improvements
* Upgrade to waf 1.8.14

See Also

Package Description
liblo-devel-0.28-44.49.i586.rpm Include Files and Libraries mandatory for Development
liblo-devel-0.28-44.49.x86_64.rpm Include Files and Libraries mandatory for Development
liblo10k1-0-0.1.8p1-115.1.i586.rpm Emu10k1 patch loader library
liblo10k1-0-0.1.8p1-115.1.x86_64.rpm Emu10k1 patch loader library
liblo7-0.28-44.49.i586.rpm Lightweight Open Sound Control implementation
liblo7-0.28-44.49.x86_64.rpm Lightweight Open Sound Control implementation
liblo7-32bit-0.28-44.49.x86_64.rpm Lightweight Open Sound Control implementation
liblrdf-devel-0.5.0-288.7.i586.rpm Development package for the liblrdf library
liblrdf-devel-0.5.0-288.7.x86_64.rpm Development package for the liblrdf library
liblrdf2-0.5.0-288.7.i586.rpm A library to Manipulate RDF Files for LADSPA Plug-Ins
liblrdf2-0.5.0-288.7.x86_64.rpm A library to Manipulate RDF Files for LADSPA Plug-Ins
liblrdf2-32bit-0.5.0-288.7.x86_64.rpm A library to Manipulate RDF Files for LADSPA Plug-Ins
liblscp-devel-0.5.8-4.6.i586.rpm LinuxSampler Control Protocol Library
liblscp-devel-0.5.8-4.6.x86_64.rpm LinuxSampler Control Protocol Library
liblscp6-0.5.8-4.6.i586.rpm LinuxSampler Control Protocol Library
Advertisement
Advertisement