libgroove4-4.3.0-9.1.x86_64.rpm


Advertisement

Description

libgroove4 - A library to streaming audio processing

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libgroove4-4.3.0-9.1.x86_64.rpm
Package name libgroove4
Package version 4.3.0
Package release 9.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://andrewrk.github.io/libgroove/
License MIT
Maintainer -
Download size 28.93 KB
Installed size 60.24 KB
This library provides decoding and encoding of audio on a playlist. It is
intended to be used as a backend for music player applications. That said,
it is also generic enough to be used as a backend for any streaming audio
processing utility.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libgroove4-4.3.0-9.1.i586.rpm 4.3.0 i586 Multimedia Libs
libgroove4-4.3.0-3.1.x86_64.rpm 4.3.0 x86_64 openSUSE Oss
libgroove4-4.3.0-3.1.i586.rpm 4.3.0 i586 openSUSE Oss
libgroove4 - - -

Requires

Name Value
/sbin/ldconfig -
libavcodec.so.58()(64bit) -
libavcodec.so.58(LIBAVCODEC_58)(64bit) -
libavfilter.so.7()(64bit) -
libavfilter.so.7(LIBAVFILTER_7)(64bit) -
libavformat.so.58()(64bit) -
libavformat.so.58(LIBAVFORMAT_58)(64bit) -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -

Provides

Name Value
libgroove.so.4()(64bit) -
libgroove4 = 4.3.0-9.1
libgroove4(x86-64) = 4.3.0-9.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgroove4-4.3.0-9.1.x86_64.rpm
Source Package libgroove-4.3.0-9.1.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libgroove4 rpm package:
    # zypper install libgroove4

Files

Path
/usr/lib64/libgroove.so.4
/usr/lib64/libgroove.so.4.3.0
/usr/share/doc/packages/libgroove4/CHANGELOG.md
/usr/share/licenses/libgroove4/LICENSE

Changelog

2019-02-13 - bjorn.lie@gmail.com
- Add libgroove-4.3.0_ffmpeg-4.0.patch: Fix build with ffmpeg v4.
- Following the above patch, drop ffmpeg3-devel BuildRequires.
2018-04-21 - jengelh@inai.de
- Explicitly request ffmpeg 3.x for building
2017-10-31 - aloisio@gmx.com
- Renamed package to upstream name
- Renamed groove.patch to libgroove-4.3.0-no_overflow.patch
and added description
2017-10-28 - aloisio@gmx.com
- Added libgroove-4.3.0-no_Werror.patch to fix build in Factory
2016-06-29 - avvissu@yandex.by
- Build with -Wno-error=deprecated-declarations
2016-06-16 - aloisio@gmx.com
- Added libgroove-4.3.0_unused-result.patch to fix SLE11 build
2016-05-26 - avvissu@yandex.by
- Initial release

See Also

Package Description
libgroovefingerprinter-devel-4.3.0-9.1.i586.rpm Development files for groovefingerprinter
libgroovefingerprinter-devel-4.3.0-9.1.x86_64.rpm Development files for groovefingerprinter
libgroovefingerprinter4-4.3.0-9.1.i586.rpm A library to acoustid fingerprinter for libgroove
libgroovefingerprinter4-4.3.0-9.1.x86_64.rpm A library to acoustid fingerprinter for libgroove
libgrooveloudness-devel-4.3.0-9.1.i586.rpm Development files for libgrooveloudness
libgrooveloudness-devel-4.3.0-9.1.x86_64.rpm Development files for libgrooveloudness
libgrooveloudness4-4.3.0-9.1.i586.rpm A library to loudness scanner for libgroove
libgrooveloudness4-4.3.0-9.1.x86_64.rpm A library to loudness scanner for libgroove
libgrooveplayer-devel-4.3.0-9.1.i586.rpm Development files for libgrooveplayer
libgrooveplayer-devel-4.3.0-9.1.x86_64.rpm Development files for libgrooveplayer
libgrooveplayer4-4.3.0-9.1.i586.rpm A library to hardware audio playback for libgroove
libgrooveplayer4-4.3.0-9.1.x86_64.rpm A library to hardware audio playback for libgroove
libgsm-devel-1.0.18-46.3.i586.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
libgsm-devel-1.0.18-46.3.x86_64.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
libgsm-devel-32bit-1.0.18-46.3.x86_64.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
Advertisement
Advertisement