libgmyth-devel-0.7.1-8.51.i586.rpm


Advertisement

Description

libgmyth-devel - GMyth Frontend Library - Development files

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libgmyth-devel-0.7.1-8.51.i586.rpm
Package name libgmyth-devel
Package version 0.7.1
Package release 8.51
Package architecture i586
Package type rpm
Category Development/Languages/C and C++
Homepage http://sourceforge.net/projects/gmyth/
License LGPL-2.0+
Maintainer -
Download size 24.61 KB
Installed size 96.66 KB
GMyth is a library to access MythTV backend services. It is designed to have few dependencies and is
written in ANSI C and GObject. The project also provides a library sample use with a Mythtv Frontend
UI for Linux based Mobile devices like Nokia 770.
This package contains header files of libgmyth

Alternatives

Package Version Architecture Repository
libgmyth-devel-0.7.1-8.51.x86_64.rpm 0.7.1 x86_64 Multimedia Libs
libgmyth-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libgmyth0 = 0.7.1
libmysqlclient-devel -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(gthread-2.0) -
pkgconfig(libcurl) -

Provides

Name Value
gmyth-devel = 0.7.1-8.51
libgmyth-devel = 0.7.1-8.51
libgmyth-devel(x86-32) = 0.7.1-8.51
pkgconfig(gmyth) = 0.7.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgmyth-devel-0.7.1-8.51.i586.rpm
Source Package gmyth-0.7.1-8.51.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libgmyth-devel rpm package:
    # zypper install libgmyth-devel

Files

Path
/usr/include/gmyth/gmyth.h
/usr/include/gmyth/gmyth_backendinfo.h
/usr/include/gmyth/gmyth_common.h
/usr/include/gmyth/gmyth_debug.h
/usr/include/gmyth/gmyth_epg.h
/usr/include/gmyth/gmyth_file.h
/usr/include/gmyth/gmyth_file_local.h
/usr/include/gmyth/gmyth_file_transfer.h
/usr/include/gmyth/gmyth_http.h
/usr/include/gmyth/gmyth_jobqueue.h
/usr/include/gmyth/gmyth_livetv.h
/usr/include/gmyth/gmyth_monitor_handler.h
/usr/include/gmyth/gmyth_programinfo.h
/usr/include/gmyth/gmyth_query.h
/usr/include/gmyth/gmyth_recorder.h
/usr/include/gmyth/gmyth_recprofile.h
/usr/include/gmyth/gmyth_remote_util.h
/usr/include/gmyth/gmyth_scheduler.h
/usr/include/gmyth/gmyth_socket.h
/usr/include/gmyth/gmyth_stringlist.h
/usr/include/gmyth/gmyth_transcoder.h
/usr/include/gmyth/gmyth_tvchain.h
/usr/include/gmyth/gmyth_uri.h
/usr/include/gmyth/gmyth_util.h
/usr/include/gmyth/gmyth_vlc.h
/usr/lib/libgmyth.so
/usr/lib/pkgconfig/gmyth.pc

Changelog

2015-07-12 - olaf@aepfle.de
- Use libmysqlclient-devel instead of mysql-devel because
13.1/13.2:Update does not provide it anymore
2012-06-23 - chris@computersalat.de
- add macros
* libname, libsoname
- fix dep
* provides gmyth-devel
2012-02-25 - dimstar@opensuse.org
- Add baselibs.conf
- Change BuildRequires from pkgconfig()-style to old-style:
+ pkkconfig(): glib-2.0, libxml-2.0, libcurl
+ old-style: glib2-devel, libxml2-devel, libcurl-devel
2012-02-25 - dimstar@opensuse.org
- Rename gmyth-devel to libgmyth-devel, as this is more closely
matching reality. Additionally, this improves compatibility with
what other 3rd party repos already used in BuildRequires.
2012-01-11 - reddwarf@opensuse.org
- Add autoconf, automake and libtool BuildRequires
- Add missing ldconfig post/postun
- Remove the %clean section
2011-10-27 - dimstar@opensuse.org
- Require mysql-devel from the -devel package. As mysql does not
have a .pc file, there is no automatic way to identify the
dependency; gmyth.pc references -lmysqlclient.
2011-10-17 - dimstar@opensuse.org
- Initial package, imported for OBS as a dependency to gstreamer.
- Patches added:
+ gmyth-includes.patch: curl/types.h does not exist
+ gmyth-samples-linking.patch: Fix build of samples with
- -as-needed.

See Also

Package Description
libgmyth0-0.7.1-8.51.i586.rpm GMyth Frontend Library
libgmyth0-0.7.1-8.51.x86_64.rpm GMyth Frontend Library
libgmyth0-32bit-0.7.1-8.51.x86_64.rpm GMyth Frontend Library
libgpod-devel-0.8.3-70.16.i586.rpm Development files for libgpod
libgpod-devel-0.8.3-70.16.x86_64.rpm Development files for libgpod
libgpod-doc-0.8.3-70.16.noarch.rpm Documentation for libgpod
libgpod-lang-0.8.3-70.16.noarch.rpm Translations for package libgpod
libgpod-tools-0.8.3-70.16.i586.rpm Tools for libgpod
libgpod-tools-0.8.3-70.16.x86_64.rpm Tools for libgpod
libgpod4-0.8.3-70.16.i586.rpm Library to Manipulate Songs and Playlists Stored on an iPod
libgpod4-0.8.3-70.16.x86_64.rpm Library to Manipulate Songs and Playlists Stored on an iPod
libgpod4-32bit-0.8.3-70.16.x86_64.rpm Library to Manipulate Songs and Playlists Stored on an iPod
libgroove-devel-4.3.0-9.1.i586.rpm Development files for libgroove
libgroove-devel-4.3.0-9.1.x86_64.rpm Development files for libgroove
libgroove4-4.3.0-9.1.i586.rpm A library to streaming audio processing
Advertisement
Advertisement