libffado-devel-2.4.1-100.4.x86_64.rpm


Advertisement

Description

libffado-devel - Development files for ffado

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename libffado-devel-2.4.1-100.4.x86_64.rpm
Package name libffado-devel
Package version 2.4.1
Package release 100.4
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.ffado.org/
License GPL-2.0-or-later
Maintainer -
Download size 16.27 KB
Installed size 16.93 KB
This package supplys the files necessary to develop
applications that use the FFADO libraries and api.

Alternatives

Package Version Architecture Repository
libffado-devel-2.4.1-100.4.i586.rpm 2.4.1 i586 Multimedia Libs
libffado-devel-2.4.1-2.1.x86_64.rpm 2.4.1 x86_64 openSUSE Oss
libffado-devel-2.4.1-2.1.i586.rpm 2.4.1 i586 openSUSE Oss
libffado-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
libconfig-devel -
libdbus-c++-devel -
libffado2 = 2.4.1

Provides

Name Value
libffado-devel = 2.4.1-100.4
libffado-devel(x86-64) = 2.4.1-100.4
pkgconfig(libffado) = 2.4.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libffado-devel-2.4.1-100.4.x86_64.rpm
Source Package ffado-2.4.1-100.4.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install libffado-devel rpm package:
    # zypper install libffado-devel

Files

Path
/usr/include/libffado/ffado.h
/usr/lib64/libffado.so
/usr/lib64/pkgconfig/libffado.pc

Changelog

2019-01-03 - davejplater@gmail.com
- Update to release 2.4.1
- Removed uneeded and incorporated patches:
libffado-SConstruct-py3.patch, ffado-gcc6.patch and byteswap.patch
- Upstream changes:
* Fix some python syntax which was not compatible with python3.
These were missed during the preparation of FFADO 2.4.0.
* Modify the SCons build system to allow for scons running under
python3.
* Merge distribution patches provided by package maintainers.
* Address some difficulties experienced by package maintainers
when compiling FFADO.
* Improve the output of ffado-diag.
2018-10-21 - schwab@suse.de
- byteswap.patch: ensure byte swap macros are available for all components
2018-08-17 - bwiedemann@suse.com
- Add reproducible.patch to always build with SSE2,
independent of build system CPU (boo#1100677)
2018-02-08 - davejplater@gmail.com
- Update to release 2.4.0 and fix build against glibc-2.27
see boo#1079938.
- Removed patches fixed upstream:
ffado_SConstruct_powerpc_update.patch and sigev.patch.
- Rebased libffado-SConstruct-py3.patch partially fixed upstream.
- Added ffado-nosys.patch for missing import sys in SConstruct.
- Rebased ffado-gcc6.patch, partially fixed upstream.
- Upstream changes:
* Numerous build system and code improvements to support
architectures such as MIPS, x32 and various PowerPC flavours.
* A large number of fixes for newer versions of gcc
(particularly versions 6 and 7).
* Initial support for the optional TCO module of the
RME Fireface-800.
* Expanded ffado-mixer support for the Phase88 device.
* Initial work to make ffado-mixer compatible with
python3/pyqt5.
* Start work towards compatibility with scons3.
2017-12-04 - dimstar@opensuse.org
- Extend libffado-SConstruct-py3.patch: convert more of the build
tools to python3. This allows us not to pull a different version
of python into buildroot than is not already used by SCons.
2017-11-24 - davejplater@gmail.com
- Added conditional for libffado-SConstruct-py3.patch to only apply
if scons built with python 3.
2017-11-23 - astieger@suse.com
- Fix building with python3 scons, add libffado-SConstruct-py3.patch
2017-07-31 - schwab@suse.de
- sigev.patch: add missing header to define SIGEV_THREAD
2017-04-12 - davejplater@gmail.com
- Modify libffado-date_time.patch to allow reproducible builds.
2017-03-31 - davejplater@gmail.com
- Update to 2.3.0
- Fix gcc7 errors with -fpermissive see boo#1030245
- Removed obsolete udev macro definition
- Rebased ffado_SConstruct_powerpc_update.patch and
ffado-gcc6.patch
- Duplicated %build scons statement in %install to prevent a
complete rebuild of the package.
- Upstream changes:
* Configuration entries added for additional devices which work
with the generic support layer (PreSonus Studiolive 32.4.2,
Presonus StudioLive 16.0.2, ICON FireXon, Onyx Blackbird and
the new Onyx 1640i, among others).
* Support added for the newer Focusrite Saffire Pro 26.
* Improved build support for various downstream consumers.
* Better routing for selected Saffire devices and the Firestudio
Mobile.
* Significant cleanup and refinement of the M-Audio and Yamaha
driver.
* Compilation fixes for recent versions of gcc.
* Recover from dead streams without causing jackd to shut down.

See Also

Package Description
libffado2-2.4.1-100.4.i586.rpm FireWire 1394 support for audio devices
libffado2-2.4.1-100.4.x86_64.rpm FireWire 1394 support for audio devices
libffado2-32bit-2.4.1-100.4.x86_64.rpm FireWire 1394 support for audio devices
libffms2-4-2.23.1-4.29.i586.rpm Wrapper library around libffmpeg
libffms2-4-2.23.1-4.29.x86_64.rpm Wrapper library around libffmpeg
libffms2-4-32bit-2.23.1-4.29.x86_64.rpm Wrapper library around libffmpeg
libffms2-devel-2.23.1-4.29.i586.rpm Wrapper library around libffmpeg
libffms2-devel-2.23.1-4.29.x86_64.rpm Wrapper library around libffmpeg
libfftw3-3-3.3.8-88.3.i586.rpm Discrete Fourier Transform (DFT) C Subroutine Library
libfftw3-3-3.3.8-88.3.x86_64.rpm Discrete Fourier Transform (DFT) C Subroutine Library
libfftw3-3-32bit-3.3.8-88.3.x86_64.rpm Discrete Fourier Transform (DFT) C Subroutine Library
libfftw3-gnu-hpc-3.3.8-88.3.i586.rpm Dependency package for libfftw3_3_3_8-gnu-hpc
libfftw3-gnu-hpc-3.3.8-88.3.x86_64.rpm Dependency package for libfftw3_3_3_8-gnu-hpc
libfftw3-gnu-mpich-hpc-3.3.8-88.3.i586.rpm Dependency package for libfftw3_3_3_8-gnu-mpich-hpc
libfftw3-gnu-mpich-hpc-3.3.8-88.3.x86_64.rpm Dependency package for libfftw3_3_3_8-gnu-mpich-hpc
Advertisement
Advertisement