ladspa-32bit-1.15-67.7.x86_64.rpm


Advertisement

Description

ladspa-32bit - The Linux Audio Developer's Simple Plug-In API

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename ladspa-32bit-1.15-67.7.x86_64.rpm
Package name ladspa-32bit
Package version 1.15
Package release 67.7
Package architecture x86_64
Package type rpm
Category Productivity/Multimedia/Sound/Utilities
Homepage http://www.ladspa.org/
License LGPL-2.1-or-later
Maintainer -
Download size 18.65 KB
Installed size 67.13 KB
The Linux Audio Developer's Simple Plug-in API (LADSPA) provides the
ability to write simple plug-in audio processors in C/C++ and link them
dynamically.  This package contains the plugins built from LADSPA SDK.

Alternatives

Package Version Architecture Repository
ladspa-32bit-1.15-1.2.x86_64.rpm 1.15 x86_64 openSUSE Oss
ladspa-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.1.3) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
ladspa-32bit = 1.15-67.7
ladspa-32bit(x86-32) = 1.15-67.7

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ladspa-32bit-1.15-67.7.x86_64.rpm
Source Package ladspa-1.15-67.7.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install ladspa-32bit rpm package:
    # zypper install ladspa-32bit

Files

Path
/usr/lib/ladspa/amp.so
/usr/lib/ladspa/delay.so
/usr/lib/ladspa/filter.so
/usr/lib/ladspa/noise.so
/usr/lib/ladspa/sine.so

Changelog

2019-01-06 - davejplater@gmail.com
- Update to version 1.15 removed incorporated patch:
ladspa-ldcommand.patch and ladspa.diff
- Upstream changes:
* Perform macro string expansion in C code rather than in Makefile
for better portability.
* Modernise init()/fini() style in GNU C plugin builds (not C++),
tweak link line to correspond.
2019-01-05 - davejplater@gmail.com
- Update to version 1.4 and remove incorporated patches:
ladspa-find-plugin-path.patch and ladspa-pie.patch
- Modified ladspa.dif, one hunk was incorporated.
- Added ladspa-ldcommand.patch to fix plugin linking.
- Upstream changes:
* Rename Makefile.
* Modernise C++ #include style.
* Make some globals static.
* Use mkdir -p rather than mkdirhier during build.
* Use GCC export map to ensure only the ladspa_descriptor()
is  exported.
* Put libraries at the end of link instructions.
* Package with version number in archive and directory names.
* Tweaks to documentation processing.
* Fix bug in LADSPA plugin search which did not handle shared
libraries that are not plugins correctly.
* Introduce a default LADSPA plugin search path.
2017-11-04 - davejplater@gmail.com
- Add ladspa-find-plugin-path.patch to enable listplugins to find
plugins without LADSPA_PATH variable set.
- Add ladspa-pie.patch to enable position independent executables.
2014-03-03 - tiwai@suse.de
- package the original tarball instead of re-packed tar.bz2
2014-03-01 - andreas.stieger@gmx.de
- some spec file cleanup
- add source URLs, see https://en.opensuse.org/SourceUrls
2013-12-16 - tiwai@suse.de
- Split to each plugin sub-package; also fix the self-dependency
on ladspa-devel
- Fix build with SLE11 targets
2013-12-04 - tiwai@suse.de
- Merge ladspa-devel.spec into ladspa.spec; back to root, as OBS
doesn't like split packages (the submitreq always declined),
and the development activity of this package is pretty low, so
no worth to resist
2013-09-26 - tiwai@suse.de
- caps-fix-double-free.diff:
Fix double free in destructor of caps plugin (bnc#842420)
2012-02-14 - coolo@suse.com
- remove old %suse_update_config
2012-02-09 - reddwarf@opensuse.org
- Remove swh-configure-2.65.patch for >12.1

See Also

Package Description
ladspa-AMB-0.6.1-9.33.i586.rpm LADSPA Ambisonics plugin
ladspa-AMB-0.6.1-9.33.x86_64.rpm LADSPA Ambisonics plugin
ladspa-FIL-0.3.0-9.32.i586.rpm LADSPA FIL-plugin
ladspa-FIL-0.3.0-9.32.x86_64.rpm LADSPA FIL-plugin
ladspa-MCP-0.4.0-9.34.i586.rpm LADSPA MCP-plugins
ladspa-MCP-0.4.0-9.34.x86_64.rpm LADSPA MCP-plugins
ladspa-REV-0.3.1-9.30.i586.rpm LADSPA REV-plugin
ladspa-REV-0.3.1-9.30.x86_64.rpm LADSPA REV-plugin
ladspa-VCO-0.3.0-9.30.i586.rpm LADSPA VCO-plugin
ladspa-VCO-0.3.0-9.30.x86_64.rpm LADSPA VCO-plugin
ladspa-alienwah-1.13-7.29.i586.rpm LADSPA alienwah plugin
ladspa-alienwah-1.13-7.29.x86_64.rpm LADSPA alienwah plugin
ladspa-blepvco-0.1.0-9.32.i586.rpm LADSPA blepvco plugin
ladspa-blepvco-0.1.0-9.32.x86_64.rpm LADSPA blepvco plugin
ladspa-blop-0.2.8-9.35.i586.rpm LADSPA blop plugins
Advertisement
Advertisement