dssi-devel-1.1.1-35.53.i586.rpm


Advertisement

Description

dssi-devel - Development Package for DSSI plugins

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename dssi-devel-1.1.1-35.53.i586.rpm
Package name dssi-devel
Package version 1.1.1
Package release 35.53
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://dssi.sf.net/
License GPL-2.0+ and LGPL-2.1+ and SUSE-Public-Domain
Maintainer -
Download size 14.78 KB
Installed size 18.34 KB
This package contains files to be needed for building DSSI plugins.

Alternatives

Package Version Architecture Repository
dssi-devel-1.1.1-35.53.x86_64.rpm 1.1.1 x86_64 Multimedia Libs
dssi-devel-1.1.1-11.12.x86_64.rpm 1.1.1 x86_64 openSUSE Oss
dssi-devel-1.1.1-11.12.i586.rpm 1.1.1 i586 openSUSE Oss
dssi-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
ladspa-devel -

Provides

Name Value
dssi-devel = 1.1.1-35.53
dssi-devel(x86-32) = 1.1.1-35.53
pkgconfig(dssi) = 1.1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package dssi-devel-1.1.1-35.53.i586.rpm
Source Package dssi-1.1.1-35.53.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install dssi-devel rpm package:
    # zypper install dssi-devel

Files

Path
/usr/include/dssi.h
/usr/lib/pkgconfig/dssi.pc

Changelog

2014-10-05 - davejplater@gmail.com
- Own the dssi libdir
2013-03-05 - coolo@suse.com
- update license to new format
2012-01-10 - reddwarf@opensuse.org
- Update to version 1.1.1:
* Fix to a crash on startup in one of the example plugins
(less_trivial_synth)
- Run spec-cleaner
2011-09-30 - coolo@suse.com
- add libtool as buildrequire to make the spec file more reliable
2011-09-18 - jengelh@medozas.de
- Remove redundant tags/sections from specfile
(cf. packaging guidelines)
- Use %_smp_mflags for parallel build
2011-08-30 - crrodriguez@opensuse.org
- Fix linking with new toolchain.
2010-09-22 - davejplater@gmail.com
- Update to version 1.1.0
- Upstram changes :
* Man page updates.
* Added '-c' option for client name to jack-dssi-host.
* Fixed configure.ac to check for OS X Qt 4 frameworks, and to add
'-lX11' to QT_LIBS when Qt is X11-based.
* Added dssi_list_plugins and dssi_analyse_plugin tools.
* Updated README for Qt 4 and new tools.
* Fixed jack-dssi-host.c ALSA client ports to be of type 'application'.
* Fixed trivial_synth.c getControllerTS() to use DSSI_CC().
* examples/Makefile.am fixes: reverted trivial_sampler_qt_CXXFLAGS
to again include $(ALSA_CFLAGS); added math lib to trivial_synth_la_LIBADD.
* Version bump to 1.0.1.
* Updated example GUIs to use Qt 4 (thanks to Charles Fl├Ęche!)
* Fixed an uninitialized variable bug in less_trivial_synth.c.
2009-07-24 - tiwai@suse.de
- fix dssi-devel not to require dssi itself (no dependecny!)
2009-07-24 - tiwai@suse.de
- split to devel sub-package
2009-07-22 - tiwai@suse.de
- add missing closedir() (bnc#524217)

See Also

Package Description
echomixer-1.0.5-115.1.i586.rpm Echoaudio console application
echomixer-1.0.5-115.1.x86_64.rpm Echoaudio console application
envy24control-0.6.0-115.1.i586.rpm Control tool for Envy24 (ice1712) based soundcards
envy24control-0.6.0-115.1.x86_64.rpm Control tool for Envy24 (ice1712) based soundcards
exempi-tools-2.4.5-36.17.i586.rpm Tools from Exempi, an XMP support library
exempi-tools-2.4.5-36.17.x86_64.rpm Tools from Exempi, an XMP support library
ffado-2.4.1-100.4.i586.rpm FireWire 1394 support for audio devices, svn snapshot
ffado-2.4.1-100.4.x86_64.rpm FireWire 1394 support for audio devices, svn snapshot
ffado-mixer-2.4.1-100.1.noarch.rpm FireWire 1394 support for audio devices, svn snapshot
ffmpeg-4-4.1.3-62.1.i586.rpm Library for working with various multimedia formats
ffmpeg-4-4.1.3-64.1.x86_64.rpm Library for working with various multimedia formats
ffmpeg-4-libavcodec-devel-4.1.3-62.1.i586.rpm Development files for FFmpeg's codec library
ffmpeg-4-libavcodec-devel-4.1.3-64.1.x86_64.rpm Development files for FFmpeg's codec library
ffmpeg-4-libavdevice-devel-4.1.3-62.1.i586.rpm Development files for FFmpeg's device library
ffmpeg-4-libavdevice-devel-4.1.3-64.1.x86_64.rpm Development files for FFmpeg's device library
Advertisement
Advertisement