audaspace-plugins-1.3.0-61.4.i586.rpm


Advertisement

Description

audaspace-plugins - Plugins for audaspace

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Libs all
Package filename audaspace-plugins-1.3.0-61.4.i586.rpm
Package name audaspace-plugins
Package version 1.3.0
Package release 61.4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://github.com/audaspace/audaspace/releases/tag/v1.3.0
License Apache-2.0
Maintainer -
Download size 68.73 KB
Installed size 226.96 KB
Audaspace (pronounced "outer space") is a high-level audio library written
in C++ with language bindings for Python for example. It started out as the
audio engine of the 3D modelling application Blender and is now released as
a standalone library. This package contains audio plugins.

Alternatives

Package Version Architecture Repository
audaspace-plugins-1.3.0-61.4.x86_64.rpm 1.3.0 x86_64 Multimedia Libs
audaspace-plugins-1.3.0-9.1.x86_64.rpm 1.3.0 x86_64 openSUSE Oss
audaspace-plugins-1.3.0-9.1.i586.rpm 1.3.0 i586 openSUSE Oss
audaspace-plugins - - -

Requires

Name Value
audaspace = 1.3.0
libSDL2-2.0.so.0 -
libaudaspace.so.1.3 -
libavcodec.so.58 -
libavcodec.so.58(LIBAVCODEC_58) -
libavformat.so.58 -
libavformat.so.58(LIBAVFORMAT_58) -
libavutil.so.56 -
libavutil.so.56(LIBAVUTIL_56) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libjack.so.0 -
libopenal.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libsndfile.so.1 -
libsndfile.so.1(libsndfile.so.1.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.22) -
libstdc++.so.6(GLIBCXX_3.4.9) -

Provides

Name Value
audaspace-plugins = 1.3.0-61.4
audaspace-plugins(x86-32) = 1.3.0-61.4
libaudffmpeg.so -
libaudjack.so -
libaudlibsndfile.so -
libaudopenal.so -
libaudsdl.so -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package audaspace-plugins-1.3.0-61.4.i586.rpm
Source Package audaspace-1.3.0-61.4.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Tumbleweed/ multimedia-libs
  2. Install audaspace-plugins rpm package:
    # zypper install audaspace-plugins

Files

Path
/usr/lib/audaspace-1.3/
/usr/lib/audaspace-1.3/plugins/libaudffmpeg.so
/usr/lib/audaspace-1.3/plugins/libaudjack.so
/usr/lib/audaspace-1.3/plugins/libaudlibsndfile.so
/usr/lib/audaspace-1.3/plugins/libaudopenal.so
/usr/lib/audaspace-1.3/plugins/libaudsdl.so

Changelog

2019-02-12 - bjorn.lie@gmail.com
- Add audaspace-support-ffmpeg4.patch: Fix build with ffmpeg 4.
2018-05-04 - olaf@aepfle.de
- Use ffmpeg3 versions of pkgconfig(libav*)
2018-04-21 - jengelh@inai.de
- Explicitly request ffmpeg 3.x for building
2017-10-23 - davejplater@gmail.com
- Added upstream patch audaspace-plugin-build-options.patch as
final fix for boo#1057965 and audaspace issue#10.
- Build example executables as position independent executables.
2017-10-18 - davejplater@gmail.com
- Delete plugin symlinks and remove version suffixes to further fix
boo#1057965 and audaspace issue#10
2017-09-22 - davejplater@gmail.com
- Moved lib*.so plugin symlinks from the devel package to the
pluginsn package as a temporary work around for boo#1057965
reported upstream https://github.com/audaspace/audaspace/issues/10
2017-03-28 - davejplater@gmail.com
- Fix gcc7 build by requiring graphviz-gnome and creating
audaspace-gcc7.patch to add missing #include <functional>
2017-02-11 - jengelh@inai.de
- Rename %soname to %sover to better reflect its use.
Update descriptions.
2017-02-10 - davejplater@gmail.com
- Update to release 1.3.0
- Removed patch audaspace-findffmpeg.patch Fixed upstream
- Upstream changes:
* Audaspace 1.3.0 is a bug fixing release without changes to the
API, but two small new features:
linear interpolation for volume changes in the software mixer
dynamic Loading for JACK
* Bug fixes:
renamed Jack to JACK
C API was not working
filter python API parameter check
finding ffmpeg with pkgconfig
2016-07-03 - mpluskal@suse.com
- Fix building with recent cmake (macros), which default to -fPIE

See Also

Package Description
audiofile-0.3.6-56.6.i586.rpm An Audio File Library
audiofile-0.3.6-56.6.x86_64.rpm An Audio File Library
audiofile-devel-0.3.6-56.6.i586.rpm An audio file library
audiofile-devel-0.3.6-56.6.x86_64.rpm An audio file library
audiofile-devel-32bit-0.3.6-56.6.x86_64.rpm An audio file library
audiofile-doc-0.3.6-56.6.i586.rpm An audio file library
audiofile-doc-0.3.6-56.6.x86_64.rpm An audio file library
bcmatroska2-devel-0.23-5.5.i586.rpm Development files for bcmatroska2
bcmatroska2-devel-0.23-5.5.x86_64.rpm Development files for bcmatroska2
bs2b-tools-3.1.0-17.30.i586.rpm Tools to use the Bauer stereophonic-to-binaural DSP
bs2b-tools-3.1.0-17.30.x86_64.rpm Tools to use the Bauer stereophonic-to-binaural DSP
caca-utils-0.99.beta19.git20171003-67.4.i586.rpm Colour ASCII Art Text mode graphics utilities based on libcaca
caca-utils-0.99.beta19.git20171003-67.4.x86_64.rpm Colour ASCII Art Text mode graphics utilities based on libcaca
cd-paranoia-10.2+2.0.0-22.5.i586.rpm CDDA reader
cd-paranoia-10.2+2.0.0-22.5.x86_64.rpm CDDA reader
Advertisement
Advertisement