libxine-devel-1.2.9-135.7.x86_64.rpm


Advertisement

Description

libxine-devel - Development environment for xine-based media players

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Apps all
Package filename libxine-devel-1.2.9-135.7.x86_64.rpm
Package name libxine-devel
Package version 1.2.9
Package release 135.7
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.xine-project.org/
License GPL-2.0+ and SUSE-Public-Domain
Maintainer -
Download size 95.26 KB
Installed size 343.41 KB
This package contains all necessary include files, libraries and
configuration files needed to compile applications that use the xine
media player.
xine is a video player which supports a large number of file formats
(i.e., VCD, MPEG2) using plug-ins. Several plug-ins are included.
Others can be post-installed. Supports stereo sound using OSS and AC5.1
using Alsa.
This version of xine may lack certain features because of legal
requirements (potential patent violation). See also
http://www.opensuse.org/XINE#Legal_Matters
More information about xine plug-ins can be found at
http://www.xine-project.org/home
Authors:
--------
Guenter Bartsch <guenter@users.sourceforge.net>

Alternatives

Package Version Architecture Repository
libxine-devel-1.2.9-149.11.i586.rpm 1.2.9 i586 Packman
libxine-devel-1.2.9-149.11.x86_64.rpm 1.2.9 x86_64 Packman
libxine-devel-1.2.9-7.1.x86_64.rpm 1.2.9 x86_64 openSUSE Oss
libxine-devel-1.2.9-7.1.i586.rpm 1.2.9 i586 openSUSE Oss
libxine-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
freetype2-devel -
glibc-devel -
libv4l-devel -
libxine2 = 1.2.9
zlib-devel -

Provides

Name Value
libxine-devel = 1.2.9-135.7
libxine-devel(x86-64) = 1.2.9-135.7
libxine2-devel = 1.2.9-135.7
pkgconfig(libxine) = 1.2.9
xine-devel = 1.2.9-135.7
xine-lib2-devel = 1.2.9-135.7

Obsoletes

Name Value
libxine2-devel < 1.2.9-135.7
xine-devel < 1.2.9-135.7
xine-lib2-devel < 1.2.9-135.7

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libxine-devel-1.2.9-135.7.x86_64.rpm
Source Package xine-lib-1.2.9-135.7.src.rpm

Install Howto

  1. Add the Multimedia Apps repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/apps/openSUSE_Tumbleweed/ multimedia-apps
  2. Install libxine-devel rpm package:
    # zypper install libxine-devel

Files

Path
/usr/bin/xine-config
/usr/include/xine.h
/usr/include/xine/alphablend.h
/usr/include/xine/array.h
/usr/include/xine/attributes.h
/usr/include/xine/audio_decoder.h
/usr/include/xine/audio_out.h
/usr/include/xine/broadcaster.h
/usr/include/xine/buffer.h
/usr/include/xine/compat.h
/usr/include/xine/configfile.h
/usr/include/xine/demux.h
/usr/include/xine/info_helper.h
/usr/include/xine/input_plugin.h
/usr/include/xine/io_helper.h
/usr/include/xine/list.h
/usr/include/xine/metronom.h
/usr/include/xine/os_types.h
/usr/include/xine/osd.h
/usr/include/xine/plugin_catalog.h
/usr/include/xine/pool.h
/usr/include/xine/post.h
/usr/include/xine/refcounter.h
/usr/include/xine/resample.h
/usr/include/xine/ring_buffer.h
/usr/include/xine/scratch.h
/usr/include/xine/sorted_array.h
/usr/include/xine/spu.h
/usr/include/xine/spu_decoder.h
/usr/include/xine/vdr.h
/usr/include/xine/version.h
/usr/include/xine/video_decoder.h
/usr/include/xine/video_out.h
/usr/include/xine/video_overlay.h
/usr/include/xine/vo_scale.h
/usr/include/xine/xine_buffer.h
/usr/include/xine/xine_internal.h
/usr/include/xine/xine_plugin.h
/usr/include/xine/xineintl.h
/usr/include/xine/xineutils.h
/usr/include/xine/xmllexer.h
/usr/include/xine/xmlparser.h
/usr/lib64/libxine.so
/usr/lib64/pkgconfig/libxine.pc
/usr/share/aclocal/xine.m4
/usr/share/man/man1/xine-config.1.gz

Changelog

2018-06-02 - bjorn.lie@gmail.com
- Set to bcond_without gnome_vfs to bcond_with, no longer build
gnome-vfs support by default, gnome-vfs is deprecated upstream
for a long time.
2018-01-27 - davejplater@gmail.com
- Rebase fix-non-x86-build.diff to fix arm build.
2018-01-23 - davejplater@gmail.com
- Update to release 1.2.9 and add xine-lib-a52dec.patch.
- Moved xineplug_decode_mad and xineplug_decode_a52 into the main
package as they are now unrestricted.
- Enabled sdl and jack subpackages.
- Upstream changes:
* Add LIBXINE_VERBOSITY environment var override.
* Add auto gapless switch. Play clips to their very end when that
is likely what the user wants.
* Add video single step feature.
* Add generic keyframe index feature.
* Add x32 (x86 32 on 64bit) support.
* Add some more debug logging.
* Join 4 network input plugins into a single file.
* Matroska fixes.
* Build fixes.
* Directx2 audio fixes.
* VAAPI fixes.
* XCB video fixes and optimizations.
* Return driver held video frames on shutdown properly.
* FAAD audio compatibility fixes.
* Fix VP9 playback.
* Fix post filtering crash.
* Make xml parser thread safe.
* More user configuration safety.
* Inline assembly fixes.
* Failed memory allocation safety fixes.
* Memory leak fixes.
* Debug and LOG build fixes.
* Again, lots of small fixes and optimizations.
* Better multiengine client safety.
* Hide yuv2rgb implementation details.
* Use a single libyuv2rgb copy in both engine and plugins.
* Minor ffmpeg optimization.
* Lift a few video engine handbrakes. Less CPU load, fewer frame
drops, faster seeking.
* Optimize audio engine.
* Optimize demux buffering system.
* Optimize metronom clock.
* Optimize port tickets.
* Optimize sse/mmx2 memcpy.
* Code simplification and cleanup.
* Update german translation. * Add LIBXINE_VERBOSITY environment var override.
* Add auto gapless switch. Play clips to their very end when that
is likely what the user wants.
* Add video single step feature.
* Add generic keyframe index feature.
* Add x32 (x86 32 on 64bit) support.
* Add some more debug logging.
* Join 4 network input plugins into a single file.
* Matroska fixes.
* Build fixes.
* Directx2 audio fixes.
* VAAPI fixes.
* XCB video fixes and optimizations.
* Return driver held video frames on shutdown properly.
* FAAD audio compatibility fixes.
* Fix VP9 playback.
* Fix post filtering crash.
* Make xml parser thread safe.
* More user configuration safety.
* Inline assembly fixes.
* Failed memory allocation safety fixes.
* Memory leak fixes.
* Debug and LOG build fixes.
* Again, lots of small fixes and optimizations.
* Better multiengine client safety.
* Hide yuv2rgb implementation details.
* Use a single libyuv2rgb copy in both engine and plugins.
* Minor ffmpeg optimization.
* Lift a few video engine handbrakes. Less CPU load, fewer frame
drops, faster seeking.
* Optimize audio engine.
* Optimize demux buffering system.
* Optimize metronom clock.
* Optimize port tickets.
* Optimize sse/mmx2 memcpy.
* Code simplification and cleanup.
* Update german translation.
2018-01-22 - crrodriguez@opensuse.org
- Cleanup buildrequires so neither Mesa-devel nor xorg-x11-devel
meta/mega packages are required anymore.
2017-08-15 - olaf@aepfle.de
- Build unconditionally with modplug and pulseaudio
2017-07-06 - olaf@aepfle.de
- Remove dependency to gcc5
- Use simple bcond for ffmpeg

See Also

Package Description
libxine2-1.2.9-135.7.x86_64.rpm Video Player with Plug-Ins
libxine2-jack-1.2.9-135.7.x86_64.rpm Jack plugin for xine
libxine2-pulse-1.2.9-135.7.x86_64.rpm Pulseaudio plugin for xine
libxine2-sdl-1.2.9-135.7.x86_64.rpm SDL plugin for xine
libxnoise-devel-0.2.21-17.9.x86_64.rpm Development files of libxnoise
libxnoise-devel-0.2.21-20.9.i586.rpm Development files of libxnoise
libxnoise0-0.2.21-17.9.x86_64.rpm Library for xnoise
libxnoise0-0.2.21-20.9.i586.rpm Library for xnoise
libyami-utils-1.3.0-9.7.x86_64.rpm Collection of tools for development and testing of Libyami
libzvbi-chains0-0.2.35-49.10.x86_64.rpm VBI Decoding Library
libzvbi-chains0-0.2.35-49.18.i586.rpm VBI Decoding Library
libzvbi-chains0-32bit-0.2.35-49.18.x86_64.rpm VBI Decoding Library
libzvbi0-0.2.35-49.10.x86_64.rpm VBI Decoding Library
libzvbi0-0.2.35-49.18.i586.rpm VBI Decoding Library
libzvbi0-32bit-0.2.35-49.18.x86_64.rpm VBI Decoding Library
Advertisement
Advertisement