libaudcore5-3.10-10.4.x86_64.rpm


Advertisement

Description

libaudcore5 - Main functionality library of Audacious

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Apps all
Package filename libaudcore5-3.10-10.4.x86_64.rpm
Package name libaudcore5
Package version 3.10
Package release 10.4
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://audacious-media-player.org/
License BSD-2-Clause
Maintainer -
Download size 138.38 KB
Installed size 343.95 KB
Library from the Audacious audio player.

Alternatives

Package Version Architecture Repository
libaudcore5-3.10.1-12.10.i586.rpm 3.10.1 i586 Multimedia Apps
libaudcore5-3.10.1-1.3.x86_64.rpm 3.10.1 x86_64 openSUSE Oss
libaudcore5-3.10.1-1.3.i586.rpm 3.10.1 i586 openSUSE Oss
libaudcore5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.15)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libaudcore(x86-64) = 3.10
libaudcore.so.5()(64bit) -
libaudcore5 = 3.10-10.4
libaudcore5(x86-64) = 3.10-10.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libaudcore5-3.10-10.4.x86_64.rpm
Source Package audacious-3.10-10.4.src.rpm

Install Howto

  1. Add the Multimedia Apps repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/apps/openSUSE_Tumbleweed/ multimedia-apps
  2. Install libaudcore5 rpm package:
    # zypper install libaudcore5

Files

Path
/usr/lib64/libaudcore.so.5
/usr/lib64/libaudcore.so.5.1.0

Changelog

2018-08-09 - sor.alexei@meowr.ru
- Update to version 3.10:
+ New features (general):
* Shuffle history is remembered at exit to avoid repeating
songs.
* Exported M3U and PLS playlists now use relative paths by
default.
* Recursively adding subdirectories to the playlist is now
optional.
* The URL history shown in the Add/Open URL dialogues can be
cleared.
* Toolbar buttons in the GTK+ UI now show tooltip hints.
* The adplug input plugin has a new settings window.
* The Search Tool can be configured to scan for new files at
start-up.
* The number of results shown in the Search Tool is now
configurable.
* The Delete Files plugin is clearer about which files will be
deleted.
* Icons from the desktop theme are used more consistently.
* The bottom info bar now matches the colour tone of dark
themes.
* The soxr resampler has some new, more detailed settings.
+ Qt UI enhancements:
* "audacious -m" now raises the main window as expected.
* The number pad Enter key now starts playback as expected.
* The Escape key can be used to return to the currently playing
playlist.
* Fix the row height of the playlist view changing
unexpectedly.
* Volume can be changed using the mouse wheel on the system
tray icon.
* Add Playlist Import/Export dialogue windows.
* Add a song info tooltip to the playlist and system tray icon.
* Add a "Play" icon to the tab of the currently playing
playlist.
* Add a label showing file path/URI to the song info window.
* URI and tag values in the song info window can be copied to
the clipboard.
* Add the missing "Search Library" command in the Winamp UI.
* Add font formatting to improve readability in the
Search Tool.
* Fix a build error (QStaticText-related) with Qt 5.10.
* Fix Audacious exiting when the settings window is closed.
* Fix font preferences not being respected in a couple of
places.
* Fix playlist position sometimes not updating when the song
changes.
* The info bar correctly changes colour when the theme changes.
+ Bugs fixed:
* Non-existent files are no longer skipped when loading a
playlist.
* Fix an issue when trying to seek beyond the end of a WAV
file.
* The default ReplayGain amplification for untagged files works
again.
* Fix a crash when changing UI with the Ampache plugin enabled.
* Fix a crash on exit when using the Winamp UI and the Ampache
plugin.
* Fix a warning about --datarootdir when running ./configure.
* Reduce excessive file I/O when loading playlists.
* Fix repeated error messages when playing a short playlist on
repeat.
* PulseAudio users can now change the volume without a song
playing.
* Fix an error preventing FLAC tags from being updated.
* Add a .m4v extension to the whitelist so that audio can be
played.
* Fix a rare crash triggered by a specific sequence of playlist
edits.
* Fix incorrect "Recording On/Off" notifications in the
Winamp UI.
* Fix an error in the MPRIS 2 server affecting the playerctl
client.
+ Other changes:
* The GNOME Shortcuts plugin, which has been broken since
GNOME 3.26, is gone.
* The system version of the AdPlug library is now used
(if installed).
* Audacious no longer registers as an inode/directory MIME
type handler.
- Remove audacious-no-inode-directory-mimetype.patch: fixed
upstream.
- Switch back to Gtk2 from Gtk3 for the Gtk3 version is gone.
2017-10-29 - olaf@aepfle.de
- Remove the versioned conditional for Qt build.
It builds fine in PackageHub, and audacious-plugins expects the
Qt variant.
- Remove Qt and GTK conditionals, they are always enabled and the
name is too generic
- Remove conditional for appdata for obsolete Leap 42.1

See Also

Package Description
libaudgui5-3.10-10.4.x86_64.rpm GTK GUI implementation of Audacious
libaudgui5-3.10.1-12.10.i586.rpm GTK GUI implementation of Audacious
libaudqt2-3.10-10.4.x86_64.rpm QT GUI implementation of Audacious
libaudqt2-3.10.1-12.10.i586.rpm QT GUI implementation of Audacious
libaudtag3-3.10-10.4.x86_64.rpm ID3 and APE metadata support for Audacious
libaudtag3-3.10.1-12.10.i586.rpm ID3 and APE metadata support for Audacious
libbml-devel-0.10.2-43.5.x86_64.rpm Development files for libbml
libbml-devel-0.10.2-49.1.i586.rpm Development files for libbml
libbml1-0.10.2-43.5.x86_64.rpm Buzztrax Machine Loader
libbml1-0.10.2-49.1.i586.rpm Buzztrax Machine Loader
libbuzztrax-core-devel-0.10.2-43.5.x86_64.rpm Development files for libbuzztrax-core
libbuzztrax-core-devel-0.10.2-49.1.i586.rpm Development files for libbuzztrax-core
libbuzztrax-core1-0.10.2-43.5.x86_64.rpm Core support classes for buzztrax based applications
libbuzztrax-core1-0.10.2-49.1.i586.rpm Core support classes for buzztrax based applications
libbuzztrax-core1-32bit-0.10.2-49.1.x86_64.rpm Core support classes for buzztrax based applications
Advertisement
Advertisement