abcm2ps-8.14.4-15.1.i586.rpm


Advertisement

Description

abcm2ps - A program to typeset abc tunes into Postscript

Property Value
Distribution openSUSE Tumbleweed
Repository Multimedia Apps all
Package filename abcm2ps-8.14.4-15.1.i586.rpm
Package name abcm2ps
Package version 8.14.4
Package release 15.1
Package architecture i586
Package type rpm
Category Productivity/Publishing/Other
Homepage https://github.com/leesavide/abcm2ps/
License GPL-2.0-or-later
Maintainer -
Download size 237.15 KB
Installed size 534.83 KB
abcm2ps is a package which converts music tunes from ABC format to
PostScript. Based on abc2ps version 1.2.5, it was developed mainly to print
barock organ scores which have independent voices played on one or many
keyboards and a pedal board. abcm2ps introduces many extensions to the ABC
language that make it suitable for classical music.

Alternatives

Package Version Architecture Repository
abcm2ps-8.14.4-1.1.x86_64.rpm 8.14.4 x86_64 openSUSE Oss
abcm2ps-8.14.4-1.1.i586.rpm 8.14.4 i586 openSUSE Oss
abcm2ps-8.14.0-3.1.x86_64.rpm 8.14.0 x86_64 Multimedia Apps
abcm2ps - - -

Requires

Name Value
libc.so.6(GLIBC_2.7) -
libfreetype.so.6 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpango-1.0.so.0 -
libpangocairo-1.0.so.0 -
libpangoft2-1.0.so.0 -

Provides

Name Value
abcm2ps = 8.14.4-15.1
abcm2ps(x86-32) = 8.14.4-15.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package abcm2ps-8.14.4-15.1.i586.rpm
Source Package abcm2ps-8.14.4-15.1.src.rpm

Install Howto

  1. Add the Multimedia Apps repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/apps/openSUSE_Tumbleweed/ multimedia-apps
  2. Install abcm2ps rpm package:
    # zypper install abcm2ps

Files

Path
/usr/bin/abcm2ps
/usr/share/abcm2ps/abc2svg.ttf
/usr/share/abcm2ps/flute.fmt
/usr/share/abcm2ps/landscape.fmt
/usr/share/abcm2ps/musicfont.fmt
/usr/share/doc/packages/abcm2ps/README.md
/usr/share/doc/packages/abcm2ps/accordion.abc
/usr/share/doc/packages/abcm2ps/bravura.abc
/usr/share/doc/packages/abcm2ps/chinese.abc
/usr/share/doc/packages/abcm2ps/deco.abc
/usr/share/doc/packages/abcm2ps/free.abc
/usr/share/doc/packages/abcm2ps/glyphs.abc
/usr/share/doc/packages/abcm2ps/newfeatures.abc
/usr/share/doc/packages/abcm2ps/sample.abc
/usr/share/doc/packages/abcm2ps/sample2.abc
/usr/share/doc/packages/abcm2ps/sample3.abc
/usr/share/doc/packages/abcm2ps/sample3.eps
/usr/share/doc/packages/abcm2ps/sample4.abc
/usr/share/doc/packages/abcm2ps/sample5.abc
/usr/share/doc/packages/abcm2ps/voices.abc
/usr/share/licenses/abcm2ps/COPYING
/usr/share/man/man1/abcm2ps.1.gz

Changelog

2019-03-18 - mvetter@suse.com
- Update to 8.14.4:
* program loop when P: on beamed note at end of line and %%breakoneoln 0
* crash/loop when slur between note and grace note and other slurs later
2019-03-11 - mvetter@suse.com
- Update to 8.14.3:
* erroneous double '8va's on a same staff when set on combined notes/rests
* don't put two '8va's on the same staff
* loss of %%sep since previous version
2018-12-22 - Michael Vetter <mvetter@suse.com>
- Update to 8.14.2:
* !8va! must be above the staff
* crash when SVG output and call to an unknown symbol in PS sequence
* crash when no note in voice overlay
* crash when SVG output and 'F' is not a font name in a PS sequence
* crash when only one bar in a voice and no symbol in a second voice
* possible crashes when bad definition of special decorations
* crash on decoration type 7 without start/stop
* crash on decoration type 5 without start/stop
* crash when unterminated decoration in U:
* crash when random character greater than 128 in a s: line
* bad test of font encoding
* read access outside of array when exact memory allocation of w:
* read access outside of array on small line starting with %%
* fixes from Debian (Makefile/configure/INSTALL)
2018-11-19 - mvetter@suse.com
- Update to 8.14.1:
* bad definition of the music font (@font-face[1])
* bad error when --pango 2 in command line and SVG output
* bad beams when notes on 2 staves and %%flatbeams
* error in SVG output when color setting since version v8.14.0
* code revert: use pango only when needed
* crash in 'make install' when no 'rst2man' in the shell PATH
2018-09-24 - Jan Engelhardt <jengelh@inai.de>
- Fix some grammar issues in descriptions.
- Use %configure macro.
2018-09-21 - Edgar Aichinger <edogawa@aon.at>
- more work on spec to enable A4 paper format and use pango for non-latin characters in PS output
- use make install target instead of custom commands in specfile
2018-09-13 - Edgar Aichinger <edogawa@aon.at>
- some minor specfile tweaks to reduce rpmlint warnings
2018-09-12 - mvetter@suse.com
- Update to 8.14.0:
* better handling of fonts when pango
* bad transposition when chord symbols separated by ';'
* always use pango when available
* Use CSS shorthand file description for SVG output
build:
* Split clean targets according to the GNU guidelines
* Install documentation into prefix/share/doc instead of prefix/doc
* Install the examples in a separate documentation directory
documentation:
* add man page
- Use github URL in source field
- Clean up spec file with spec-cleaner
- Clean up spec file according to rpmlint warnings
- Use %license tag for COPYING file
- Dont install INSTALL file
2018-01-12 - edogawa@aon.at
- updated to version 8.13.18
- sources are on github now, changed specfile accordingly
2013-05-21 - edogawa@aon.at
- updated to version 6.6.22

See Also

Package Description
abxtest-0.15.2b-5.15.x86_64.rpm Double-blind ABX comparison testing script
abxtest-0.15.2b-5.19.i586.rpm Double-blind ABX comparison testing script
adlmidi-1.2.6.2-3.1.i586.rpm A MIDI player that uses OPL3 emulation
adlmidi-tools-1.4.0.1-3.1.i586.rpm A MIDI player with OPL3 emulation
aegisub-3.2.2+git20180710-71.4.x86_64.rpm Subtitle editor
alevt-1.6.2-172.13.i586.rpm Teletext and Videotext Decoder for the BTTV Driver
alevt-1.6.2-172.5.x86_64.rpm Teletext and Videotext Decoder for the BTTV Driver
amsynth-1.8.0-11.7.x86_64.rpm Analog modelling (a.k.a virtual analog) software synthesizer
amsynth-1.9.0-12.2.i586.rpm Analog modelling (a.k.a virtual analog) software synthesizer
amsynth-lang-1.8.0-11.7.noarch.rpm Translations for package amsynth
amsynth-lang-1.9.0-12.2.noarch.rpm Translations for package amsynth
amsynth-plugin-dssi-1.8.0-11.7.x86_64.rpm Analog modelling (a.k.a virtual analog) software synthesizer
amsynth-plugin-dssi-1.9.0-12.2.i586.rpm Analog modelling (a.k.a virtual analog) software synthesizer
amsynth-plugin-lv2-1.8.0-11.7.x86_64.rpm Analog modelling (a.k.a virtual analog) software synthesizer
amsynth-plugin-lv2-1.9.0-12.2.i586.rpm Analog modelling (a.k.a virtual analog) software synthesizer
Advertisement
Advertisement