snorenotify-qt5-devel-0.7.0-ku.4.8.x86_64.rpm


Advertisement

Description

snorenotify-qt5-devel - Snorenotify is a multi platform Qt based notification framework

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename snorenotify-qt5-devel-0.7.0-ku.4.8.x86_64.rpm
Package name snorenotify-qt5-devel
Package version 0.7.0
Package release ku.4.8
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/KDE/snorenotify
License LGPL-3.0
Maintainer -
Download size 28.44 KB
Installed size 83.81 KB
Snorenotify is a multi platform Qt based notification framework. Using a plugin system it is possible to create notifications with many different notification systems on Windows, Unix and Mac.

Alternatives

Package Version Architecture Repository
snorenotify-qt5-devel-0.7.0-14.27.x86_64.rpm 0.7.0 x86_64 KDE 5
snorenotify-qt5-devel-0.7.0-14.27.i586.rpm 0.7.0 i586 KDE 5
snorenotify-qt5-devel-0.7.0-2.8.x86_64.rpm 0.7.0 x86_64 openSUSE Oss
snorenotify-qt5-devel-0.7.0-2.8.i586.rpm 0.7.0 i586 openSUSE Oss
snorenotify-qt5-devel-0.7.0-ku.4.8.i586.rpm 0.7.0 i586 KDE Unstable
snorenotify-qt5-devel - - -

Requires

Name Value
snorenotify-qt5 = 0.7.0

Provides

Name Value
cmake(LibsnoreQt5) = 0.7.0
cmake(LibsnoreSettingsQt5) = 0.7.0
snorenotify-qt5-devel = 0.7.0-ku.4.8
snorenotify-qt5-devel(x86-64) = 0.7.0-ku.4.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package snorenotify-qt5-devel-0.7.0-ku.4.8.x86_64.rpm
Source Package snorenotify-qt5-0.7.0-ku.4.8.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install snorenotify-qt5-devel rpm package:
    # zypper install snorenotify-qt5-devel

Files

Path
/usr/include/libsnore/alert.h
/usr/include/libsnore/application.h
/usr/include/libsnore/hint.h
/usr/include/libsnore/lambdahint.h
/usr/include/libsnore/snore.h
/usr/include/libsnore/snore_exports.h
/usr/include/libsnore/snore_p.h
/usr/include/libsnore/snoreglobals.h
/usr/include/libsnore/utils.h
/usr/include/libsnore/version.h
/usr/include/libsnore/notification/icon.h
/usr/include/libsnore/notification/notification.h
/usr/include/libsnore/notification/notificationaction.h
/usr/include/libsnore/plugins/plugins.h
/usr/include/libsnore/plugins/settingsplugin.h
/usr/include/libsnore/plugins/snorebackend.h
/usr/include/libsnore/plugins/snorefrontend.h
/usr/include/libsnore/plugins/snoresecondarybackend.h
/usr/include/libsnore/settings/pluginsettingswidget.h
/usr/include/libsnore/settings/settings.h
/usr/include/libsnore/settings/settingsdialog.h
/usr/include/libsnore/settings/snore_settings_exports.h
/usr/lib64/libsnore-qt5.so
/usr/lib64/libsnoresettings-qt5.so
/usr/lib64/cmake/libsnoreQt5/LibsnoreQt5Config.cmake
/usr/lib64/cmake/libsnoreQt5/LibsnoreQt5ConfigVersion.cmake
/usr/lib64/cmake/libsnoreQt5/LibsnoreQt5Target-none.cmake
/usr/lib64/cmake/libsnoreQt5/LibsnoreQt5Target.cmake
/usr/lib64/cmake/libsnoreQt5/SnoreAddPlugin.cmake
/usr/lib64/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Config.cmake
/usr/lib64/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5ConfigVersion.cmake
/usr/lib64/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Target-none.cmake
/usr/lib64/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Target.cmake
/usr/lib64/qt5/mkspecs/modules/qt_LibsnoreQt5.pri
/usr/lib64/qt5/mkspecs/modules/qt_LibsnoreSettingsQt5.pri
/usr/share/doc/packages/snorenotify-qt5-devel/COPYING.LGPL-3

Changelog

2016-06-19 - hrvoje.senjan@gmail.com
- Stop BuildRequiring deprecated qtquick1 module
2016-02-12 - javier@opensuse.org
- Update to 0.7.0
- Updated spec for 0.7.0
- Added patch fix_desktop_files.patch to fix desktop
categories and remove version (see desktop-entry-spec)
- Removed fix_lib_suffix.patch (no longer needed)
2014-10-19 - tittiatcoke@gmail.com
- Initial package
- Added patch fix_lib_suffix.patch to correct the
installation path for the libraries on x86_64

See Also

Package Description
telepathy-qt5-devel-0.9.7-ku.3.5.i586.rpm Header files, libraries and development documentation for telepathy-qt5
telepathy-qt5-devel-0.9.7-ku.3.5.x86_64.rpm Header files, libraries and development documentation for telepathy-qt5
telepathy-qt5-devel-32bit-0.9.7-ku.3.5.x86_64.rpm Header files, libraries and development documentation for telepathy-qt5
typelib-1_0-AppStream-1.0-0.12.6-ku.4.3.i586.rpm Introspection bindings for AppStream
typelib-1_0-AppStream-1.0-0.12.6-ku.4.3.x86_64.rpm Introspection bindings for AppStream
typelib-1_0-Poppler-0_18-0.72.0-3.8.i586.rpm Introspection bindings for the Poppler PDF rendering library
typelib-1_0-Poppler-0_18-0.72.0-3.8.x86_64.rpm Introspection bindings for the Poppler PDF rendering library
Advertisement
Advertisement