python2-opencv-3.4.3-ku.3.10.i586.rpm


Advertisement

Description

python2-opencv - Python 2 bindings for apps which use OpenCV

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename python2-opencv-3.4.3-ku.3.10.i586.rpm
Package name python2-opencv
Package version 3.4.3
Package release ku.3.10
Package architecture i586
Package type rpm
Category Development/Libraries/Python
Homepage http://opencv.org/
License BSD-3-Clause
Maintainer -
Download size 629.57 KB
Installed size 3.04 MB
This package contains Python 2 bindings for the OpenCV library.

Alternatives

Package Version Architecture Repository
python2-opencv-3.4.3-122.17.x86_64.rpm 3.4.3 x86_64 Education
python2-opencv-3.4.3-122.17.i586.rpm 3.4.3 i586 Education
python2-opencv-3.4.3-119.15.x86_64.rpm 3.4.3 x86_64 KDE Extra
python2-opencv-3.4.3-119.15.i586.rpm 3.4.3 i586 KDE Extra
python2-opencv-3.4.3-3.12.x86_64.rpm 3.4.3 x86_64 KDE 5
python2-opencv-3.4.3-3.12.i586.rpm 3.4.3 i586 KDE 5
python2-opencv-3.4.3-1.5.x86_64.rpm 3.4.3 x86_64 openSUSE Oss
python2-opencv-3.4.3-1.5.i586.rpm 3.4.3 i586 openSUSE Oss
python2-opencv-3.4.3-ku.3.10.x86_64.rpm 3.4.3 x86_64 KDE Unstable
python2-opencv - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libopencv_calib3d.so.3.4 -
libopencv_core.so.3.4 -
libopencv_dnn.so.3.4 -
libopencv_face.so.3.4 -
libopencv_features2d.so.3.4 -
libopencv_flann.so.3.4 -
libopencv_highgui.so.3.4 -
libopencv_imgcodecs.so.3.4 -
libopencv_imgproc.so.3.4 -
libopencv_ml.so.3.4 -
libopencv_objdetect.so.3.4 -
libopencv_photo.so.3.4 -
libopencv_plot.so.3.4 -
libopencv_shape.so.3.4 -
libopencv_stitching.so.3.4 -
libopencv_tracking.so.3.4 -
libopencv_video.so.3.4 -
libopencv_videoio.so.3.4 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
python(abi) = 2.7

Provides

Name Value
python-opencv = 3.4.3-ku.3.10
python-opencv-qt5 -
python2-opencv = 3.4.3-ku.3.10
python2-opencv(x86-32) = 3.4.3-ku.3.10

Obsoletes

Name Value
python-opencv < 3.4.3-ku.3.10
python-opencv-qt5 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-opencv-3.4.3-ku.3.10.i586.rpm
Source Package opencv-3.4.3-ku.3.10.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install python2-opencv rpm package:
    # zypper install python2-opencv

Files

Path
/usr/lib/python2.7/site-packages/cv2.so
/usr/share/licenses/python2-opencv/LICENSE
/usr/share/licenses/python2-opencv/LICENSE.contrib

Changelog

2018-10-29 - Christophe Giboudeaux <christophe@krop.fr>
- Update to 3.4.3
* Compatibility fixes with python 3.7
* Added a new computational target DNN_TARGET_OPENCL_FP16
* Extended support of Intel's Inference Engine backend
* Enabled import of Intel's OpenVINO pre-trained networks from
intermediate representation (IR).
* tutorials improvements
Check https://github.com/opencv/opencv/wiki/ChangeLog#version343
for the complete changelog.
- Drop fix-build-i386-nosse.patch, build-workaround-issues-with-c.patch
(fixed upstream)
- Refresh patches
2018-05-29 - fabian@ritter-vogt.de
- Add patch to fix use of headers from C:
* build-workaround-issues-with-c.patch
2018-05-28 - fvogt@suse.com
- Update to 3.4.1:
* Added support for quantized TensorFlow networks
* OpenCV is now able to use Intel DL inference engine as DNN
acceleration backend
* Added AVX-512 acceleration to the performance-critical kernels
* For more information, read
https://github.com/opencv/opencv/wiki/ChangeLog#version341
- Update contrib modules to 3.4.1:
* No changelog available
- Change mechanism the contrib modules are built
- Include LICENSE of contrib tarball as well
- Build with python3 on >= 15
- Add patch to fix build on i386 without SSE:
* fix-build-i386-nosse.patch
- Refresh patches:
* fix_processor_detection_for_32bit_on_64bit.patch
* opencv-build-compare.patch
- Mention all libs explicitly
- Rebase 3.4.0 update from i@marguerite.su
- update to 3.4.0
* Added faster R-CNN support
* Javascript bindings have been extended to
cover DNN module
* DNN has been further accelerated for iGPU
using OpenCL
* On-disk caching of precompiled OpenCL
kernels has been finally implemented
* possible to load and run pre-compiled
OpenCL kernels via T-API
* Bit-exact 8-bit and 16-bit resize has been
implemented (currently supported only
bilinear interpolation)
- update face module to 3.4.0
- add opencv-lib_suffix.patch, remove LIB_SUFFIX
from OPENCV_LIB_INSTALL_PATH, as CMAKE_INSTALL
_LIBDIR is arch dependent.
2018-03-12 - schwab@suse.de
- Add option to build without openblas
2018-01-08 - tchvatal@suse.com
- Add conditionals for python2 and python3 to allow us enabling
only desired python variants when needed
- Do not depend on sphinx as py2 and py3 seem to collide there
2017-11-25 - stefan.bruens@rwth-aachen.de
- Readd opencv-gles.patch, it is *not* included upstream; otherwise
build breaks on all GLES Qt5 platforms (armv6l, armv7l, aarch64)
- add fix_processor_detection_for_32bit_on_64bit.patch
- Correctly set optimizations and dynamic dispatch on ARM, use
OpenCV 3.3 syntax on x86.
2017-11-13 - mpluskal@suse.com
- Update licensing information
2017-11-08 - ecsos@opensuse.org
- change requires of python-numpy-devel to build in Leap and
to not break factory in future
2017-11-04 - ecsos@opensuse.org
- fix build error/unresolvable for Leap 42.2 and 42.3
2017-11-03 - mpluskal@suse.com
- Update to version 3.3.1:
* Lots of various bugfixes
- Update source url

See Also

Package Description
python2-qt5-5.12.1-ku.134.2.i586.rpm Python bindings for Qt 5
python2-qt5-5.12.1-ku.134.2.x86_64.rpm Python bindings for Qt 5
python2-qt5-devel-5.12.1-ku.134.2.i586.rpm PyQt - devel part of python bindings for Qt 5
python2-qt5-devel-5.12.1-ku.134.2.x86_64.rpm PyQt - devel part of python bindings for Qt 5
python2-sip-4.19.16-196.1.i586.rpm SIP tool to use python sip bindings
python2-sip-4.19.16-196.1.x86_64.rpm SIP tool to use python sip bindings
python2-sip-devel-4.19.16-196.1.i586.rpm SIP tool to create python bindings
python2-sip-devel-4.19.16-196.1.x86_64.rpm SIP tool to create python bindings
python3-gpg-1.13.0-ku.3.1.i586.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-gpg-1.13.0-ku.3.1.x86_64.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-opencv-3.4.3-ku.3.10.i586.rpm Python 3 bindings for apps which use OpenCV
python3-opencv-3.4.3-ku.3.10.x86_64.rpm Python 3 bindings for apps which use OpenCV
python3-pyside2-5.12.2-ku.24.2.i586.rpm Python bindings for Qt
python3-pyside2-5.12.2-ku.24.2.x86_64.rpm Python bindings for Qt
python3-pyside2-devel-5.12.2-ku.24.2.i586.rpm Header Files for PySide2
Advertisement
Advertisement