libqt5-qtwebengine-devel-5.12.3-ku.2.1.x86_64.rpm


Advertisement

Description

libqt5-qtwebengine-devel - Development files for the Qt5 WebEngine library

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename libqt5-qtwebengine-devel-5.12.3-ku.2.1.x86_64.rpm
Package name libqt5-qtwebengine-devel
Package version 5.12.3
Package release ku.2.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/X11
Homepage https://www.qt.io
License LGPL-3.0-only OR GPL-2.0-only OR GPL-3.0-only
Maintainer -
Download size 72.02 KB
Installed size 283.96 KB
You need this package if you want to compile programs with Qt WebEngine.

Alternatives

Package Version Architecture Repository
libqt5-qtwebengine-devel-5.12.3-2.1.i586.rpm 5.12.3 i586 KDE 5
libqt5-qtwebengine-devel-5.12.3-2.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libqt5-qtwebengine-devel-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 openSUSE Oss
libqt5-qtwebengine-devel-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libqt5-qtwebengine-devel-5.12.3-ku.2.1.i586.rpm 5.12.3 i586 KDE Unstable
libqt5-qtwebengine-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libqt5-qtwebengine = 5.12.3
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(Qt5Network) -
pkgconfig(Qt5Positioning) -
pkgconfig(Qt5PrintSupport) -
pkgconfig(Qt5Qml) -
pkgconfig(Qt5Quick) -
pkgconfig(Qt5WebChannel) -
pkgconfig(Qt5WebEngineCore) -
pkgconfig(Qt5Widgets) -

Provides

Name Value
cmake(Qt5WebEngine) = 5.12.3
cmake(Qt5WebEngineCore) = 5.12.3
cmake(Qt5WebEngineWidgets) = 5.12.3
libqt5-qtwebengine-devel = 5.12.3-ku.2.1
libqt5-qtwebengine-devel(x86-64) = 5.12.3-ku.2.1
pkgconfig(Qt5WebEngine) = 5.12.3
pkgconfig(Qt5WebEngineCore) = 5.12.3
pkgconfig(Qt5WebEngineWidgets) = 5.12.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libqt5-qtwebengine-devel-5.12.3-ku.2.1.x86_64.rpm
Source Package libqt5-qtwebengine-5.12.3-ku.2.1.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install libqt5-qtwebengine-devel rpm package:
    # zypper install libqt5-qtwebengine-devel

Files

Path
/usr/include/qt5/QtWebEngine/QQuickWebEngineProfile
/usr/include/qt5/QtWebEngine/QQuickWebEngineScript
/usr/include/qt5/QtWebEngine/QtWebEngine
/usr/include/qt5/QtWebEngine/QtWebEngineDepends
/usr/include/qt5/QtWebEngine/QtWebEngineVersion
/usr/include/qt5/QtWebEngine/qquickwebengineprofile.h
/usr/include/qt5/QtWebEngine/qquickwebenginescript.h
/usr/include/qt5/QtWebEngine/qtwebengineglobal.h
/usr/include/qt5/QtWebEngine/qtwebengineversion.h
/usr/include/qt5/QtWebEngineCore/QWebEngineCallback
/usr/include/qt5/QtWebEngineCore/QWebEngineCookieStore
/usr/include/qt5/QtWebEngineCore/QWebEngineHttpRequest
/usr/include/qt5/QtWebEngineCore/QWebEngineQuotaRequest
/usr/include/qt5/QtWebEngineCore/QWebEngineRegisterProtocolHandlerRequest
/usr/include/qt5/QtWebEngineCore/QWebEngineUrlRequestInfo
/usr/include/qt5/QtWebEngineCore/QWebEngineUrlRequestInterceptor
/usr/include/qt5/QtWebEngineCore/QWebEngineUrlRequestJob
/usr/include/qt5/QtWebEngineCore/QWebEngineUrlScheme
/usr/include/qt5/QtWebEngineCore/QWebEngineUrlSchemeHandler
/usr/include/qt5/QtWebEngineCore/QtWebEngineCore
/usr/include/qt5/QtWebEngineCore/QtWebEngineCoreDepends
/usr/include/qt5/QtWebEngineCore/QtWebEngineCoreVersion
/usr/include/qt5/QtWebEngineCore/qtwebenginecore-config.h
/usr/include/qt5/QtWebEngineCore/qtwebenginecoreglobal.h
/usr/include/qt5/QtWebEngineCore/qtwebenginecoreversion.h
/usr/include/qt5/QtWebEngineCore/qwebenginecallback.h
/usr/include/qt5/QtWebEngineCore/qwebenginecookiestore.h
/usr/include/qt5/QtWebEngineCore/qwebenginehttprequest.h
/usr/include/qt5/QtWebEngineCore/qwebenginequotarequest.h
/usr/include/qt5/QtWebEngineCore/qwebengineregisterprotocolhandlerrequest.h
/usr/include/qt5/QtWebEngineCore/qwebengineurlrequestinfo.h
/usr/include/qt5/QtWebEngineCore/qwebengineurlrequestinterceptor.h
/usr/include/qt5/QtWebEngineCore/qwebengineurlrequestjob.h
/usr/include/qt5/QtWebEngineCore/qwebengineurlscheme.h
/usr/include/qt5/QtWebEngineCore/qwebengineurlschemehandler.h
/usr/include/qt5/QtWebEngineWidgets/QWebEngineCertificateError
/usr/include/qt5/QtWebEngineWidgets/QWebEngineClientCertificateSelection
/usr/include/qt5/QtWebEngineWidgets/QWebEngineContextMenuData
/usr/include/qt5/QtWebEngineWidgets/QWebEngineDownloadItem
/usr/include/qt5/QtWebEngineWidgets/QWebEngineFullScreenRequest
/usr/include/qt5/QtWebEngineWidgets/QWebEngineHistory
/usr/include/qt5/QtWebEngineWidgets/QWebEngineHistoryItem
/usr/include/qt5/QtWebEngineWidgets/QWebEnginePage
/usr/include/qt5/QtWebEngineWidgets/QWebEngineProfile
/usr/include/qt5/QtWebEngineWidgets/QWebEngineScript
/usr/include/qt5/QtWebEngineWidgets/QWebEngineScriptCollection
/usr/include/qt5/QtWebEngineWidgets/QWebEngineSettings
/usr/include/qt5/QtWebEngineWidgets/QWebEngineView
/usr/include/qt5/QtWebEngineWidgets/QtWebEngineWidgets
/usr/include/qt5/QtWebEngineWidgets/QtWebEngineWidgetsDepends
/usr/include/qt5/QtWebEngineWidgets/QtWebEngineWidgetsVersion
/usr/include/qt5/QtWebEngineWidgets/qtwebenginewidgetsglobal.h
/usr/include/qt5/QtWebEngineWidgets/qtwebenginewidgetsversion.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginecertificateerror.h
/usr/include/qt5/QtWebEngineWidgets/qwebengineclientcertificateselection.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginecontextmenudata.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginedownloaditem.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginefullscreenrequest.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginehistory.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginepage.h
/usr/include/qt5/QtWebEngineWidgets/qwebengineprofile.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginescript.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginescriptcollection.h
/usr/include/qt5/QtWebEngineWidgets/qwebenginesettings.h
/usr/include/qt5/QtWebEngineWidgets/qwebengineview.h
/usr/lib64/libQt5WebEngine.prl
/usr/lib64/libQt5WebEngine.so
/usr/lib64/libQt5WebEngineCore.prl
/usr/lib64/libQt5WebEngineCore.so
/usr/lib64/libQt5WebEngineWidgets.prl
/usr/lib64/libQt5WebEngineWidgets.so
/usr/lib64/cmake/Qt5Designer/Qt5Designer_QWebEngineViewPlugin.cmake
/usr/lib64/cmake/Qt5WebEngine/Qt5WebEngineConfig.cmake
/usr/lib64/cmake/Qt5WebEngine/Qt5WebEngineConfigVersion.cmake
/usr/lib64/cmake/Qt5WebEngineCore/Qt5WebEngineCoreConfig.cmake
/usr/lib64/cmake/Qt5WebEngineCore/Qt5WebEngineCoreConfigVersion.cmake
/usr/lib64/cmake/Qt5WebEngineWidgets/Qt5WebEngineWidgetsConfig.cmake
/usr/lib64/cmake/Qt5WebEngineWidgets/Qt5WebEngineWidgetsConfigVersion.cmake
/usr/lib64/pkgconfig/Qt5WebEngine.pc
/usr/lib64/pkgconfig/Qt5WebEngineCore.pc
/usr/lib64/pkgconfig/Qt5WebEngineWidgets.pc
/usr/lib64/qt5/mkspecs/modules/qt_lib_webengine.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webengine_private.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webenginecore.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webenginecore_private.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webenginecoreheaders_private.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webenginewidgets.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_webenginewidgets_private.pri
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.Chromium
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.GPL2
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.GPL3
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.GPL3-EXCEPT
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.GPLv3
/usr/share/licenses/libqt5-qtwebengine-devel/LICENSE.LGPL3

Changelog

2019-04-30 - Fabian Vogt <fabian@ritter-vogt.de>
- Fix system_vpx bcond
2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.3/?h=v5.12.3
- Refresh chromium-non-void-return.patch
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.2/?h=5.12.2
- Remove patches, now upstream:
* cve-2019-5786.patch
2019-03-11 - Martin Herkt <9+suse@cirno.systems>
- Add cve-2019-5786.patch
Backport fix for CVE-2019-5786
https://bugreports.qt.io/browse/QTBUG-74254
2019-02-04 - wbauer@tmo.at
- Fix build on Leap 42.3 by adding c++14 to QT_CONFIG
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.1/?h=v5.12.1
- Refresh disable-gpu-when-using-nouveau-boo-1005323.diff
- Remove patches, now upstream:
* gn-fix_arm.patch
* chromium-66.0.3359.170-gcc8-alignof.patch
2019-01-21 - Bernhard Wiedemann <bwiedemann@suse.com>
- Add reproducible.patch to override chromium build date
to make package build reproducible (boo#1047218)
- Use openSUSE's ninja for the build so that we can apply fixes there
that are used by everyone (boo#1118619)
2018-12-21 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Backport patch to fix %arm builds:
* gn-fix_arm.patch
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.0/?h=5.12.0

See Also

Package Description
libqt5-qtwebengine-examples-5.12.3-ku.2.1.i586.rpm Qt5 location examples
libqt5-qtwebengine-examples-5.12.3-ku.2.1.x86_64.rpm Qt5 location examples
libqt5-qtwebengine-private-headers-devel-5.12.3-ku.2.1.noarch.rpm Non-ABI stable experimental API for the Qt5 WebEngine library
libqt5-qtwebsockets-devel-32bit-5.12.3-ku.1.1.x86_64.rpm Development files for the Qt5 WebSockets library
libqt5-qtwebsockets-devel-5.12.3-ku.1.1.i586.rpm Development files for the Qt5 WebSockets library
libqt5-qtwebsockets-devel-5.12.3-ku.1.1.x86_64.rpm Development files for the Qt5 WebSockets library
libqt5-qtwebsockets-examples-5.12.3-ku.1.1.i586.rpm Qt5 websockets examples
libqt5-qtwebsockets-examples-5.12.3-ku.1.1.x86_64.rpm Qt5 websockets examples
libqt5-qtwebsockets-private-headers-devel-5.12.3-ku.1.1.noarch.rpm Non-ABI stable experimental API for the Qt5 WebSocket library
libqt5-qtwebview-devel-5.12.3-ku.1.1.i586.rpm Development files for the Qt5's Webview library
libqt5-qtwebview-devel-5.12.3-ku.1.1.x86_64.rpm Development files for the Qt5's Webview library
libqt5-qtwebview-examples-5.12.3-ku.1.1.i586.rpm Qt5 webview examples
libqt5-qtwebview-examples-5.12.3-ku.1.1.x86_64.rpm Qt5 webview examples
libqt5-qtwebview-private-headers-devel-5.12.3-ku.1.1.noarch.rpm Non-ABI stable experimental API for Qt5's Webview library
libqt5-qtx11extras-devel-32bit-5.12.3-ku.1.1.x86_64.rpm Development files for the Qt5 X11 Extras library
Advertisement
Advertisement