libqoauth2-2.0.0-ku.5.5.x86_64.rpm


Advertisement

Description

libqoauth2 - Library for interaction with OAuth-powered network services

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename libqoauth2-2.0.0-ku.5.5.x86_64.rpm
Package name libqoauth2
Package version 2.0.0
Package release ku.5.5
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://github.com/ayoy/qoauth
License LGPL-2.1-or-later
Maintainer -
Download size 41.51 KB
Installed size 117.35 KB
QOAuth supports interaction with OAuth-powered network services,
in the style of Qt libraries.

Alternatives

Package Version Architecture Repository
libqoauth2-2.0.0-13.10.x86_64.rpm 2.0.0 x86_64 KDE 5
libqoauth2-2.0.0-13.10.i586.rpm 2.0.0 i586 KDE 5
libqoauth2-2.0.0-3.2.x86_64.rpm 2.0.0 x86_64 openSUSE Oss
libqoauth2-2.0.0-3.2.i586.rpm 2.0.0 i586 openSUSE Oss
libqoauth2-2.0.0-ku.5.5.i586.rpm 2.0.0 i586 KDE Unstable
libqoauth2 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libqca-qt5.so.2()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libqoauth.so.2()(64bit) -
libqoauth2 = 2.0.0-ku.5.5
libqoauth2(x86-64) = 2.0.0-ku.5.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libqoauth2-2.0.0-ku.5.5.x86_64.rpm
Source Package qoauth-qt5-2.0.0-ku.5.5.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install libqoauth2 rpm package:
    # zypper install libqoauth2

Files

Path
/usr/lib64/libqoauth.so.2
/usr/lib64/libqoauth.so.2.0
/usr/lib64/libqoauth.so.2.0.0
/usr/share/licenses/libqoauth2/LICENSE

Changelog

2018-08-15 - schwab@suse.de
- qoauth-ppc64-libdir.patch: Also add riscv64 as lib64 platform
- Use %licence for LICENSE
2017-03-14 - sor.alexei@meowr.ru
- Add qoauth-qt5-fix-includedir.patch: fix the include directory.
- A minor spec cleanup.
2017-01-30 - jengelh@inai.de
- Trim filler words from descriptions
2017-01-19 - wbauer@tmo.at
- Change license to LGPL-2.1+
- Install LICENSE file
2016-12-28 - jengelh@inai.de
- Ensure all directories are owned. Re-set RPM groups,
drop extra author mentions.
2016-12-27 - wbauer@tmo.at
- Update to version 2.0.0:
* Qt5 support
- Rename qoauth-rpmoptflags.patch to qoauth-qt5-rpmoptflags.patch
- Rename qoauth-ppc64-libdir.patch to qoauth-qt5-ppc64-libdir.patch
- Add pcfile.patch to adjust the pkgconfig file to Qt5
2015-05-28 - ro@suse.de
- expand qoauth-ppc64-libdir.patch for s390x
2013-12-15 - uweigand@de.ibm.com
- qoauth-ppc64-libdir.patch: Add ppc64le as lib64 platform
2013-03-18 - schwab@suse.de
- Add aarch64 to the list of lib64 platforms
2012-07-06 - dvaleev@suse.com
- fix ppc64 libdir

See Also

Package Description
libqscintilla2_qt5-15-2.11.1-ku.3.1.i586.rpm C++ Editor Class Library
libqscintilla2_qt5-15-2.11.1-ku.3.1.x86_64.rpm C++ Editor Class Library
libqscintilla_qt5-devel-2.11.1-ku.3.1.i586.rpm C++ Editor Class Library Development Files
libqscintilla_qt5-devel-2.11.1-ku.3.1.x86_64.rpm C++ Editor Class Library Development Files
libqt5-creator-4.9.0-ku.15.1.x86_64.rpm Integrated Development Environment targeting Qt apps
libqt5-creator-plugin-devel-4.9.0-ku.15.1.x86_64.rpm Qt Creator Plugin Development Files
libqt5-linguist-5.12.3-ku.1.2.i586.rpm Qt 5 Linguist Tools
libqt5-linguist-5.12.3-ku.1.2.x86_64.rpm Qt 5 Linguist Tools
libqt5-linguist-devel-5.12.3-ku.1.2.i586.rpm Development files for the Qt 5 Linguist tools
libqt5-linguist-devel-5.12.3-ku.1.2.x86_64.rpm Development files for the Qt 5 Linguist tools
libqt5-qdbus-5.12.3-ku.1.2.i586.rpm Interface to Qt applications communicating over D-Bus
libqt5-qdbus-5.12.3-ku.1.2.x86_64.rpm Interface to Qt applications communicating over D-Bus
libqt5-qt3d-devel-5.12.3-ku.1.1.i586.rpm Development files for the Qt5 3D library
libqt5-qt3d-devel-5.12.3-ku.1.1.x86_64.rpm Development files for the Qt5 3D library
libqt5-qt3d-examples-5.12.3-ku.1.1.i586.rpm Qt5 3D examples
Advertisement
Advertisement