libmygpo-qt5-devel-1.1.0-ku.4.4.i586.rpm


Advertisement

Description

libmygpo-qt5-devel - Qt Library that wraps the gpodder.net Web API

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename libmygpo-qt5-devel-1.1.0-ku.4.4.i586.rpm
Package name libmygpo-qt5-devel
Package version 1.1.0
Package release ku.4.4
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://wiki.gpodder.org/wiki/Libmygpo-qt
License LGPL-2.1-or-later
Maintainer -
Download size 28.82 KB
Installed size 91.98 KB
libmygpo-qt5 is a Qt Library that wraps the gpodder.net Web API (http://wiki.gpodder.org/wiki/Web_Services/API_2)
v1.0 wraps nearly every Request from the gpodder.net API except:
- Simple API Calls Downloading subscription Lists & Uploading subscription Lists
- Retrieving Subscription Changes (you should use "Retrieving Updates for a given Device" instead)

Alternatives

Package Version Architecture Repository
libmygpo-qt5-devel-1.1.0-14.14.x86_64.rpm 1.1.0 x86_64 KDE 5
libmygpo-qt5-devel-1.1.0-14.14.i586.rpm 1.1.0 i586 KDE 5
libmygpo-qt5-devel-1.1.0-2.3.x86_64.rpm 1.1.0 x86_64 openSUSE Oss
libmygpo-qt5-devel-1.1.0-2.3.i586.rpm 1.1.0 i586 openSUSE Oss
libmygpo-qt5-devel-1.1.0-ku.4.4.x86_64.rpm 1.1.0 x86_64 KDE Unstable
libmygpo-qt5-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libmygpo-qt5-1 = 1.1.0
pkgconfig(Qt5Core) -
pkgconfig(Qt5Network) -

Provides

Name Value
cmake(Mygpo-qt5) = 1.1.0
libmygpo-qt5-devel = 1.1.0-ku.4.4
libmygpo-qt5-devel(x86-32) = 1.1.0-ku.4.4
pkgconfig(libmygpo-qt5) = 1.1.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libmygpo-qt5-devel-1.1.0-ku.4.4.i586.rpm
Source Package libmygpo-qt5-1.1.0-ku.4.4.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install libmygpo-qt5-devel rpm package:
    # zypper install libmygpo-qt5-devel

Files

Path
/usr/include/mygpo-qt5/AddRemoveResult.h
/usr/include/mygpo-qt5/ApiRequest.h
/usr/include/mygpo-qt5/Config.h
/usr/include/mygpo-qt5/Device.h
/usr/include/mygpo-qt5/DeviceList.h
/usr/include/mygpo-qt5/DeviceSyncResult.h
/usr/include/mygpo-qt5/DeviceUpdates.h
/usr/include/mygpo-qt5/Episode.h
/usr/include/mygpo-qt5/EpisodeAction.h
/usr/include/mygpo-qt5/EpisodeActionList.h
/usr/include/mygpo-qt5/EpisodeList.h
/usr/include/mygpo-qt5/Podcast.h
/usr/include/mygpo-qt5/PodcastList.h
/usr/include/mygpo-qt5/Settings.h
/usr/include/mygpo-qt5/Tag.h
/usr/include/mygpo-qt5/TagList.h
/usr/include/mygpo-qt5/mygpo_export.h
/usr/lib/libmygpo-qt5.so
/usr/lib/cmake/mygpo-qt5/Mygpo-qt5Config.cmake
/usr/lib/cmake/mygpo-qt5/Mygpo-qt5ConfigVersion.cmake
/usr/lib/cmake/mygpo-qt5/Mygpo-qt5Targets-relwithdebinfo.cmake
/usr/lib/cmake/mygpo-qt5/Mygpo-qt5Targets.cmake
/usr/lib/pkgconfig/libmygpo-qt5.pc
/usr/share/licenses/libmygpo-qt5-devel/LICENSE

Changelog

2018-05-24 - christophe@krop.fr
- Add fix-build-with-qt-5_11.patch to fix build with Qt >= 5.11
2018-04-03 - wbauer@tmo.at
- Update to 1.1.0:
* Deprecated Qt4 support
* Improvements in Qt5 support
* Fix in URL parsing, preventing Double Encoding of URLs
2018-02-26 - wbauer@tmo.at
- Update to 1.0.9:
* Different header installation directories for the qt4 & qt5
version
* Bugfix: Top level include_install_dir is now respected
* Support for QJson 0.7
* Default to https instead of http
* Bugfix: Allow setting the server URL
- Tell cmake to install the include files to
%{_includedir}/mygpo-qt5/ (which actually is the default but gets
overridden by the %cmake macro)
- Drop conflict with libmygqo-qt-devel, there is no overlap anymore
2014-11-13 - hrvoje.senjan@gmail.com
- Install license
2014-08-24 - hrvoje.senjan@gmail.com
- Activate Qt5 version of libmygpo library: libmygpo-qt5
- Update to 1.0.8:
* Qt5 support
* Support for the "Get All Subscriptions" API endpoint
2013-04-13 - hrvoje.senjan@gmail.com
- Update to 1.0.7
* New Config Class. This class allows to programmatically to
retrieve the libmygpo-qt version and retrieve and set the
gpodder.net API endpoint
* Config Class also allows to set a prefix to the user-agent.
* fixed a bug that created incomplete Episode Actions if an
Episode Action couldn?t be parsed completely by libmygpo-qt
* fixed a small bug with the pkgconfig file
* added support for uploading & retrieving flattr Episode Actions
to gpodder.net
2012-11-25 - nico.kruber@gmail.com
- Fix the SLES build (%make_install is not expanded on SLES)
2012-10-23 - cgiboudeaux@gmx.com
- Update to 1.0.6
* Added support for DeviceSync API. This API makes it possible to
set up synchronization with existing gpodder.net devices from inside
your application
* Set Contenttype Header to avoid warnings with Qt 4.8
* Some fixes & enhancements to CMake build system
2011-11-13 - cgiboudeaux@gmx.com
- Update to 1.0.5
* fixed a bug in downloadSubscriptionsJson()
* changed the way http basic auth information is transmitted to
gpodder.net to no longer getting annoying popups when using
libmygpo-qt with KIO from KDE 4.7.X
* implemented functions to access the new API for retrieving
synchronization information of devices
* implemented functions to retrieve toplist and search results in
gpodders custom XML format
* added ?ConfigStyle? package finding to CMake Buildsystem
2011-09-19 - cgiboudeaux@gmx.com
- Update to 1.0.4
* fixed a bug with an invalid timestamp when uploading EpisodeActions
* fixed a bug with a wrong url when retrieving EpisodeActions by Podcast
* fixed a crash happening on MeeGo because of the deletion of QNetworkReply Pointers

See Also

Package Description
libopencv3_4-3.4.3-ku.3.10.i586.rpm Libraries to use OpenCV computer vision
libopencv3_4-3.4.3-ku.3.10.x86_64.rpm Libraries to use OpenCV computer vision
libpoppler-cpp0-0.72.0-3.8.i586.rpm C++ API of the Poppler PDF rendering library
libpoppler-cpp0-0.72.0-3.8.x86_64.rpm C++ API of the Poppler PDF rendering library
libpoppler-cpp0-32bit-0.72.0-3.8.x86_64.rpm C++ API of the Poppler PDF rendering library
libpoppler-devel-0.72.0-3.8.i586.rpm Development files for the Poppler PDF rendering library
libpoppler-devel-0.72.0-3.8.x86_64.rpm Development files for the Poppler PDF rendering library
libpoppler-glib-devel-0.72.0-3.8.i586.rpm Development files for the Poppler Glib wrapper library
libpoppler-glib-devel-0.72.0-3.8.x86_64.rpm Development files for the Poppler Glib wrapper library
libpoppler-glib8-0.72.0-3.8.i586.rpm Glib wrapper for the poppler PDF rendering library
libpoppler-glib8-0.72.0-3.8.x86_64.rpm Glib wrapper for the poppler PDF rendering library
libpoppler-glib8-32bit-0.72.0-3.8.x86_64.rpm Glib wrapper for the poppler PDF rendering library
libpoppler-qt5-1-0.72.0-ku.3.8.i586.rpm Qt5 wrapper for the Poppler PDF rendering library
libpoppler-qt5-1-0.72.0-ku.3.8.x86_64.rpm Qt5 wrapper for the Poppler PDF rendering library
libpoppler-qt5-1-32bit-0.72.0-ku.3.8.x86_64.rpm Qt5 wrapper for the Poppler PDF rendering library
Advertisement
Advertisement