libjreen-qt5-devel-1.3.0-ku.3.5.x86_64.rpm


Advertisement

Description

libjreen-qt5-devel - Qt Jabber/XMPP library

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename libjreen-qt5-devel-1.3.0-ku.3.5.x86_64.rpm
Package name libjreen-qt5-devel
Package version 1.3.0
Package release ku.3.5
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://github.com/euroelessar/jreen
License LGPL-3.0-or-later
Maintainer -
Download size 56.12 KB
Installed size 222.58 KB
Qt Jabber/XMPP extensible library.

Alternatives

Package Version Architecture Repository
libjreen-qt5-devel-1.3.0-16.18.x86_64.rpm 1.3.0 x86_64 KDE 5
libjreen-qt5-devel-1.3.0-16.18.i586.rpm 1.3.0 i586 KDE 5
libjreen-qt5-devel-1.3.0-1.3.x86_64.rpm 1.3.0 x86_64 openSUSE Oss
libjreen-qt5-devel-1.3.0-1.3.i586.rpm 1.3.0 i586 openSUSE Oss
libjreen-qt5-devel-1.3.0-ku.3.5.i586.rpm 1.3.0 i586 KDE Unstable
libjreen-qt5-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libjreen-qt5-1 = 1.3.0
pkgconfig(Qt5Core) -
pkgconfig(Qt5Network) -

Provides

Name Value
libjreen-qt5-devel = 1.3.0-ku.3.5
libjreen-qt5-devel(x86-64) = 1.3.0-ku.3.5
pkgconfig(libjreen-qt5) = 1.3.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libjreen-qt5-devel-1.3.0-ku.3.5.x86_64.rpm
Source Package libjreen-qt5-1.3.0-ku.3.5.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install libjreen-qt5-devel rpm package:
    # zypper install libjreen-qt5-devel

Files

Path
/usr/include/jreen-qt5/
/usr/include/jreen-qt5/jreen/abstractroster.h
/usr/include/jreen-qt5/jreen/activity.h
/usr/include/jreen-qt5/jreen/attention.h
/usr/include/jreen-qt5/jreen/bitsofbinary.h
/usr/include/jreen-qt5/jreen/bookmark.h
/usr/include/jreen-qt5/jreen/bookmarkstorage.h
/usr/include/jreen-qt5/jreen/buffereddatastream.h
/usr/include/jreen-qt5/jreen/capabilities.h
/usr/include/jreen-qt5/jreen/captcha.h
/usr/include/jreen-qt5/jreen/chatstate.h
/usr/include/jreen-qt5/jreen/client.h
/usr/include/jreen-qt5/jreen/connection.h
/usr/include/jreen-qt5/jreen/connectionbosh.h
/usr/include/jreen-qt5/jreen/dataform.h
/usr/include/jreen-qt5/jreen/datastream.h
/usr/include/jreen-qt5/jreen/delayeddelivery.h
/usr/include/jreen-qt5/jreen/directconnection.h
/usr/include/jreen-qt5/jreen/disco.h
/usr/include/jreen-qt5/jreen/entitytime.h
/usr/include/jreen-qt5/jreen/error.h
/usr/include/jreen-qt5/jreen/forwarded.h
/usr/include/jreen-qt5/jreen/iq.h
/usr/include/jreen-qt5/jreen/iqreply.h
/usr/include/jreen-qt5/jreen/jid.h
/usr/include/jreen-qt5/jreen/jreen.h
/usr/include/jreen-qt5/jreen/jstrings.h
/usr/include/jreen-qt5/jreen/langmap.h
/usr/include/jreen-qt5/jreen/logger.h
/usr/include/jreen-qt5/jreen/message.h
/usr/include/jreen-qt5/jreen/messagesession.h
/usr/include/jreen-qt5/jreen/metacontactstorage.h
/usr/include/jreen-qt5/jreen/mood.h
/usr/include/jreen-qt5/jreen/mucroom.h
/usr/include/jreen-qt5/jreen/nickname.h
/usr/include/jreen-qt5/jreen/parser.h
/usr/include/jreen-qt5/jreen/pgpencrypted.h
/usr/include/jreen-qt5/jreen/pgpsigned.h
/usr/include/jreen-qt5/jreen/ping.h
/usr/include/jreen-qt5/jreen/presence.h
/usr/include/jreen-qt5/jreen/privacymanager.h
/usr/include/jreen-qt5/jreen/privatexml.h
/usr/include/jreen-qt5/jreen/pubsubevent.h
/usr/include/jreen-qt5/jreen/pubsubmanager.h
/usr/include/jreen-qt5/jreen/receipt.h
/usr/include/jreen-qt5/jreen/registrationmanager.h
/usr/include/jreen-qt5/jreen/softwareversion.h
/usr/include/jreen-qt5/jreen/stanza.h
/usr/include/jreen-qt5/jreen/stanzaextension.h
/usr/include/jreen-qt5/jreen/streamprocessor.h
/usr/include/jreen-qt5/jreen/subscription.h
/usr/include/jreen-qt5/jreen/tcpconnection.h
/usr/include/jreen-qt5/jreen/tune.h
/usr/include/jreen-qt5/jreen/udpconnection.h
/usr/include/jreen-qt5/jreen/util.h
/usr/include/jreen-qt5/jreen/vcard.h
/usr/include/jreen-qt5/jreen/vcardmanager.h
/usr/include/jreen-qt5/jreen/vcardupdate.h
/usr/include/jreen-qt5/jreen/experimental/iristransport.h
/usr/include/jreen-qt5/jreen/experimental/jingleaudiocontent.h
/usr/include/jreen-qt5/jreen/experimental/jingleaudiopayload.h
/usr/include/jreen-qt5/jreen/experimental/jinglecontent.h
/usr/include/jreen-qt5/jreen/experimental/jinglemanager.h
/usr/include/jreen-qt5/jreen/experimental/jinglesession.h
/usr/include/jreen-qt5/jreen/experimental/jingletransport.h
/usr/lib64/libjreen-qt5.so
/usr/lib64/pkgconfig/libjreen-qt5.pc
/usr/share/licenses/libjreen-qt5-devel/COPYING
/usr/share/licenses/libjreen-qt5-devel/COPYING.LESSER

Changelog

2018-05-24 - christophe@krop.fr
- Update to 1.3.0. Changes since 1.2.0:
* Change license to LGPL-3.0-or-later
* Use QSsl::SecureProtocols instead of QSsl::TlsV1
* Fix build with recent qbs (up to version 1.7)
- Drop 0001-Use-GNUInstallDirs-to-determine-install-dirs.patch and
0002-Clean_includes.patch (fixed upstream)
- Add Patch fix-build-with-Qt-5_11.patch
2016-01-27 - cgiboudeaux@gmx.com
- Add 0002-Clean_includes.patch. The code using the qMetaTypeId
class is commented out and this camelcase header will be removed
in Qt 5.6.
2015-02-06 - dev@dominik-schmidt.de
- New package providing Qt5 version: libjreen-qt5(-devel)
* coinstallable with Qt4 version: libjreen(-devel)
* removed kde4 macros
* upstreamed patch to use GNUInstallDirs and get rid
of LIB_SUFFIX specified by kde4 cmake macro
2014-10-22 - hrvoje.senjan@gmail.com
- Update to 1.2.0
* No upstream changelog
- Drop update-to-latest-git-fixes.patch, merged upstream
2014-07-27 - hrvoje.senjan@gmail.com
- Move back to standard macros for filelists: libjreen doesn't use
kde4 buildsystem
2013-12-12 - hrvoje.senjan@gmail.com
- Added update-to-latest-git-fixes.patch: fixes build failure with
cmake 2.8.12 and adds Qt5 support
- Added speex-devel, libidn-devel and libgsasl-devel BuildRequires
- Droped libqca2-devel (Build)Requires
- Pass DJREEN_FORCE_QT4=ON to CMake, as the buildsystem now defaults
to Qt 5
- Use kde macros
2013-01-07 - dev@dominik-schmidt.de
- Update to version 1.1.1
* Added support for XEP-224: Attentions
* Fixed roster update receiving on some servers
2012-04-18 - magist3r@gmail.com
- Update to version 1.1.0
* Added PGP payloads
* Added support for Message Forwarding
* Added MetaContacts support
* Added experimental Jingle support
* Fixed authorization with SCRAM-SHA1
* Fixed sending of IQ's on connect
- Changes in version 1.0.6
* Fixed parsing of PubSub payload
* Fixed serializing of PubSub payload
2012-04-01 - dev@dominik-schmidt.de
- Update to version 1.0.5
* Fixed parsing of message's thread attribute
- Changes in 1.0.4
* Added support for in-band registration
* Added ability to force/deny compression/encryption
* Added CAPTCHA support
* Fixed IQ requests to yourself
* Fixed handling of messages' types in MessageSession
2012-03-14 - dev@dominik-schmidt.de
- Update to version 1.0.3
* Added Logger implementation
* Fixed QJDns initialization issue
- Changes in 1.0.2
* Added support for ProxyFactory
* Added immunity to invalid stanzas
* Added localization support for incoming stanzas
* Fixed QJDns initialization behaviour

See Also

Package Description
libkdstatemachineeditor_core1_2_5-1.2.5-ku.27.3.i586.rpm KDAB State Machine Editor core library
libkdstatemachineeditor_core1_2_5-1.2.5-ku.27.3.x86_64.rpm KDAB State Machine Editor core library
libkdstatemachineeditor_view1_2_5-1.2.5-ku.27.3.i586.rpm KDAB State Machine Editor view library
libkdstatemachineeditor_view1_2_5-1.2.5-ku.27.3.x86_64.rpm KDAB State Machine Editor view library
liblastfm-qt5-devel-1.0.9+20150206-ku.5.5.i586.rpm Development Files for the Last.fm Webservices
liblastfm-qt5-devel-1.0.9+20150206-ku.5.5.x86_64.rpm Development Files for the Last.fm Webservices
liblastfm5-1-1.0.9+20150206-ku.5.5.i586.rpm A Qt C++ Library for the Last.fm Webservices
liblastfm5-1-1.0.9+20150206-ku.5.5.x86_64.rpm A Qt C++ Library for the Last.fm Webservices
liblastfm5-1-32bit-1.0.9+20150206-ku.5.5.x86_64.rpm A Qt C++ Library for the Last.fm Webservices
liblastfm_fingerprint5-1-1.0.9+20150206-ku.5.5.i586.rpm A Qt C++ Library for the Last.fm Webservices
liblastfm_fingerprint5-1-1.0.9+20150206-ku.5.5.x86_64.rpm A Qt C++ Library for the Last.fm Webservices
liblastfm_fingerprint5-1-32bit-1.0.9+20150206-ku.5.5.x86_64.rpm A Qt C++ Library for the Last.fm Webservices
libmlt++-devel-6.14.0-ku.2.1.i586.rpm Development files for MLT's C++ language API
libmlt++-devel-6.14.0-ku.2.1.x86_64.rpm Development files for MLT's C++ language API
libmlt++3-6.14.0-ku.2.1.i586.rpm C++ library API for the MLT multimedia framework
Advertisement
Advertisement