fcitx-qt5-1.2.2-ku.46.7.x86_64.rpm


Advertisement

Description

fcitx-qt5 - Fcitx QT5 Input Context

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Unstable all
Package filename fcitx-qt5-1.2.2-ku.46.7.x86_64.rpm
Package name fcitx-qt5
Package version 1.2.2
Package release ku.46.7
Package architecture x86_64
Package type rpm
Category System/I18n/Chinese
Homepage https://github.com/fcitx/fcitx-qt5
License GPL-2.0-or-later AND GPL-3.0-or-later AND BSD-3-Clause
Maintainer -
Download size 166.76 KB
Installed size 635.45 KB
A QT5 input context plugin of Fcitx IM Framework.

Alternatives

Package Version Architecture Repository
fcitx-qt5-1.2.2-2.9.x86_64.rpm 1.2.2 x86_64 openSUSE Oss
fcitx-qt5-1.2.2-2.9.i586.rpm 1.2.2 i586 openSUSE Oss
fcitx-qt5-1.2.2-ku.46.7.i586.rpm 1.2.2 i586 KDE Unstable
fcitx-qt5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5DBus.so.5()(64bit) -
libQt5DBus.so.5(Qt_5)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQt5Gui5 = 5.12.3
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libfcitx-config.so.4()(64bit) -
libfcitx-utils.so.0()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libxkbcommon.so.0()(64bit) -
libxkbcommon.so.0(V_0.5.0)(64bit) -

Provides

Name Value
fcitx-qt5 = 1.2.2-ku.46.7
fcitx-qt5(x86-64) = 1.2.2-ku.46.7
libFcitxQt5DBusAddons.so.1()(64bit) -
libFcitxQt5WidgetsAddons.so.1()(64bit) -
libfcitx-quickphrase-editor5.so()(64bit) -
libfcitxplatforminputcontextplugin.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package fcitx-qt5-1.2.2-ku.46.7.x86_64.rpm
Source Package fcitx-qt5-1.2.2-ku.46.7.src.rpm

Install Howto

  1. Add the KDE Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Qt/openSUSE_Tumbleweed/ kde-unstable
  2. Install fcitx-qt5 rpm package:
    # zypper install fcitx-qt5

Files

Path
/usr/lib64/libFcitxQt5DBusAddons.so.1
/usr/lib64/libFcitxQt5DBusAddons.so.1.0
/usr/lib64/libFcitxQt5WidgetsAddons.so.1
/usr/lib64/libFcitxQt5WidgetsAddons.so.1.0
/usr/lib64/fcitx/libexec/fcitx-qt5-gui-wrapper
/usr/lib64/fcitx/qt/libfcitx-quickphrase-editor5.so
/usr/lib64/qt5/plugins/
/usr/lib64/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so
/usr/share/doc/packages/fcitx-qt5/COPYING
/usr/share/locale/ca/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/da/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/de/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/es/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/fr/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/ja/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/ko/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/ru/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/zh_CN/LC_MESSAGES/fcitx-qt5.mo
/usr/share/locale/zh_TW/LC_MESSAGES/fcitx-qt5.mo

Changelog

2018-04-28 - lbeltrame@kde.org
- Add upstream patch fix-compilation-with-qt-5.11.patch:
* Fix compilation with Qt 5.11 (missing include)
2018-02-10 - opensuse@trummer.xyz
- update version 1.2.2
* We already changed reset of code to use "isRelease" for
filterEventFallback. This check should be changed accordingly.
2017-12-02 - i@marguerite.su
- update version 1.2.1
* fix issue #27 and #28
* Add relative rect support
- changes in version 1.2.0
* Relicense platforminputcontext/ to BSD
* do the real unwatch
* prefer to recheck the availability after original service gone
* set display type for fcitx5
* add fcitx 5 format support
* Adapt changes in fcitx5-qt to fix commitPreedit.
* implement compatibility layer for fcitx5
* try to reimplement im module with lgpl free code
* make sure that quickphrae editor does not compile with qt4 header
* move quickphrase editor to fcitx-qt5
- changes in version 1.1.1
* fix high dpi screen position, only happen when you have two
high dpi screen
* use new cmake for package config
* enforce cmake 3.1
* handle the missing password flag
* QInputMethod::update shouldn't be used by input method,
just do query
* workaround some qquickwidget bug
2017-02-11 - i@marguerite.su
- update version 1.1.0
* added guiwrapper for fcitx-qt5
* fix build and add support for webengine
2016-12-03 - i@marguerite.su
- update version 1.0.6
* [qt5]fix inconsistency between qstring and ucs4 string
when handle surrounding
* [qt5]fromUcs4 expect a null terminated string by default,
give it a size
* [qt5]use new connection syntax
* [qt5]use more nullptr
* [qt5]remove usage of QPointer in icdata
* [qt5]don't crash if window->screen() is null
2015-12-23 - i@marguerite.su
- update version 1.0.5
* implement locale in platform context
* use link_directories for widgetaddons
* use the correct var name
* use some c++11 featues and fix ic not get recreated when
fcitx restarts
* clean proxy even it's invalid
2015-08-31 - i@marguerite.su
- update version 1.0.4
* fix the coordinates for high dpi in qt5
2015-07-09 - i@marguerite.su
- update version 1.0.3
* fix build w/ qt 5.5
2015-05-30 - i@marguerite.su
- update version 1.0.2
* fix google code issue 748
* fix dependency check
* fix leak
* use xkbcommon for compose
* install to lib instead of data
2015-04-02 - i@marguerite.su
- update version 1.0.1
* small fix against 1.0.0
- changes from 0.1.3 to 1.0.0
* add COPYING
* use platform name to check x11
* access window function when context destructs is a bad thing
* reorganize fcitx-qt5 library
- changes from 0.1.2 to 0.1.3
* remove debug message
* fix fcitx-qt5 display number resolution
* fix pkg-config file
* use filterEvent instead of x11FilterEvent
* update dbus support
* use new qt5 library name

See Also

Package Description
fcitx-qt5-32bit-1.2.2-ku.46.7.x86_64.rpm Fcitx QT5 Input Context
fcitx-qt5-devel-1.2.2-ku.46.7.i586.rpm Development files for fcitx-qt5
fcitx-qt5-devel-1.2.2-ku.46.7.x86_64.rpm Development files for fcitx-qt5
gammaray-2.10.0-ku.42.1.i586.rpm Introspection/Debugging Tool for Qt Applications
gammaray-2.10.0-ku.42.1.x86_64.rpm Introspection/Debugging Tool for Qt Applications
gammaray-devel-2.10.0-ku.42.1.i586.rpm Introspection/Debugging Tool for Qt Applications
gammaray-devel-2.10.0-ku.42.1.x86_64.rpm Introspection/Debugging Tool for Qt Applications
gnuplot-5.2.6-ku.3.49.i586.rpm Function Plotting Utility and more
gnuplot-5.2.6-ku.3.49.x86_64.rpm Function Plotting Utility and more
gnuplot-doc-5.2.6-ku.3.49.noarch.rpm Documentation of GNUplot
gpgme-1.13.0-ku.3.1.i586.rpm Programmatic library interface to GnuPG
gpgme-1.13.0-ku.3.1.x86_64.rpm Programmatic library interface to GnuPG
grantlee5-32bit-5.1.0-ku.4.1.x86_64.rpm Qt string template library
grantlee5-5.1.0-ku.4.1.i586.rpm Qt string template library
grantlee5-5.1.0-ku.4.1.x86_64.rpm Qt string template library
Advertisement
Advertisement