libKF5Plotting5-5.58.0git.20190413T100124~66eef95-ku.24.5.i586.rpm


Advertisement

Description

libKF5Plotting5 - KDE Data plotting library

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Frameworks Unstable all
Package filename libKF5Plotting5-5.58.0git.20190413T100124~66eef95-ku.24.5.i586.rpm
Package name libKF5Plotting5
Package version 5.58.0git.20190413T100124~66eef95
Package release ku.24.5
Package architecture i586
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 52.81 KB
Installed size 107.79 KB
KPlotWidget is a QWidget-derived class that provides a virtual base
class for data plotting. The idea behind KPlotWidget is that a
developer only has to specify information in "data units", i.e. the
natural units of the data being plotted. KPlotWidget automatically
converts everything to screen pixel units.

Alternatives

Package Version Architecture Repository
libKF5Plotting5-5.58.0git.20190413T100124~66eef95-ku.24.5.x86_64.rpm 5.58.0git.20190413T100124~66eef95 x86_64 KDE Frameworks Unstable
libKF5Plotting5-5.57.0-160.2.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
libKF5Plotting5-5.57.0-160.2.i586.rpm 5.57.0 i586 KDE Frameworks 5
libKF5Plotting5-5.57.0-1.1.x86_64.rpm 5.57.0 x86_64 openSUSE Oss
libKF5Plotting5-5.57.0-1.1.i586.rpm 5.57.0 i586 openSUSE Oss
libKF5Plotting5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.12) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Widgets.so.5 -
libQt5Widgets.so.5(Qt_5) -
libQt5Widgets5 >= 5.12.3
libc.so.6(GLIBC_2.4) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.29) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
libKF5Plotting.so.5 -
libKF5Plotting5 = 5.58.0git.20190413T100124~66eef95-ku.24.5
libKF5Plotting5(x86-32) = 5.58.0git.20190413T100124~66eef95-ku.24.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libKF5Plotting5-5.58.0git.20190413T100124~66eef95-ku.24.5.i586.rpm
Source Package kplotting-5.58.0git.20190413T100124~66eef95-ku.24.5.src.rpm

Install Howto

  1. Add the KDE Frameworks Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Frameworks/openSUSE_Factory/ kde-frameworks-unstable
  2. Install libKF5Plotting5 rpm package:
    # zypper install libKF5Plotting5

Files

Path
/usr/lib/libKF5Plotting.so.5
/usr/lib/libKF5Plotting.so.5.58.0
/usr/share/licenses/libKF5Plotting5/COPYING.LIB

Changelog

2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* Add override
2018-12-15 - Jan Engelhardt <jengelh@inai.de>
- Use noun phrase in summaries.
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* Use isEmpty()
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0
2018-10-16 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-10-15 - lbeltrame@kde.org
- Update to 5.51.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
* No code changes since 5.50.0
2018-09-13 - lbeltrame@kde.org
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None
2018-08-19 - christophe@krop.fr
- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

See Also

Package Description
libKF5Prison5-32bit-5.58.0git.20190413T100323~518b8ec-ku.24.5.x86_64.rpm Barcode abstraction layer library
libKF5Prison5-5.58.0git.20190413T100323~518b8ec-ku.24.5.i586.rpm Barcode abstraction layer library
libKF5Prison5-5.58.0git.20190413T100323~518b8ec-ku.24.5.x86_64.rpm Barcode abstraction layer library
libKF5Pty5-32bit-5.58.0git.20190413T100132~fb6cae3-24.4.x86_64.rpm Interfacing with pseudo terminal devices
libKF5Pty5-5.58.0git.20190413T100132~fb6cae3-24.4.i586.rpm Interfacing with pseudo terminal devices
libKF5Pty5-5.58.0git.20190413T100132~fb6cae3-24.4.x86_64.rpm Interfacing with pseudo terminal devices
libKF5Purpose5-32bit-5.58.0git.20190429T053238~8a76790-ku.62.2.x86_64.rpm Framework to integrate services and actions - core library
libKF5Purpose5-5.58.0git.20190429T053238~8a76790-ku.62.2.i586.rpm Framework to integrate services and actions - core library
libKF5Purpose5-5.58.0git.20190429T053238~8a76790-ku.62.2.x86_64.rpm Framework to integrate services and actions - core library
libKF5PurposeWidgets5-32bit-5.58.0git.20190429T053238~8a76790-ku.62.2.x86_64.rpm Framework to integrate services and actions - GUI library
libKF5PurposeWidgets5-5.58.0git.20190429T053238~8a76790-ku.62.2.i586.rpm Framework to integrate services and actions - GUI library
libKF5PurposeWidgets5-5.58.0git.20190429T053238~8a76790-ku.62.2.x86_64.rpm Framework to integrate services and actions - GUI library
libKF5QuickAddons5-32bit-5.58.0git.20190418T171409~0aab7d2-36.4.x86_64.rpm Integration of QML and KDE workspaces
libKF5QuickAddons5-5.58.0git.20190418T171409~0aab7d2-36.4.i586.rpm Integration of QML and KDE workspaces
libKF5QuickAddons5-5.58.0git.20190418T171409~0aab7d2-36.4.x86_64.rpm Integration of QML and KDE workspaces
Advertisement
Advertisement