libdigikamcore6-6.1.0-197.1.x86_64.rpm


Advertisement

Description

libdigikamcore6 - The main digikam libraries

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Extra all
Package filename libdigikamcore6-6.1.0-197.1.x86_64.rpm
Package name libdigikamcore6
Package version 6.1.0
Package release 197.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/KDE
Homepage http://www.digikam.org/
License GPL-2.0-or-later
Maintainer -
Download size 9.31 MB
Installed size 49.16 MB
The main digikam libraries that are being shared between showfoto and digikam

Alternatives

Package Version Architecture Repository
libdigikamcore6-6.1.0-197.1.i586.rpm 6.1.0 i586 KDE Extra
libdigikamcore6-6.1.0-2.1.x86_64.rpm 6.1.0 x86_64 openSUSE Oss
libdigikamcore6-6.1.0-2.1.i586.rpm 6.1.0 i586 openSUSE Oss
libdigikamcore6-6.0.0git173~1791ffc761-ku.66.1.x86_64.rpm 6.0.0git173~1791ffc761 x86_64 KDE Extra Unstable
libdigikamcore6-6.0.0git173~1791ffc761-ku.66.1.i586.rpm 6.0.0git173~1791ffc761 i586 KDE Extra Unstable
libdigikamcore6 - - -

Requires

Name Value
/sbin/ldconfig -
libKF5AkonadiContact.so.5()(64bit) -
libKF5ConfigCore.so.5()(64bit) -
libKF5ConfigGui.so.5()(64bit) -
libKF5ConfigWidgets.so.5()(64bit) -
libKF5Contacts.so.5()(64bit) -
libKF5CoreAddons.so.5()(64bit) -
libKF5FileMetaData.so.3()(64bit) -
libKF5I18n.so.5()(64bit) -
libKF5IconThemes.so.5()(64bit) -
libKF5KIOWidgets.so.5()(64bit) -
libKF5Notifications.so.5()(64bit) -
libKF5NotifyConfig.so.5()(64bit) -
libKF5Service.so.5()(64bit) -
libKF5Solid.so.5()(64bit) -
libKF5WidgetsAddons.so.5()(64bit) -
libKF5WindowSystem.so.5()(64bit) -
libKF5XmlGui.so.5()(64bit) -
libMagick++-7.Q16HDRI.so.4()(64bit) -
libQt5Concurrent.so.5()(64bit) -
libQt5Concurrent.so.5(Qt_5)(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5DBus.so.5()(64bit) -
libQt5DBus.so.5(Qt_5)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5PrintSupport.so.5()(64bit) -
libQt5PrintSupport.so.5(Qt_5)(64bit) -
libQt5Sql.so.5()(64bit) -
libQt5Sql.so.5(Qt_5)(64bit) -
libQt5WebEngineWidgets.so.5()(64bit) -
libQt5WebEngineWidgets.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5X11Extras.so.5()(64bit) -
libQt5X11Extras.so.5(Qt_5)(64bit) -
libQt5Xml.so.5()(64bit) -
libQt5Xml.so.5(Qt_5)(64bit) -
libQtAV.so.1()(64bit) -
libQtAVWidgets.so.1()(64bit) -
libX11.so.6()(64bit) -
libavcodec.so.58()(64bit) -
libavcodec.so.58(LIBAVCODEC_58)(64bit) -
libavfilter.so.7()(64bit) -
libavfilter.so.7(LIBAVFILTER_7)(64bit) -
libavformat.so.58()(64bit) -
libavformat.so.58(LIBAVFORMAT_58)(64bit) -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libexiv2.so.27()(64bit) -
libexpat.so.1()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgphoto2.so.6()(64bit) -
libgphoto2_port.so.12()(64bit) -
libgphoto2_port.so.12(LIBGPHOTO2_5_0)(64bit) -
libjasper.so.4()(64bit) -
libjpeg.so.8()(64bit) -
libjpeg.so.8(LIBJPEG_8.0)(64bit) -
liblcms2.so.2()(64bit) -
liblensfun.so.1()(64bit) -
liblqr-1.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.27)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libmarblewidget-qt5.so.28()(64bit) -
libopencv_core.so.3.4()(64bit) -
libopencv_imgcodecs.so.3.4()(64bit) -
libopencv_imgproc.so.3.4()(64bit) -
libopencv_objdetect.so.3.4()(64bit) -
libpng16.so.16()(64bit) -
libpng16.so.16(PNG16_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libswscale.so.5()(64bit) -
libswscale.so.5(LIBSWSCALE_5)(64bit) -
libtiff.so.5()(64bit) -

Provides

Name Value
libdigikamcore.so.6.1.0()(64bit) -
libdigikamcore6 = 6.1.0-197.1
libdigikamcore6(x86-64) = 6.1.0-197.1
libdigikamdatabase.so.6.1.0()(64bit) -
libdigikamgui.so.6.1.0()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libdigikamcore6-6.1.0-197.1.x86_64.rpm
Source Package digikam-6.1.0-197.1.src.rpm

Install Howto

  1. Add the KDE Extra repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Extra/openSUSE_Tumbleweed/ kde-extra
  2. Install libdigikamcore6 rpm package:
    # zypper install libdigikamcore6

Files

Path
/usr/lib64/libdigikamcore.so.6.1.0
/usr/lib64/libdigikamdatabase.so.6.1.0
/usr/lib64/libdigikamgui.so.6.1.0
/usr/share/doc/packages/libdigikamcore6/AUTHORS
/usr/share/doc/packages/libdigikamcore6/ChangeLog
/usr/share/doc/packages/libdigikamcore6/NEWS
/usr/share/doc/packages/libdigikamcore6/README.md
/usr/share/licenses/libdigikamcore6/COPYING
/usr/share/licenses/libdigikamcore6/COPYING-CMAKE-SCRIPTS
/usr/share/licenses/libdigikamcore6/COPYING.LIB

Changelog

2019-04-29 - wbauer@tmo.at
- Drop Lower-minimum-exiv2-version.patch, the latest digikam
version just crashes on start with exiv2-0.25 (kde#407022)
2019-04-16 - wbauer@tmo.at
- Update to 6.1.0
* https://www.digikam.org/news/2019-04-14-6.1.0_release_announcement/
- New features (from NEWS):
General     : New plugins interface for digiKam and Showfoto named
dplugins.
General     : All export tools become generic plugins and are
shared with Showfoto.
General     : Update internal libpgf to last 07193.
General     : Add compatiblity with OpenCV version 4.
General     : MacOS and AppImage bundles are now published with Qt
5.11.3.
General     : Add new optional configuration option to compile with
Faces Engine Neural Network.
General     : Add optional support to ImageMagick codecs to support
extra image formats as XCF, FITS, HEIC, etc.
BQM         : Add new advanced settings in resize tool.
BQM         : All Batch Queue Manager tools become Bqm plugins.
Editor      : All Image Editor tools become Editor plugins and are
shared with Showfoto.
Item View   : Add sort items by modification date.
DPlugin     : New plugin to copy items to a local storage.
DPlugin     : New plugin to set image as Linux desktop wallpaper.
- 138 bugs fixed
- Add digikam-devel subpackage
- Add digikam-plugins subpackage that contains all the plugins
- Move plugins' icons to the -plugins subpackage
- Move enblend-enfuse and hugin Recommends to the -plugins package
as the functionality has been moved to the plugins
- Add pkgconfig(Magic++) BuildRequires to enable the new
ImageMagick support
- Add patches to fix build on Leap 42.3:
* Fix-compilation-with-Qt-5.6.patch
* Fix-build-with-QtWebEngine-5.6.patch
- Refresh 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch

See Also

Package Description
libdivecomputer-0.6.0-5.15.i586.rpm Library for communication with dive computers
libdivecomputer-0.6.0-5.15.x86_64.rpm Library for communication with dive computers
libdivecomputer-devel-0.6.0-5.15.i586.rpm Development package for libdivecomputer
libdivecomputer-devel-0.6.0-5.15.x86_64.rpm Development package for libdivecomputer
libdivecomputer0-0.6.0-5.15.i586.rpm Library of libdivecomputer
libdivecomputer0-0.6.0-5.15.x86_64.rpm Library of libdivecomputer
libdrumstick-alsa1-1.1.2-26.10.i586.rpm MIDI Sequencer C++ Library
libdrumstick-alsa1-1.1.2-26.10.x86_64.rpm MIDI Sequencer C++ Library
libdrumstick-devel-1.1.2-26.10.i586.rpm Development package for the libdrumstick library
libdrumstick-devel-1.1.2-26.10.x86_64.rpm Development package for the libdrumstick library
libdrumstick-doc-1.1.2-26.10.noarch.rpm Development documentation package for the drumstick libraries
libdrumstick-file1-1.1.2-26.10.i586.rpm MIDI Sequencer C++ Library
libdrumstick-file1-1.1.2-26.10.x86_64.rpm MIDI Sequencer C++ Library
libdrumstick-rt-plugins-1.1.2-26.10.i586.rpm MIDI Sequencer C++ Library
libdrumstick-rt-plugins-1.1.2-26.10.x86_64.rpm MIDI Sequencer C++ Library
Advertisement
Advertisement