libKF5Contacts5-19.07.70git.20190430T054927~d35fbbd6-104.1.x86_64.rpm


Advertisement

Description

libKF5Contacts5 - KDE Frameworks based address book API

Property Value
Distribution openSUSE Tumbleweed
Repository KDE Applications Unstable all
Package filename libKF5Contacts5-19.07.70git.20190430T054927~d35fbbd6-104.1.x86_64.rpm
Package name libKF5Contacts5
Package version 19.07.70git.20190430T054927~d35fbbd6
Package release 104.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 390.33 KB
Installed size 1.33 MB
kcontacts is a Qt5 based library which provides an API
to access address book data stored in different formats.

Alternatives

Package Version Architecture Repository
libKF5Contacts5-19.07.70git.20190430T054927~d35fbbd6-104.1.i586.rpm 19.07.70git.20190430T054927~d35fbbd6 i586 KDE Applications Unstable
libKF5Contacts5-19.04.0-118.2.x86_64.rpm 19.04.0 x86_64 KDE Applications 5
libKF5Contacts5-19.04.0-118.2.i586.rpm 19.04.0 i586 KDE Applications 5
libKF5Contacts5-19.04.0-1.1.x86_64.rpm 19.04.0 x86_64 openSUSE Oss
libKF5Contacts5-19.04.0-1.1.i586.rpm 19.04.0 i586 openSUSE Oss
libKF5Contacts5 - - -

Requires

Name Value
/sbin/ldconfig -
libKF5Codecs.so.5()(64bit) -
libKF5ConfigCore.so.5()(64bit) -
libKF5CoreAddons.so.5()(64bit) -
libKF5I18n.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -

Provides

Name Value
kcontacts = 19.07.70git.20190430T054927~d35fbbd6
libKF5Contacts.so.5()(64bit) -
libKF5Contacts5 = 19.07.70git.20190430T054927~d35fbbd6-104.1
libKF5Contacts5(x86-64) = 19.07.70git.20190430T054927~d35fbbd6-104.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libKF5Contacts5-19.07.70git.20190430T054927~d35fbbd6-104.1.x86_64.rpm
Source Package kcontacts-19.07.70git.20190430T054927~d35fbbd6-104.1.src.rpm

Install Howto

  1. Add the KDE Applications Unstable repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Unstable:/Applications/KDE_Unstable_Frameworks_openSUSE_Factory/ kde-applications-unstable
  2. Install libKF5Contacts5 rpm package:
    # zypper install libKF5Contacts5

Files

Path
/usr/lib64/libKF5Contacts.so.5
/usr/lib64/libKF5Contacts.so.5.11.44
/usr/share/licenses/libKF5Contacts5/COPYING.LIB

Changelog

2018-11-20 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-11-20 - lbeltrame@kde.org
- Update to 18.11.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.11.80.php
- Changes since 18.08.3:
* QT_NO_NARROWING_CONVERSIONS_IN_CONNECT is defined in kf5.51
* Complete the dependency list, matters for static builds
* Make KContacts work in static builds
* Add a new ISO 3166 code to country name mapping table
* Unbreak the char encoding for Android
* Attempt to fix the Windows build
* Restore Qt 5.9 compatibility
* Add CLDR-based country to ISO code mapping
* Fix translation of country names
* Use new syntax
2018-11-08 - lbeltrame@kde.org
- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2
2018-10-11 - lbeltrame@kde.org
- Update to 18.08.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.2.php
- Changes since 18.08.1:
* None
2018-09-06 - lbeltrame@kde.org
- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None
2018-08-16 - christophe@krop.fr
- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
2018-07-26 - lbeltrame@kde.org
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Cache country <-> ISO code mapping in both directions
* Load the address formatting rules only once
* Fix country detection from QLocale
* Don't rely on address formatting data from kdelibs4support
* Put the countrytransl.map file into a Qt resource
* Use Q_REQUIRED_RESULT
* Fix countryToISO() returning the local country for unknown country names
* Remove unused D-Bus dependency
2018-07-13 - lbeltrame@kde.org
- Update to 18.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.3.php
- Changes since 18.04.2:
* None
2018-06-08 - lbeltrame@kde.org
- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None
2018-05-11 - lbeltrame@kde.org
- Update to 18.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.1.php
- Changes since 18.04.0:
* None

See Also

Package Description
libKF5Contacts5-32bit-19.07.70git.20190430T054927~d35fbbd6-104.1.x86_64.rpm KDE Frameworks based address book API
libKF5EventViews5-19.07.70git.20190422T102850~c2f7251-ku.117.3.i586.rpm Eventviews Library
libKF5EventViews5-19.07.70git.20190422T102850~c2f7251-ku.117.3.x86_64.rpm Eventviews Library
libKF5GrantleeTheme5-19.07.70git.20190426T133423~b25ad59-ku.73.3.i586.rpm GrantleeTheme library for kdepim
libKF5GrantleeTheme5-19.07.70git.20190426T133423~b25ad59-ku.73.3.x86_64.rpm GrantleeTheme library for kdepim
libKF5Gravatar5-19.07.70git.20190418T070033~3462067-ku.83.4.i586.rpm Libgravatar library for kdepim
libKF5Gravatar5-19.07.70git.20190418T070033~3462067-ku.83.4.x86_64.rpm Libgravatar library for kdepim
libKF5IMAP5-19.07.70git.20190426T133411~c81aecf-ku.91.3.i586.rpm KDE PIM Libraries: IMAP APIs
libKF5IMAP5-19.07.70git.20190426T133411~c81aecf-ku.91.3.x86_64.rpm KDE PIM Libraries: IMAP APIs
libKF5IdentityManagement5-19.07.70git.20190426T133416~f71f4ddf-96.2.i586.rpm KDE PIM Libraries: Identity Management - core library
libKF5IdentityManagement5-19.07.70git.20190426T133416~f71f4ddf-96.2.x86_64.rpm KDE PIM Libraries: Identity Management - core library
libKF5IncidenceEditor5-19.07.70git.20190418T065802~74ec10f-122.3.i586.rpm Incidenceeditor Library
libKF5IncidenceEditor5-19.07.70git.20190418T065802~74ec10f-122.3.x86_64.rpm Incidenceeditor Library
libKF5KDcraw5-19.07.70git.20181127T115410~7cc73de-ku.15.14.i586.rpm Shared library interface around dcraw
libKF5KDcraw5-19.07.70git.20181127T115410~7cc73de-ku.15.14.x86_64.rpm Shared library interface around dcraw
Advertisement
Advertisement